Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

kernm23
***
Beiträge: 74
Registriert: Mi, 16.07.2014 15:54

Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von kernm23 » Mi, 12.09.2018 11:48

ich suche eine Formel die mir die Spalte B im Tabellenblatt 1 ausfüllt mit einem Text aus Tabellenblatt 2, wenn der Eintrag in Spalte A der beiden Tabellen identisch ist. Sollte keine Übereinstimmung vorliegen, soll das Feld in der Spalte B leer bleiben.

Hat jemand einen Tipp?

vgl. das vereinfachte Beispiel im Anhang
Dateianhänge
Formel_fuer_SpalteB_Tab1.ods
(8.19 KiB) 37-mal heruntergeladen

Mondblatt24
*****
Beiträge: 266
Registriert: So, 14.05.2017 16:11

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von Mondblatt24 » Mi, 12.09.2018 12:32

Hallo,
da nicht zu erkennen ist ob Du mit AOO oder Libre Office arbeitest, hier zwei Versionen der Formel.
Formel_fuer_SpalteB_Tab1.ods
(12.08 KiB) 40-mal heruntergeladen
und noch eine Formel:

Code: Alles auswählen

=Wennfehler(SVERWEIS(A2;Tabelle2.$A$2:$B$11;2;0);"")
BG Peter
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

paljass als Gast

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von paljass als Gast » Mi, 12.09.2018 12:57

...oder - auch für AOO und LO

Code: Alles auswählen

=WENN(ZÄHLENWENN($Tabelle2.$A$2:$A$20;A2);SVERWEIS(A2;$Tabelle2.$A$2:$B$20;2;0);"")
Gruß
paljass

kernm23
***
Beiträge: 74
Registriert: Mi, 16.07.2014 15:54

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von kernm23 » Mi, 12.09.2018 13:23

Ich arbeite mit OpenOffice. Müssen die beiden Tabellen sortiert sein? Wenn ja, beide nach FeldA?

kernm23
***
Beiträge: 74
Registriert: Mi, 16.07.2014 15:54

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von kernm23 » Mi, 12.09.2018 13:31

Verwende AOO 4.1.5.

bisher hat´s mit oben genannten Formeln bei meiner Echt-Tabelle noch nicht geklappt.

kernm23
***
Beiträge: 74
Registriert: Mi, 16.07.2014 15:54

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von kernm23 » Mi, 12.09.2018 15:08

hiermit hat´s jetzt geklappt: =WENN(ZÄHLENWENN($Tabelle2.$A$2:$A$20;A2);SVERWEIS(A2;$Tabelle2.$A$2:$B$20;2;0);"")

wofür steht die 2 und die 0 am Ende im SVERWEIS-Befehl?

datensätze habe ich vorher nicht sortiert. scheint keine Rolle zu spielen, oder?

paljass
******
Beiträge: 686
Registriert: Do, 25.10.2012 07:25

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von paljass » Mi, 12.09.2018 16:10

Hi,
wofür steht die 2 und die 0 am Ende im SVERWEIS-Befehl?
datensätze habe ich vorher nicht sortiert. scheint keine Rolle zu spielen, oder?
OO 4.1.5 wird mit Hilfe-Datei ausgeliefert. Hast du da mal reingeguckt?

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

Antworten