Stunden zählen [Gelöst]

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Tiger
Beiträge: 3
Registriert: Sa, 22.09.2018 14:34

Stunden zählen [Gelöst]

Beitrag von Tiger » Sa, 22.09.2018 15:12

Erstmal ein "Hallo" in die Runde,

ich habe mir eine Tabelle erstellt um den Lohn und die Zuschläge zu berechnen, mit Arbeitszeit von-bis, Pausenzeiten von-bis, es funktioniert alles soweit außer das die erste Stunde von 05:00 bis 06:00 Uhr nicht gezählt wird. Vielleicht könnte von euch jemand sich das mal anschauen. Ich stehe auf dem Schlauch und komme nicht weiter. :roll:

Formel

Code: Alles auswählen

=MAX(0;MIN(O$2+(O$2>P$2);$D18+($C18>$D18))-MAX(O2;$C18))+MAX(0;(MIN(P$2;$D18+($C18>$D18))-$C18)*(O$2>P$2))+MAX(0;MIN(P$2+(O$2>P$2);$D18+0)-O$2)*($C18>$D18)
stundenlohn-zuschläge.ods
(17.55 KiB) 19-mal heruntergeladen
std-zaehlen.jpg
std-zaehlen.jpg (153.53 KiB) 457 mal betrachtet
Zuletzt geändert von Tiger am Sa, 22.09.2018 19:07, insgesamt 1-mal geändert.

Gast

Re: Stunden zählen

Beitrag von Gast » Sa, 22.09.2018 15:44

Servus,

dieser Teile liefert eine -Zahl.

Code: Alles auswählen

=MIN(O$2+(O$2>P$2);$D18+($C18>$D18))-MAX(O2;$C18)

Gast

Tiger
Beiträge: 3
Registriert: Sa, 22.09.2018 14:34

Re: Stunden zählen

Beitrag von Tiger » Sa, 22.09.2018 16:02

Wenn ich da was ändere passiert nichts. Und wenn es eine andere Möglichkeit gibt die Stunden in den Zeitbereichen zu Zählen, immer her damit, ich bin für alles offen, zb. zählenwenn.

Tiger
Beiträge: 3
Registriert: Sa, 22.09.2018 14:34

Re: Stunden zählen

Beitrag von Tiger » Sa, 22.09.2018 19:06

Habe das Problem gelöst, in Zelle M4 & O4 ist eine andere Formel enthalten als in Zelle K4.

Zelle K4:

Code: Alles auswählen

=WENN(C18*D18;MAX(0;MIN(L$2+(K$2>L$2);$D18+($C18>$D18))-MAX(K$2;$C18))+MAX(0;(MIN(L$2;$D18+($C18>$D18))-$C18)*(K$2>L$2))+MAX(0;MIN(L$2+(L$2>L$2);$D18+0)-K$2)*($C18>$D18);0)
Zelle M4:

Code: Alles auswählen

=WENN(C18*D18;MAX(0;MIN(N$2+(M$2>N$2);$D18+($C18>$D18))-MAX(M$2;$C18))+MAX(0;(MIN(N$2;$D18+($C18>$D18))-$C18)*(M$2>N$2))+MAX(0;MIN(N$2+(M$2>N$2);$D18+0)-M$2)*($C18>$D18);0)
Zelle O4:

Code: Alles auswählen

=WENN(C18*D18;MAX(0;MIN(P$2+(O$2>P$2);$D18+($C18>$D18))-MAX(O$2;$C18))+MAX(0;(MIN(P$2;$D18+($C18>$D18))-$C18)*(O$2>P$2))+MAX(0;MIN(P$2+(O$2>P$2);$D18+0)-O$2)*($C18>$D18);0)
stundenlohn-zuschläge-neu.ods
(17.5 KiB) 11-mal heruntergeladen

Antworten