ZÄHLENWENN(Bereich;"^^^^^")

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

erikafuchs
*****
Beiträge: 445
Registriert: Di, 13.02.2007 17:38
Wohnort: Büttelborn

ZÄHLENWENN(Bereich;"^^^^^")

Beitrag von erikafuchs » So, 30.09.2018 15:05

Hallo zusammen!
ich muss in Spalten Zellen zählen in denen "^^^^^" steht, das funktioniert nur, wenn ich in den Einstellungen reguläre Ausdrücke in Formeln erlaube. Mein Programm muss aber auch bei Nutzern funktionieren bei denen diese Einstellung nicht vorgenommen wurde.
Hat jemand eine Idee?
Pit

Lupo1
****
Beiträge: 145
Registriert: Sa, 13.10.2012 10:36

Re: ZÄHLENWENN(Bereich;"^^^^^")

Beitrag von Lupo1 » So, 30.09.2018 16:25

=ZÄHLENWENN(E1:E6;"*^^^^^^*") zählt auch die ^^^^^^, die nur Teilstrings sind.
MfG Lupo - LO5462+LO6062 Win10Pro

erikafuchs
*****
Beiträge: 445
Registriert: Di, 13.02.2007 17:38
Wohnort: Büttelborn

Re: ZÄHLENWENN(Bereich;"^^^^^")

Beitrag von erikafuchs » So, 30.09.2018 18:18

@lupo1
hilft mir das weiter?

Lupo1
****
Beiträge: 145
Registriert: Sa, 13.10.2012 10:36

Re: ZÄHLENWENN(Bereich;"^^^^^")

Beitrag von Lupo1 » So, 30.09.2018 19:35

Da Du eine mögliche Lösung im Betreff stehen hast, verstehe ich nicht, was Du sonst noch willst.
MfG Lupo - LO5462+LO6062 Win10Pro

mikeleb
******
Beiträge: 722
Registriert: Fr, 09.12.2011 16:50

Re: ZÄHLENWENN(Bereich;"^^^^^")

Beitrag von mikeleb » So, 30.09.2018 20:55

Hallo Pit,
das funktioniert nur, wenn ich in den Einstellungen reguläre Ausdrücke in Formeln erlaube
Das wundert mich, denn es müsste genau anders herum sein. Mit aktivierten regulären Ausdrücken sollte "^^^^^" gerade nicht gefunden werden.
Nimm anstelle von Zählenwenn() die Funktion Summenprodukt(), die nicht auf reguläre Ausdrücke reagiert.

Code: Alles auswählen

=SUMMENPRODUKT(A1:A20="^^^^^")
Gruß,
mikeleb

Helmut_S
**
Beiträge: 44
Registriert: So, 29.10.2017 11:29

Re: ZÄHLENWENN(Bereich;"^^^^^")

Beitrag von Helmut_S » So, 30.09.2018 21:07

Hallo erikafuchs, Dein erster Satz im Eingangspost stimmt nicht. Wenn die zu untersuchenden Zellen nur die gesuchten Zeichen enthalten, kann/muss die Option "Reguläre Ausdrücke in Formeln ermöglichen AUSgeschaltet sein. Sollten die gesuchten Zeichen aber als Teilstring enthalten sein, musst du in den Optionen "Platzhalter in Formeln ermöglichen" einschalten. Ein Stern in der Formel zählenwenn(Bezug;"*^^^^^") genügt und es spielt keine Rolle ob er am Anfang oder am Ende steht. Zumindest bei mir mit LO 6.1.2 funktioniert es so.
Schau dir die Tabelle an. Mit wenigen Mausklicks kannst du alles nachvollziehen.

Gruß, Helmut
Edit: Da hab ich was übersehen, daher Tabelle entfernt.
Zuletzt geändert von Helmut_S am Di, 02.10.2018 11:50, insgesamt 1-mal geändert.
openSUSE Leap 15.0 / Linux Mint 18.3 / Win 10-64
LO 6.1.2

erikafuchs
*****
Beiträge: 445
Registriert: Di, 13.02.2007 17:38
Wohnort: Büttelborn

Re: ZÄHLENWENN(Bereich;"^^^^^")

Beitrag von erikafuchs » So, 30.09.2018 22:53

Das wundert mich, denn es müsste genau anders herum sein. Mit aktivierten regulären Ausdrücken sollte "^^^^^" gerade nicht gefunden werden.
... stimmt! Aber wie dem auch sei - da ich die Einstellung auf fremden Computern nicht ändern kann, funktioniert es hier - und dort nicht. Ich habe jetzt ein Makro ergänzt, dass die Zellen mit "^^^^^^^" zählt. Das "*" hilft mir auch nicht, es handelt sich nicht um Teilstrings.
Trotzdem vielen Dank!

erikafuchs
*****
Beiträge: 445
Registriert: Di, 13.02.2007 17:38
Wohnort: Büttelborn

Re: ZÄHLENWENN(Bereich;"^^^^^")

Beitrag von erikafuchs » So, 30.09.2018 22:57

... aber das mit dem Summenprodukt scheint zu klappen!

Antworten