Übersichtseite mit Tabellennamen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

lars.bln
Beiträge: 3
Registriert: Fr, 30.11.2018 14:26

Übersichtseite mit Tabellennamen

Beitrag von lars.bln » Fr, 30.11.2018 14:54

Hallo allerseits,
ich möchte gerne auf der ersten Tabelle einer Arbeitsmappe eine Übersicht mit den Tabellennamen der übrigen angelegten Tabellenblätter erzeugen.
Die Übersicht sollte sich aktualisieren wenn ein weiteres Tabellenblatt angelegt wird.
Bisher hab ich bei meiner Suche nur eine Lösung für EXCEL unter Verwendung eines bordeingenen Makros (ARBEITSMAPPE.ZUORDNEN) gefunden:

Zunächst einen Name definieren über Menü Einfügen - Name
Name: x
Bezieht sich auf: =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
Dann in der Übersichtsseite in irgendeine Zelle:
=WENN(ZEILE(A1)>ANZAHL2(x);"";HYPERLINK("#'"&INDEX(x;ZEILE(A1))&"'!A1";TEIL(INDEX(x;ZEILE(A1));FINDEN("]";INDEX(x;ZEILE(A1)))+1;31)))

Da meine bisherigen Kenntnisse recht übersichtlich sind war es mir leider nicht möglich das ganze selbst zu übertragen :/

Ich freue mich über jede Hilfe!
Liebe Grüße
Lars

paljass
******
Beiträge: 686
Registriert: Do, 25.10.2012 07:25

Re: Übersichtseite mit Tabellennamen

Beitrag von paljass » Fr, 30.11.2018 17:08

Hallo Lars,
ich hab hier vor einiger Zeit mal diesen Code gefunden:

Code: Alles auswählen

Function NameAusIndex(tabellenindex)
  On Error Resume Next
  blatt = ThisComponent.Sheets.getByIndex(tabellenindex).Name
  NameAusIndex = blatt
End Function
Also - Funktion erstellen (unter Extras - Makro) und in der ersten Zeile aufrufen mit

Code: Alles auswählen

=NAMEAUSINDEX(ZEILE(A1)-1)
. Die Formel kannst du nach unten kopieren.

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

lars.bln
Beiträge: 3
Registriert: Fr, 30.11.2018 14:26

Re: Übersichtseite mit Tabellennamen

Beitrag von lars.bln » Mo, 03.12.2018 10:06

Funktioniert. Dankeschön =)

Habe mich jetzt noch versucht zu erreichen daraus auch direkt einen Hyperlink zur entsprechenden Tabelle zu machen.... wie ihr euch denken könnt ohne erfolg :/
Vielleicht habt ihr noch einmal rat für mich?!

paljass
******
Beiträge: 686
Registriert: Do, 25.10.2012 07:25

Re: Übersichtseite mit Tabellennamen

Beitrag von paljass » Mo, 03.12.2018 12:44

Hi,

Code: Alles auswählen

=HYPERLINK("#"&NAMEAUSINDEX(ZEILE(A1)-1)&".A1";NAMEAUSINDEX(ZEILE(A1)-1))
Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

lars.bln
Beiträge: 3
Registriert: Fr, 30.11.2018 14:26

Re: Übersichtseite mit Tabellennamen

Beitrag von lars.bln » Fr, 07.12.2018 11:10

Nochmals vielen Dank! ...ick fühl mir jeholfen ;)

Antworten