[gelöst] Calc Wenn Berechnung funktioniert nich

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

dödel
Beiträge: 4
Registriert: Mo, 14.01.2019 20:17

[gelöst] Calc Wenn Berechnung funktioniert nich

Beitrag von dödel » Mo, 14.01.2019 20:25

Hallo,

folgendes Problem:
ich habe drei Tabellen, die miteinander verknüpft sind:

=WENN(ZEILE(A25)-23<$Berechnung.D$42+1;INDIREKT(VERKETTEN("Arbeitszeiterfassung!Q";VERGLEICH(VERKETTEN("Fort";ZEILE(A25)-23);$Arbeitszeiterfassung.T$1:T$104;0)));" ")

hier klappt die Verknüpfung bzw Berechnung und hier leider nicht:

=WENN(ZEILE(A25)-23<$Berechnung.D$21+1;INDIREKT(VERKETTEN("Arbeitszeiterfassung!Q";VERGLEICH(VERKETTEN("AUS";ZEILE(A25)-23);$Arbeitszeiterfassung.T$1:T$104;0)));" ")

Ich bekomme den Fehler #Name?

Hat jemand eine Idee, woran es liegen könnte? Es handelt sich um eine aus Exel importierte Datei :-(
Zuletzt geändert von dödel am Mi, 16.01.2019 07:10, insgesamt 2-mal geändert.

mikeleb
******
Beiträge: 791
Registriert: Fr, 09.12.2011 16:50

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von mikeleb » Mo, 14.01.2019 21:02

Hallo,
Es handelt sich um eine aus Exel importierte Datei
offensichtlich
Beide funktionieren nicht!
Du musst das Ausrufezeichen nach "Arbeitszeiterfassung" gegen einen Punkt austauschen!

Code: Alles auswählen

=WENN(ZEILE(A25)-23<$Berechnung.D$21+1;INDIREKT(VERKETTEN("Arbeitszeiterfassung.Q";VERGLEICH(VERKETTEN("AUS";ZEILE(A25)-23);$Arbeitszeiterfassung.T$1:T$104;0)));" ")
Gruß,
mikeleb

Gast

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von Gast » Di, 15.01.2019 09:36

Vielen Dank für die schnelle Antwort!

Leider funktioniert die Lösung nicht. Wenn ich das "!" durch den "." ersetze, erhalte ich den Fehler #REF! :(

Mondblatt24
*****
Beiträge: 412
Registriert: So, 14.05.2017 16:11

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von Mondblatt24 » Di, 15.01.2019 12:09

Hallo,
Gast hat geschrieben:
Di, 15.01.2019 09:36
Leider funktioniert die Lösung nicht. Wenn ich das "!" durch den "." ersetze, erhalte ich den Fehler #REF! :(
Dann erstelle doch bitte eine Beispieldatei, damit es nachvollziehbar wird.

Gruß Peter
Win.10 (x64)__ LO 6.2.4 (x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden. Anleitung

Gast

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von Gast » Di, 15.01.2019 19:50

Hallo,
hier sich die Beispieldatei: https://www.file-upload.net/download-13 ... t.ods.html
Im Reiter Prüfung ist alles super im Reiter Ausbildung funktioniert es leider nicht :(

dödel
Beiträge: 4
Registriert: Mo, 14.01.2019 20:17

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von dödel » Di, 15.01.2019 19:55

So, jetzt noch mal im ganzen Satz:

Die Beispieldatei befindet sich hier:

https://www.file-upload.net/delete-13471011/vukof5.html

Im Reiter Prüfung ist alles super. Im Reiter Ausbildung funktioniert es leider nicht :( Probiert mit LO 5)

mikeleb
******
Beiträge: 791
Registriert: Fr, 09.12.2011 16:50

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von mikeleb » Di, 15.01.2019 20:08

Hallo,
die Fehlerursache liegt in der (ausgeblendeten) Tabelle "Berechnung". Dort ist ein fehlerhafter Bezug, der sich dann fortpflanzt.
Ergänzung: Da in deinem Dokument unter Calc-Option ->Formel ->Detaillierte Einstellungen für Berechnungen -> Bezügesyntax für Zeichenkettenbezug "Excel A1" gewählt ist, funktioniert in deine Formeln das "!" anstelle des "." in den Indirekt()-Formeln.
Gruß,
mikeleb

dödel
Beiträge: 4
Registriert: Mo, 14.01.2019 20:17

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von dödel » Di, 15.01.2019 21:57

Dazu zwei Fragen:
1. wie blende ich die (ausgeblendeten) Tabelle "Berechnung" ein? - Diesen Teil habe ich schon selbst gelöst: auf die Reiter , dann rechte Maustaste: Tabelle einblenden
2. wo genau befindet sich der fehlerhafter Bezug?

mikeleb
******
Beiträge: 791
Registriert: Fr, 09.12.2011 16:50

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von mikeleb » Di, 15.01.2019 22:39

Hallo,
wo genau befindet sich der fehlerhafter Bezug?
ernsthaft? In der Zelle, in der anstatt "Aus" eine Fehlermeldung steht!
Gruß,
mikeleb

dödel
Beiträge: 4
Registriert: Mo, 14.01.2019 20:17

Re: Calc Wenn Berechnung funktioniert nicht

Beitrag von dödel » Mi, 16.01.2019 07:06

Vielen Dank!

Antworten