zellen addieren wenn text

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Neu
Beiträge: 4
Registriert: So, 31.03.2019 13:46

zellen addieren wenn text

Beitrag von Neu » So, 31.03.2019 15:15

Hallo ich bin neu hier und hoffe das mir jemand weiter helfen kann.

Ich habe eine Ausgabentabelle in der, wenn eine zelle durch ein "x" gelb wird in einer anderen zelle der Wert steht.
beispiel:


C29 steht der wert 20€
D29 bis O29 wird durch bedingte formatierung wenn ich dort ein "x" reinschreibe die jeweilige zelle gelb markiert
in P29 steht folgende formel:

=WENN(D29="X";C29+WENN(E29="X";C29+WENN(F29="X";C29+WENN(G29="X";C29+WENN(H29="X";C29+WENN(I29="X";C29+WENN(J29="X";C29+WENN(K29="X";C29+WENN(L29="X";C29+WENN(M29="X";C29+WENN(N29="X";C29+WENN(O29="X";C29;""))))))))))))

wenn ich ein "x" in D29 schreibe steht in P29 20€
wenn ich ein "x" in E29 schreibe steht in P29 40€ usw. bis O29
das klappt soweit mit dem berechnen

das klappt aber nur wenn in D29 ein "x" steht
wenn ich in zelle E29 anfange mit dem "x" dann bleibt P29 auf 0
Wenn ich in D29 bis O29 überall ein "x" schreibe steht in P29 240€ also 12x 20€
sobald ich aber das "x" NUR in zelle D29 entferne funktionieren die anderen zellen auch nicht mehr und in P29 steht wieder 0

Ich weiß keine Lösung mehr
habe schon mehrere formeln ausprobiert
vieleicht kann mir jemand hier weiter helfen

Gruß

Mondblatt24
*****
Beiträge: 403
Registriert: So, 14.05.2017 16:11

Re: zellen addieren wenn text

Beitrag von Mondblatt24 » So, 31.03.2019 15:17

Hallo,
geht doch.
Versuch diese Formel:

Code: Alles auswählen

=ZÄHLENWENN(D29:O29;"X")*C29
Gruß Peter
Win.10 (x64)__ LO 6.2.4 (x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden. Anleitung

Neu
Beiträge: 4
Registriert: So, 31.03.2019 13:46

Re: zellen addieren wenn text

Beitrag von Neu » So, 31.03.2019 15:24

Super Dankeschön
manchmal hat man keine Ideen mehr

Auf jedenfall klappt es
Daumen hoch :-)

Neu
Beiträge: 4
Registriert: So, 31.03.2019 13:46

Re: zellen addieren wenn text

Beitrag von Neu » So, 31.03.2019 17:20

Hallo
ich hoffe das Thema passt hier rein

ich müsste noch eine lösung haben

habe in spalte C also C3 bis C36 verschiedene summen stehen
und und spalte D also D3 bis D36 schreibe ich ein "x" rein wenn die Jeweilige summe gebraucht wird

wenn ich nun in D3 ein "x" schreibe möchte ich das in D37 die Summe von C3 steht
Wenn ich dann zusätzlich ein "x" in D4 schreibe möchte ich das in D37 die summen aus C3 und C4 addiert werden
und das soll für alle zellen bis C36 so sein

hoffe ich habe es einigermaßen erklären können

Gruß

Mondblatt24
*****
Beiträge: 403
Registriert: So, 14.05.2017 16:11

Re: zellen addieren wenn text

Beitrag von Mondblatt24 » So, 31.03.2019 17:35

Hallo,
hier ist bestimmt was für Deine Zwecke dabei.
http://www.ooowiki.de/SummeWenn.html#Be ... rtebereich

Gruß Peter
Win.10 (x64)__ LO 6.2.4 (x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden. Anleitung

Neu
Beiträge: 4
Registriert: So, 31.03.2019 13:46

Re: zellen addieren wenn text

Beitrag von Neu » So, 31.03.2019 17:50

Super Danke
hat alles geklappt wie ich es wollte :-)

Gruß

Antworten