Darstellung von Umlauten bei writer/web

Ein einfacher HTML-Editor

Moderator: Moderatoren

depadu
*
Beiträge: 10
Registriert: Di, 12.01.2010 20:22

Darstellung von Umlauten bei writer/web

Beitrag von depadu »

Sonderzeichen und Umlaute werden durch Zeichenketten ersetzt Bsp: #überblick statt Überblick.
Wie wird wieder ein lesbarer Text dargestellt?
Hiker
*****
Beiträge: 464
Registriert: Mo, 08.09.2014 21:34
Wohnort: Berlin

Re: Darstellung von Umlauten bei writer/web

Beitrag von Hiker »

Das ist lesbarer Text. Es wurde wohl nur "vergessen" dem Programm zu sagen, dass das UTF8 ist.
Dann gilt oft eine Annahme, für einen Systemzeichensatz/ANSI etc. - aber das muss ja nicht immer stimmen

Ich nehme aus Erfahrung mal an, dass Du unter Windows arbeitest... (Unter Linux/MacOS ist die "Annahme" UTF8 duchaus verbreitet ) Bei Windows kannst Du mir dem Begrif Codepage für Zeichensatz beim Suchen weiterkommen...
Libre Office 6.3.1 (Win 10 Pro) / Libre Office 6.0.7 (Win8.1 Pro, Win 7 Pro) / AOO (Win 7)
depadu
*
Beiträge: 10
Registriert: Di, 12.01.2010 20:22

Re: Darstellung von Umlauten bei writer/web

Beitrag von depadu »

Formuliere ich meine Frage anders: Wie stelle ich in OO den Zeichensatz um, entweder beim Bearbeiten oder beim Laden?
Nachtrag: Die Zeichen stehen im utf-Format. Aber: wenn ich bei Extra, Einstellungen, Laden&Speicehrn\html-kompatibibilität Zeichensatz auf utf8 umstelle, passiert nichts. Warum?
depadu
*
Beiträge: 10
Registriert: Di, 12.01.2010 20:22

Re: Darstellung von Umlauten bei writer/web

Beitrag von depadu »

Nachtrag: Alles ist noch schlimmer.
Wenn ich also die html öffne die deutsche Umlaute enthält, wird statt der Umlaute der UTF-Kode angezeigt. Ist nichts neues. Aber wenn ich die Datei erst im browser öffne wird die Datei normal angezeigt. Öffne ich die Datei mit oo, lösche die Kommentare oder eine Zeile, schließe sie dann und öffne sie anschließend wieder im browser, versteht auch der Browser nur noch Bahnhof und zeigt auch nur noch den utf kode an. Habe mir den HEX-Kode angesehen. Stand ursprünglich für ä 26 23 32 32 38 3b wurde daraus c3 a4. Wenn das keine Fehler ist. Um das als Fehler zu melden, müßte man sich anmelden; geht aber nicht.
Zuletzt geändert von depadu am Mi, 20.10.2021 23:18, insgesamt 1-mal geändert.
Hiker
*****
Beiträge: 464
Registriert: Mo, 08.09.2014 21:34
Wohnort: Berlin

Re: Darstellung von Umlauten bei writer/web

Beitrag von Hiker »

Was denn wirklich in Deinen Dateien steht, weisst ja nur Du selbst. Daher kann man Dir mit der derzeitigen Datenlage kaum helfen. Viele Nutzer dürfte die Web-Komponente nicht haben.

Allgemein gilt, dass Du einem Browser via Meta-Tag am Anfang der Seite mitteilen kannst, welcher Zeichensatz benutzt wird.
https://www.w3schools.com/tags/att_meta_charset.asp

Danach musst Du noch dafür sorgen, dass die Angabe auch stimmt.

Mfg, Jörn
Libre Office 6.3.1 (Win 10 Pro) / Libre Office 6.0.7 (Win8.1 Pro, Win 7 Pro) / AOO (Win 7)
depadu
*
Beiträge: 10
Registriert: Di, 12.01.2010 20:22

Re: Darstellung von Umlauten bei writer/web

Beitrag von depadu »

Brauchst du die Dateien vorher, nachher? Die vorher ist aus dem Netz.
cwolan
**
Beiträge: 23
Registriert: Sa, 06.03.2021 12:56

Re: Darstellung von Umlauten bei writer/web

Beitrag von cwolan »

Einfache Prüfung:

Webseite "AOO 4.1.11 Release Notes (de)"
https://cwiki.apache.org/confluence/pag ... =191333357

Ich habe diese Webseite im html-Format gespeichert.
Die .html Datei enthält Tags: <html lang="en-US" > und <meta charset="UTF-8">

LibO 7.1.6.2 en-US + de (Sprachpaket)
AOO 4.1.11 en-US + de (Sprachpaket)

Der Zeichensatz in beiden Fällen — unter 'Laden/Speichern - HTML-Kompatibilität' — ist "Osteuropäisch (Windows-1250/Winlatin 2)".

Die Datei geöffnet in LibO ---> OK.
Die Datei geöffnet in AOO ---> Problem mit Umlauten etc.
(dasselbe Ergebnis mit dem Zeichensatz "UTF-8").

siehe Anhang:
Screenshots.jpg
Screenshots.jpg (341.34 KiB) 106 mal betrachtet
Win. 7, 10 (x64) ▪ LO 7.1.6.2 ▪ AOO 4.1.11 und einige ältere Versionen
Stephan
********
Beiträge: 12317
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Darstellung von Umlauten bei writer/web

Beitrag von Stephan »

Um das als Fehler zu melden, müßte man sich anmelden; geht aber nicht.
Ich sehe was Du meinst, und habe deshalb an die dev-Liste von AOO geschrieben. Ich gebe Bescheid was ich als Antwort erhalte.


Gruß
Stephan
Stephan
********
Beiträge: 12317
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Darstellung von Umlauten bei writer/web

Beitrag von Stephan »

Ich habe auf der Mailingliste die Auskunft bekommen das ein selbstständiges Registrieren bei Bugzilla, wegen des Spamaufkommens, abgeschaltet ist. Du müsstest Dich wegen der Registrierung an die dev-Liste des Projekts wenden: http://openoffice.apache.org/mailing-li ... ist-public


Gruß
Stephan
Antworten