Format Benutzerfeld

Das Textverarbeitungsprogramm

Moderator: Moderatoren

Udo187
Beiträge: 5
Registriert: Fr, 18.11.2022 10:54

Format Benutzerfeld

Beitrag von Udo187 »

Hallo!

Folgendes Problem: Ich verwende eine Vorlage, die mehrere Benutzerfelder enthält.
Ein Feld davon hat ein Zeitformat, es wird aus meiner Datenquelle die Zeit korrekt übernommen, im Format hh:mm:ss
Wie kann ich das Feld formatieren, damit im Dokument nur hh:mm dargestellt werden?
Mein Versuch, das Format direkt beim Feld zu ändern (Einfügen - Feldbefehl - Andere, Benutzerfeld -> Format) schlägt fehl, da dann der Bezug zum Feld verloren geht (es steht dann beim Wert 0).

Danke für Tipps!

Gruß
Udo
F3K Total
********
Beiträge: 3621
Registriert: Mo, 28.02.2011 17:49

Re: Format Benutzerfeld

Beitrag von F3K Total »

Moin,
ein Bild sagt mehr ...
FB.png
FB.png (50.82 KiB) 418 mal betrachtet
Gruß R
Udo187
Beiträge: 5
Registriert: Fr, 18.11.2022 10:54

Re: Format Benutzerfeld

Beitrag von Udo187 »

Danke für die Antwort!

Genau das habe ich auch versucht, es geht dann aber der Bezug zum Feld verloren (Wert = 0):

Ohne Zeitformat - Feld "BB_Termin_Zeit_Von" = "BB_Termin_Zeit_Von" bleibt in den Feldeigenschaften auch stehen:

oo01.JPG
oo01.JPG (53.28 KiB) 364 mal betrachtet

Im Dokument bzw. PDF wird dann der korrekte Wert aus der Datenquelle übernommen (10:15:00, aber leider mit Sekunden dargestellt):

oo02.JPG
oo02.JPG (15.23 KiB) 364 mal betrachtet

Wenn das Format auf Zeit geändert wird, geht der Bezug zum Feld bzw. der Datenquelle verloren: (Wert = 0)

oo03.JPG
oo03.JPG (59.83 KiB) 364 mal betrachtet
oo04.JPG
oo04.JPG (48.66 KiB) 364 mal betrachtet

Im Dokument wird das Feld nicht mehr befüllt:

oo05.JPG
oo05.JPG (14.25 KiB) 364 mal betrachtet
Mondblatt24
******
Beiträge: 950
Registriert: So, 14.05.2017 16:11

Re: Format Benutzerfeld

Beitrag von Mondblatt24 »

Hallo,
schalte mal Menü Ansicht → Feldnamen (Strg+F9) ab.

Gruß
Peter
Win 11 (x64) ▪ LO 7.3.7.2 (x64) ▪ AOO Portable 4.1.13
Wurde die Frage zutreffend beantwortet bitte den Betreff der Eingangsfrage mit [GELÖST] ergänzen. Beschreibung
Udo187
Beiträge: 5
Registriert: Fr, 18.11.2022 10:54

Re: Format Benutzerfeld

Beitrag von Udo187 »

habe ich versucht - ändert aber nichts an der Problematik, dass das Feld mit der Zeitformatierung den Bezug verliert.
F3K Total
********
Beiträge: 3621
Registriert: Mo, 28.02.2011 17:49

Re: Format Benutzerfeld

Beitrag von F3K Total »

Tja,
es scheint wohl so zu sein, dass dein Benutzerfeld aus der Datenquelle einen Text und kein Datumswert bekommt. Also bereits in der Datenquelle falsch formatiert ist.
Gruß R
Udo187
Beiträge: 5
Registriert: Fr, 18.11.2022 10:54

Re: Format Benutzerfeld

Beitrag von Udo187 »

Danke für den Hinweis mit dem Datumsformat.
Ich habe die Datenquelle nochmals geprüft - es ist definitiv ein Datumsformat:

oo06.JPG
oo06.JPG (24.24 KiB) 308 mal betrachtet

Dein Hinweis mit dem Textformat brachte mich aber auf eine andere Fehlerquelle - der Code zum übertragen der Feldwerte.

Die Datenquelle ist HCL Notes, Auszug aus dem Code:


oo8.JPG
oo8.JPG (47.91 KiB) 308 mal betrachtet


Ich denke, hier werden alle Datenformate in Text umgewandelt, was dann den Fehler beim Datums/Zeitformat erklären würde.

Wenn dem so ist - wie kann ich die Datenformate beibehalten?
F3K Total
********
Beiträge: 3621
Registriert: Mo, 28.02.2011 17:49

Re: Format Benutzerfeld

Beitrag von F3K Total »

Moin,
du füllst die Textfelder also nicht herkömmlich über eine angemeldete Datenquelle sondern per Makro?
Wende dich am Besten an den Hersteller der Software.
R
Udo187
Beiträge: 5
Registriert: Fr, 18.11.2022 10:54

Re: Format Benutzerfeld

Beitrag von Udo187 »

Danke an alle für die Antworten!

Meine Lösung schaut nun folgendermaßen aus:
In der Datenquelle wurde ein neues (Hilfs-) Feld hinzugefügt, dass mir den benötigten Wert als Text berechnet (Zeit ohne Sekunden) und dieses Feld übertrage ich dann ins Open Office.

Gruß Udo
Antworten