AOO 3.4.1 portable auf CD?

Antwort erstellen


Um automatische Eingaben zu unterbinden, musst du die nachfolgende Aufgabe lösen.

BBCode ist eingeschaltet
[img] ist ausgeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind ausgeschaltet

Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: AOO 3.4.1 portable auf CD?

Re: AOO 3.4.1 portable auf CD?

von noch'n Gast » Fr, 15.03.2013 19:06

balu hat geschrieben:Wie hattest Du das OOo-Benutzerverzeichnis ins Root-Verzeichnis hinbekommen? Wie lautete die dementsprechende Zeile in der bootstrap.ini?
Das sind genaugenommen zwei Paar Schuhe.
Wie lautete die dementsprechende Zeile in der bootstrap.ini?
Der Eintrag in der Bootini steht in meinem damaligen Thread direkt vor deinem Zitat ($ORIGIN/..). Und davor steht, dass es damit aber nicht funktioniert. Dh. erstellen kann OOo es dort nicht, und es wird auch nicht erkannt, wenn es dort liegt. Auf schreibgeschützten Medien kann es ohnehin nicht erstellt werden.

Grundsätzlich funktioniert das ganze aber, wenn z.B. OOo in einem Unterverzeichnis angelegt wird oder zumindest das User-Verzeichnis in einem Unterverzeichnis steht. Auf LW H: würde also funktionieren H:\AOO\user. Dabei ist es egal, ob die übrigen AOO-Ordner direkt in H: abgelegt sind oder ebenfalls in H:\AOO. Probleme gibt es nur mit H:\user und darin dann die Ordner (also ohne die durch eure Vorgaben entstandene Doppelung user\user).
Wie hattest Du das OOo-Benutzerverzeichnis ins Root-Verzeichnis hinbekommen?
Wie auch von Stephan beschrieben:
Stephan hat geschrieben: Ich hatte auf Festplatte nach E:\AOO_341\ installiert und anschließend, nachdem ich die Anpassung in bootstrap.ini gemacht habe, einmal von Festplatte gestartet und wieder beendet und nun den Inhalt von E:\AOO_341\ in die Wurzel der CD gebrannt.
Mit meiner Anpassung hasst du dann auf der Festplatte als user-Ordner E:\AOO_341\user und auf dem CD/USB/SD Laufwerk E:\user.

Grundsätzlich kannst du es auf beschreibbaren Medien auch einfach dahin kopieren und dann den Pfad in der Bootstrap.ini anpassen. OOo erstellt ja nur ein neues Verzeichnis, wenn es an der angegebenen Stelle keins findet.

Stephans Problem mit der CD löst das aber offenbar alles nicht und darum ging es ja eigentlich im Thread.

Bei PortableApps kommen sie auch nur lapidar zu dem Schluss, dass es mit CD nicht mehr funktioniert und sie auch keine Lust haben, sich weiter damit zu beschäftigen, weil nach ihrer Ansicht die CD ausgestorben ist und alle mit USB-Sticks arbeiten und damit geht's ja.

Re: AOO 3.4.1 portable auf CD?

von balu » Mi, 13.03.2013 20:33

Hallo noch'n Gast,
noch'n Gast hat geschrieben:
balu hat geschrieben:Wir reden hie von der bootstrap.ini. Und das ist keine Haarspalterei, sondern extrem wichtig zu unterscheiden.
Und eben weil hier die ganze Zeit davon geredet wird, wundere ich mich, dass du von meiner Antwort so irritiert bist.
Ganz genau genommen reden wir lediglich über eine Zeile in der Bootstrap.ini und die dort verwendeten Parameter.
Nicht nur ich, sondern auch andere können dann wohl schon mal ins schleudern kommen, wenn auf einmal von einer anderen Datei die Rede ist. Und wenn es sich dabei fast namentlich um eine Systemgeschütze Datei handelt (Boot.ini), dann sieht die Welt noch anders aus. Das es sich bei dir um einen Tipfähler handelte, war mir schon fast klar, aber sicherheitshalber hatte ich dennoch darauf hingewiesen. Lassen wir es jetzt bitte dabei.

noch'n Gast hat geschrieben:
balu hat geschrieben:
noch'n Gast hat geschrieben:Läuft nicht, wenn der User Ordner im Rootverzeichnis der SD liegt
Das wird doch auch gar nicht gemacht. Wieso kommst Du darauf das zu machen?
Zum Beispiel so:
[...]
Da ich auf der SD Karte bequem etwas ausprobieren kann, ohne immer eine CD zu verbraten zu müssen, habe ich einfach mal Schreibfehler ausprobiert, Fehlermeldungen provoziert, etc.
Und hier ist ein Punkt wo Du etwas falsch verstanden hast. Es ging mir nich darum das Du eine Speicherkarte genommen hattest um CD-Rohlinge zu sparen, ich arbeite halt mit einem Virtuellen Laufwerk, sondern mir ging es darum: "Warum Du den Ordner user ins Rootverzeichnis verschoben hattest?"


Verzeih, aber das folgende ist nicht bös gemeint und es gibt nur das wieder was dabei raus kommt.
Du hattest deinen Beitrag am Fr, 08.03.2013 mit einem Zitat von Stephan begonnen, ihn aber nicht speziell angesprochen weder mit Hallo noch dem @. Und im weiteren Verlauf war ich mir nun mal halt nicht sicher an wen Du dich speziel gewendet hattest. Da kam es dann bei mir halt zu der Frage, welche Fehlermeldung denn nun gemeint war, denn schließlich waren ja zweie geäußert worden. Aber nun gut, das ist ja jetzt auch geklärt.

noch'n Gast hat geschrieben: Ja, Forenthreads sind oft mühsam, aber war das für einen kundigen Helfer wie dich wirklich so schwer zu verstehen?
Du sagst es, mühsam (aber nicht immer). Und wenn man dann Beiträge liest die nicht eindeutig Bezug auf jemanden, oder etwas, nehmen, dann kommt man schon mal ins Stolpern und Missverständnisse sind vorprogrammiert. Dabei spielt es dann auch keine Rolle mehr ob man ein kundiger Helfer ist, oder nicht. Zumal ich ja bis zu diesem Tage sehr viel Zeit in dies Thema investiert hatte, und zwar so viel, das es mich wahrlich bis in meine Träume verfolgt hatte.


Zurück zum eigentlichem Thema hier.

Was mir jetzt aber grad eben noch mal in deinem Beitrag vom Fr, 08.03.2013 aufgefallen ist, ist das folgende.
noch'n Gast hat geschrieben: Anscheinend mag Windows oder OOo es nicht, wenn das OOo-Benutzerverzeichnis im Root-Verzeichnis steht. Dann kommt die Fehlermeldung es sei ein Fehler aufgetreten während OOo versucht hat die Einstellungen für die Benutzeroberfläche zu laden.
Wie hattest Du das OOo-Benutzerverzeichnis ins Root-Verzeichnis hinbekommen? Wie lautete die dementsprechende Zeile in der bootstrap.ini?

Denn wenn man nicht wirklich weiss was die Einträge in der Zeile UserInstallation= bedeuten und bewirken, dann bleiben solche Fehlermeldungen eben nicht aus. Auch wenn wir heutzutage mit einer Grafischen Benutzeroberfläche arbeiten, so ist es in diesem Falle von Vorteil, wenn man gewisses Kentnisse über DOS-Befehle (oder ähnliches bei Linux) und deren Wirkung hat.


Schön das Du ein Thread bei portableapps zu diesem Thema hier gefunden hast, doch da muss ich leider mangels meiner Englischkentnisse aussteigen.



Gruß
balu

Re: AOO 3.4.1 portable auf CD?

von balu » Mi, 13.03.2013 20:21

Hallo -x-,
balu hat geschrieben: Sorry, aber ich seh momentan den Wald vor lauter Bäumen nicht mehr.
Falsch!
Ich hatte Tomaten auf den Augen!
Danke x, ich habs jetzt gefunden. Und durch den download von dort kann ich jetzt auch das hier bestätigen.
Gast (freedom) hat geschrieben: Bei AOO-Portable haben sie den vollständigen Pfad genommen:
Aber aus diversen Gründen hatte ich mich jetzt auch nicht weiter darum gekümmert, und auch keine weiteren tests durchgeführt.



Gruß
balu

Re: AOO 3.4.1 portable auf CD?

von noch'n Gast » Mi, 13.03.2013 18:37

balu hat geschrieben:Nenn sie einfach Steuerzeichen.
Hm. Ich vermute dann wäre trotzdem die Nachfrage gekommen "Was meinst du mit Steuerzeichen", "Welche Steuerzeichen meinst du" oder ähnliches. Lassen wir das einfach mal so auf sich beruhen.
balu hat geschrieben:
noch'n Gast hat geschrieben:Bootini geändert
So eine Datei gibt es nicht!
Naja, wenn man es nun wirklich ganz pingelig nimmt: http://de.wikipedia.org/wiki/Boot.ini
balu hat geschrieben:Wir reden hie von der bootstrap.ini. Und das ist keine Haarspalterei, sondern extrem wichtig zu unterscheiden.
Und eben weil hier die ganze Zeit davon geredet wird, wundere ich mich, dass du von meiner Antwort so irritiert bist.
Ganz genau genommen reden wir lediglich über eine Zeile in der Bootstrap.ini und die dort verwendeten Parameter.
(der Vollständigkeit halber: mit Rootini meinte ich ebenfalls die Bootstrap.ini, war ein Flüchtigkeitsfehler)

Mehr zum Thema: http://wiki.openoffice.org/wiki/Uno/Bin ... tstrapping
balu hat geschrieben:
noch'n Gast hat geschrieben:Läuft nicht, wenn der User Ordner im Rootverzeichnis der SD liegt
Das wird doch auch gar nicht gemacht. Wieso kommst Du darauf das zu machen?
Zum Beispiel so:
balu hat geschrieben:Da ich ja nicht weiss wie das Verzeichnis bei dir aussieht, ich meine in welcher Ebene befindest sich das AOO in der Root, oder in der x-ten Ebene, kann ich auch nicht sagen ob da vielleicht ein Problem entstehen kann. Und ferner ob es vielleicht Leerzeichen oder deutsche Umlaute beinhaltet.
Stephan hat geschrieben:Mmmh, riecht nach Schreibfehler und wenn ich es nachkontrolliere ist es auch Einer. der richtige Pfad in der Fehlermeldung ist also der von Dir Genannte.
balu hat geschrieben:
Stephan hat geschrieben:den Inhalt von E:\AOO_341\ in die Wurzel der CD gebrannt.
Ich hatte wohl das Verzeichnis E:\AOO_341\ -{ja, Laufwerk und Verzeichnisname existiert auch bei mir}- "gebrannt" und nicht nur den Inhalt
Da ich auf der SD Karte bequem etwas ausprobieren kann, ohne immer eine CD zu verbraten zu müssen, habe ich einfach mal Schreibfehler ausprobiert, Fehlermeldungen provoziert, etc. Aber wäre Neugierde nicht völlig ausreichend?

balu hat geschrieben:Mehr nicht? Nur "ein interner Fehler"? Wenn schon eine Fehlermeldung genannt wird, dann doch bitte schön vollständig und am besten so das man sie sofort eindeutig erkennen kann.
Da du selbst oben bereits geschrieben hattest:
balu hat geschrieben:Ich bekam auch eine Fehlermeldung zu Gesicht, diese lautete aber:
OpenOffice.org 3.4.1 - Fatal Error hat geschrieben:Die Anwendung kann nicht gestartet werden.
Ein interner Fehler ist aufgetreten.
war ich wohl fälschlich davon ausgegangen, dass sie dir bekannt vorkommt.

Grundsätzlich hast du natürlich recht, und ich fand ebenso wie du, dass Stephan in seinem Anfangspost ruhig die Fehlermeldung hätte nennen können.
Welche Fehlermeldung kannst Du reproduzieren, die erste von Stephan oder von mir?
Die von Stephan. Auch hier dachte ich, "Eingangs" ist eindeutig, war aber wohl falsch gedacht.

Ja, Forenthreads sind oft mühsam, aber war das für einen kundigen Helfer wie dich wirklich so schwer zu verstehen?


freedom hat geschrieben:Habe geschaut, was portableapps.com sagt zum Thema Live-CD.
Dazu habe ich folgendes gefunden:
http://portableapps.com/node/36420
Beschreibt also den gleichen Fehler, den Stephan und Balu auch schon bekommen haben.

Gastfreundliche Grüße

Re: AOO 3.4.1 portable auf CD?

von -x- » Sa, 09.03.2013 00:44

Ich habe AOO Portable von der AOO-Hauptseite.
gib mir bitte den Link, wo ich die Portable von AOO downloaden kann.
Die Heimatseite von ApacheOpenoffice ist hier:
http://www.openoffice.org/de/
Dort steht:
"Download"
"Aktuelle Version von von Apache"
"Aktuelle portable Version (externer Link zu winPeckPack)"

Re: AOO 3.4.1 portable auf CD?

von balu » Sa, 09.03.2013 00:31

Hallo freedom,
Ich habe AOO Portable von der AOO-Hauptseite.
Sorry, aber ich seh momentan den Wald vor lauter Bäumen nicht mehr. Deshalb gib mir bitte den Link, wo ich die Portable von AOO downloaden kann.

Deine Reaktionen auf meinen vorherigen Beitrag zeige mir,
dass du mich im Wesentlichen nicht richtig verstanden hast.
Ich muss mich sehr schlecht, unklar, oder ä. ausgedrückt haben.
Ich weiss jetzt nicht mehr ob ich dich falsch verstanden habe, oder nicht. Aber das Du hier LO-Portableapps in den Raum geworfen hattest, fand ich als keine so gute Idee. Denn das passt einfach hier nicht rein. Selbst das normale LO und das Portableapps-LO kann man auf keinen Fall miteinander vergleichen, wenn es um die Pfade geht, dafür sind sie einfach in dieser Hinsicht defenitiv zu unterschiedlich.

Ich hab jetzt Heierabend.



Gruß
balu

Re: AOO 3.4.1 portable auf CD?

von Gast » Fr, 08.03.2013 22:18

Wer!? Und wo downloaden?
na, derjenige, der AOOPortable gemacht hat.
Ich habe AOO Portable von der AOO-Hauptseite.

Deine Reaktionen auf meinen vorherigen Beitrag zeige mir,
dass du mich im Wesentlichen nicht richtig verstanden hast.
Ich muss mich sehr schlecht, unklar, oder ä. ausgedrückt haben.

freedom

Re: AOO 3.4.1 portable auf CD?

von balu » Fr, 08.03.2013 22:01

Hallo

@noch'n Gast
Ja, aber trotz Wiki-Link weiß ich immer noch nicht, wie ich die sonst nennen soll ..
Nenn sie einfach Steuerzeichen. Denn der Punkt (.), und zwei Punkte (..) und auch der Backslash (\) bzw der Slash (/) steuern wo hin man den Pfad ändern möchte.

Bootini geändert
So eine Datei gibt es nicht!
Wir reden hie von der bootstrap.ini. Und das ist keine Haarspalterei, sondern extrem wichtig zu unterscheiden.

Läuft nicht, wenn der User Ordner im Rootverzeichnis der SD liegt
Das wird doch auch gar nicht gemacht. Wieso kommst Du darauf das zu machen?

Benenne ich einfach den Pfad um, kommt die Fehlermeldung es sei ein interner Fehler aufgetreten weswegen OOo nicht gestartet werden kann.
Mehr nicht? Nur "ein interner Fehler"? Wenn schon eine Fehlermeldung genannt wird, dann doch bitte schön vollständig und am besten so das man sie sofort eindeutig erkennen kann.


Die Eingangs von dir genannte Fehlermeldung kann ich reproduzieren, wenn ich in der Bootini ein Leerzeichen in den Pfad gebe also "/Fix /Daten" oder den Pfad komplett auskommentiere.
Welche Fehlermeldung kannst Du reproduzieren, die erste von Stephan oder von mir?




@Gast (freedom)
Habe geschaut, was portableapps.com sagt zum Thema Live-CD.
Da es dort schon lange kein OO gibt, bezieht sich das auf LO.
Stephan hat geschrieben: Es geht mir ausschließlich um AOO 3.4.1
Ist das so schwer zu verstehen?

Klar, ihr meint OO und selbst portable gamacht.
Nein! Wir reden hier von ApacheOpenOffice, kurz AOO, und nicht von OO.

Vermutlich macht es im Prinzip für Live-CD keinen Unterschied.
Möcht ich nicht für Wetten. Denn selbst wenn es hier um OOo gehen würde, und dafür noch eine dementsprechende Portableapps-Versionen gibt, so wäre das schon ein Unterschied. Weil nämlich die Portableapps-Versionen von z.B. OOo ein wenig mehr aufbereitet wurde als nur die bootstrap.ini.

Es wundert mich, dass von der Anpassung der botstrap.ini keine Rede ist
Mich nicht. Siehe oben.

Ich würde daraus schließen, dass die Pfadangabe in botstrap.ini wie in der Portable Version sein soll
Um Gottes willen blos nicht!!!
Denn die Verzeichnisstruktur der Portableapps-Versionen unterscheiden sich doch sehr stark von den Normalen Versionen. Und die bootstrap.ini liegt im Unterverzeichnis PROGRAMM. Und von dort aus wird dann das Verzeichnis gewechselt. Jedoch liegt das Unterverzeichnis PROGRAMM bei der normalen Version nicht an der gleichen Stelle wie bei der Portableapps-Versionen. Und das sollte man auf gar keinen Fall nie-nicht vergessen und/oder verwechseln!

Bei AOO-Portable haben sie den vollständigen Pfad genommen:
Wer!? Und wo downloaden?



Gruß
balu

Re: AOO 3.4.1 portable auf CD?

von Gast » Fr, 08.03.2013 20:13

Hallo,

ich weiß nicht, ob euch das in irgendeiner Weist nüzt:

Habe geschaut, was portableapps.com sagt zum Thema Live-CD.
Da es dort schon lange kein OO gibt, bezieht sich das auf LO.
Klar, ihr meint OO und selbst portable gamacht. Vermutlich macht es im Prinzip für Live-CD keinen Unterschied.

Es wundert mich, dass von der Anpassung der botstrap.ini keine Rede ist, sondern nur:

Code: Alles auswählen

Starten von CD (LibreOffice Portable Live)

LibreOffice Portable unterstützt das Starten von CD. 
Dazu beginnen Sie mit dem Laden des Installationspakets aus dem Internet und der Installation auf Ihrer Festplatte ... 
dabei ist es egal, wo.
 Starten Sie es einmal, um die Standardeinstellungen für den Benutzer zu generieren. Passen Sie dann alles so an, wie Sie wollen und stellen Sie dabei sicher, dass Sie keine der kritischen Dateien wie LibreOfficePortable.exe verschieben oder löschen. Brennen Sie dann das ganze LibreOfficePortable Verzeichnis auf eine CD und Sie Sie sind bereit loszulegen.
Ich würde daraus schließen, dass die Pfadangabe in botstrap.ini wie in der Portable Version sein soll - was mich wundert.

Beispiel bei mir botstrap.ini für ein original LO-Portable:

Code: Alles auswählen

UserInstallation=$ORIGIN/../../../Data/settings
Bei AOO-Portable haben sie den vollständigen Pfad genommen:

Code: Alles auswählen

UserInstallation=file:///D:/Programm/AOO-P-3.4.1/User/ApacheOpenOffice
freedom

Re: AOO 3.4.1 portable auf CD?

von noch'n Gast » Fr, 08.03.2013 17:50

Stephan hat geschrieben:die zwei Punkte bedeuten ganz einfach einen WEchsel ins übergeordnete Verzeichnis bei relativer Pfadadressierung und sind nur nötig wenn tatsächlich ins überrgeordnete Verzeichnis' 'gesprungen 'werden soll.
Ja, aber trotz Wiki-Link weiß ich immer noch nicht, wie ich die sonst nennen soll ..

Der Kern meiner Aussage war ja mehr, dass ich mich an Probleme bezüglich Punkte da/nicht da erinnere.
Die Erinnerung trog leider etwas. Tatsächlich bekomme ich eine Fehlermeldung, wenn hinter den Punkten nichts weiter steht (also $ORIGIN/..). Anscheinend mag Windows oder OOo es nicht, wenn das OOo-Benutzerverzeichnis im Root-Verzeichnis steht. Dann kommt die Fehlermeldung es sei ein Fehler aufgetreten während OOo versucht hat die Einstellungen für die Benutzeroberfläche zu laden.

Ich habe jetzt mal auf einer SD-Card getestet, die ich nach dem kopieren auf Schreibschutz geschaltet habe.
Portable AOO-Version auf übliche und von euch beiden ebenso beschriebene Weise erstellt.
Bootini geändert in $ORIGIN/../Daten
AOO von Festplatte gestartet, geschlossen inkl. Schnellstarter und die Programm-Ordner+Einzeldateien aus dem AOO-Verzeichnis auf die SD kopiert
Schreibschutz rein
Ins AOO-Programverzeichnis und Soffice.exe gestartet
Läuft

Läuft nicht, wenn der User Ordner im Rootverzeichnis der SD liegt (s.o.)
Läuft, wenn der Ordner ohne .. direkt benannt wird
Läuft wenn ich den Ordner umbenenne in "/Fix/Daten" und die Rootini entsprechend anpasse

Benenne ich einfach den Pfad um, kommt die Fehlermeldung es sei ein interner Fehler aufgetreten weswegen OOo nicht gestartet werden kann.

Die Eingangs von dir genannte Fehlermeldung kann ich reproduzieren, wenn ich in der Bootini ein Leerzeichen in den Pfad gebe also "/Fix /Daten" oder den Pfad komplett auskommentiere.

Vielleicht hilft es bei der Fehlersuche

Re: AOO 3.4.1 portable auf CD?

von balu » Fr, 08.03.2013 13:59

Hallo Stephan,

okay, Thema "doppeltes user" ist abgehakt.

Stephan hat geschrieben: den Inhalt von E:\AOO_341\ in die Wurzel der CD gebrannt.
Ich hatte wohl das Verzeichnis E:\AOO_341\ -{ja, Laufwerk und Verzeichnisname existiert auch bei mir}- "gebrannt" und nicht nur den Inhalt, aber nach einen eben durchgeführten Test mit nur den Inhalt des Verzeichnis konnte ich keine negative Änderung feststellen. Kurz: AOO startet bei mir im Virtuellem Laufwerk

Stephan hat geschrieben:
vielleicht klappts ja dann bei dir auch.
Ist das Andeutung dessen das es bei Dir, auf anderem Weg, klappt?
Bei mir funktioniert es nur, wenn ich mit der Festplatte und nicht mit USB-Stick arbeite. Und das ist mir nicht nur ein Rätsel, sondern ein Buch mit 7 Siegeln.

Stephan hat geschrieben: Dann würde ich Dich bitten Deinen Weg in detaillierter Form aufzuschreiben, also konkret benutze Pfade usw., damit ich das möglichst exakt nachvollziehen kann.
Du willst es detailliert? Oh je!

Also denne.
Apache_OpenOffice_incubating_3.4.1_Win_x86_install_de.exe auf Laufwerk D downloaden (ist meine einzige Interne Festplatte mit 4 Partitionen; C - F).

Die gedownloadete Datei ausführen, aber nicht den vorgegeben Pfad

Code: Alles auswählen

C:\BenutzerProfile\Name\Desktop\OpenOffice.org 3.4.1 (de) Installation Files
zum extrahieren akzeptieren, sondern einen anderen eingestellt. -{BenutzerProfile ist normalerweise "Dokumente und Einstellungen", habe ich mal in meinem System so geändert}-
Der Pfad wo hin nun extrahiert werden soll, lautet:

Code: Alles auswählen

D:\ApacheOpenOffice.org_341_Installation_Files
An gegebener Stelle die Installation abbrechen

Windows Startbutton -> Ausführen -> Zum eben genannten Verzeichnis navigieren und dort die Setup.exe auswählen. Anschließend in der Komandozeile noch das /a anhängen und das Setup mit Klick auf OK starten (*). Ja ich weiss das Du das kennst. Aber Du wolltest es detailliert :wink:.

Wenn die Aufforderung zur Verzeichnisauswahl kommt, eins eingeben oder auswählen. In unserem Falle lautet das Verzeichnis auf der Festplatte also E:\AOO_341. Anschließend auf OK klicken.

Wenn Setup fertig ist, in das Verzeichnis E:\AOO_341\program wechseln und die bootstrap.ini ändern. Die Änderung speichern.

Im Verzeichnis E:\AOO_341\program die soffice.exe ausführen.

Wenn AOO gestartet ist, mal eben in den Optionen den Schnellstarter deaktivieren.

AOO beenden.

Den Schnellstarter im Info-Bereich neben der Uhr Beenden. Muss gemacht werden, da ja sonst AOO nicht wirklich ausm Arbeitsspeicher entfernt wurde.

Brennprogramm starten und dort das Verzeichnis E:\AOO_341 zum Brennen in das dementsprechende Fenster, oder was auch immer, rüberziehen.
- Da ich ja nicht wirklich brenne, sondern ein ISO-Image erstelle, gehe ich im Brennprogramm den dementsprechenden Weg zum Image erstellen. Und nach erfolgtem erstellen beende ich das Brennprogramm.

In meinem Dateimanager rechtsklick auf das Virtuelle Laufwerk H: von VirtuelCloneDrive, und lade mir das eben erstellte ISO-Image.

Nun kann ich im Virtuellen Laufwerk H: in das Unterverzeichnis \programm wechseln und dort die soffice.exe ausführen. AOO wird wie erwartet gestartet.

Das AOO auch wirklich von einem nicht beschreibbaren Datenträger (Virtuelles Laufwerk) startet, sehe ich daran das ich wohl Änderungen in den Optionen vornehmen kann, z.B. das aktivieren von "Sicherungskopien immer erstellen", diese Option aber nach beenden und erneutem starten von AOO wieder deaktiviert ist. Mit anderen Worten, die Einstellungen können nicht gespeichert werden.


So! So viel dazu.

(*)
Da ich ja mit einem anderen Dateimanager arbeite, Idoswin Pro 5.67, war mir etwas besonderes aufgefallen was aber nur bei mir hier zutrifft.
Wenn ich also Idoswin aktiv habe und das Setup mit /a ausführen will, bekomme ich eine Fehlermeldung/Warnhinweis/was auch immer, und zwar von Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161.
MS-Visual.png
MS-Visual.png (9.74 KiB) 14226 mal betrachtet
Mehr ist nicht zu sehen. Und da ich nicht weiss was das ganze soll, gehe ich auf Cancel und breche das Setup zur sicherheit ab. Dann beende ich Idoswin und führe Setup erneut aus.

Warum ich das jetzt hier erwähne?
Weil ich nicht weis ob Du vielleicht eine andere, ältere/neuere Versionsnummer von Microsoft Visual C++ 2008 Redistributable hast und dein Problem vielleicht damit zusammenhängt. Auch wenn es vielleicht nichts damit was zu tun hat, so ist es ja wohl nicht verkehrt das mal zu erforschen.

Hier mal alle Versionen von Microsoft Visual C++ die bei mir installiert sind.
MS-Visual_alle_Versionen.png
MS-Visual_alle_Versionen.png (8.85 KiB) 14226 mal betrachtet

Mit welchem Betriebssystem arbeitest Du denn?

Ach ja, wollte ich sowieso noch Fragen: Brennst Du wirklich auf CD, oder arbeitest Du auch mit einem Virtuellen Laufwerk?



Gruß
balu

Re: AOO 3.4.1 portable auf CD?

von Stephan » Fr, 08.03.2013 10:51

Warum habe ich zweimal user, während Du nur einmal user hast?
Mmmh, riecht nach Schreibfehler und wenn ich es nachkontrolliere ist es auch Einer. der richtige Pfad in der Fehlermeldung ist also der von Dir Genannte.
Ich kann dir jetzt nur noch folgendes empfehlen zu testen, vielleicht klappts ja dann bei dir auch.
Führe das Setup auf der Festplatte aus, und installiere auch auf der Festplatte in ein Verzeichnis, z.B. E:\Office_auf_CD, und nicht auf einen USB-Stick.
Das hatte ich bereits getan, denn Deine Schrittfolge enthielt keine besondere Anweisung dazu. Ich hatte auf Festplatte nach E:\AOO_341\ installiert und anschließend, nachdem ich die Anpassung in bootstrap.ini gemacht habe, einmal von Festplatte gestartet und wieder beendet und nun den Inhalt von E:\AOO_341\ in die Wurzel der CD gebrannt.
vielleicht klappts ja dann bei dir auch.
Ist das Andeutung dessen das es bei Dir, auf anderem Weg, klappt?

Dann würde ich Dich bitten Deinen Weg in detaillierter Form aufzuschreiben, also konkret benutze Pfade usw., damit ich das möglichst exakt nachvollziehen kann. Zwar ist nicht sicher das das dann auch bei mir klapppt weil es immer noch genügend Unwägbarkeiten gibt, aber ich würde es zumindest mal probieren wollen, denn ich habe derzeitig keine bessere Idee.


Gruß
Stephan

P.S.
Ich habe jetzt auch einen Thread auf der Mailingliste:
http://www.openoffice.org/de/about-ooo/ ... glist.html

eröffnet (der Betreff ist "AOO 3.4.1 auf CD brennen"). Ich werde berichten wenn sich dort eine Lösung ergibt.

Re: AOO 3.4.1 portable auf CD?

von balu » Fr, 08.03.2013 01:03

Hallo Stephan,

Jetzt versteh ich auch nix mehr!

1.

Code: Alles auswählen

Die Anwendung kann nicht gestartet werden. Failed to updatefile://F:/program/fix/user/extensions/bundled/lastsynchronized
Hallo! Wat is den hier los!?
Die Datei lastsynchronized befindet sich bei mir hier im folgendem Verzeichnis.
program\fix\user\user\extensions\bundled\
Warum habe ich zweimal user, während Du nur einmal user hast? Obwohl ich doch die gleiche Zeile in der bootstrap.ini drin habe wie Du. Sehr määrkwürzik!


2.
Ich hatte jetzt noch mal alles so gemacht wie beschrieben, jedoch mit einem kleinen unterschied. Anstatt auf Festplatte in ein Verzeichnis, installierte ich direkt auf einen USB-Stick. Also bei der Verzeichnisauswahl einfach J:\ eingegeben.

Und vom Stick hatte ich auch das Image erstellt und "gebrannt". Und drei mal darfst Du raten was ich zu Gesichte bekam, als ich dann in VirtuelCloneDrive die soffice.exe gestartet hatte.

...
...
...

Richtig!

Code: Alles auswählen

Die Anwendung kann nicht gestartet werden. Failed to updatefile://H:/program/fix/user/user/extensions/bundled/lastsynchronized
Verdammt noch mal!
Wat is denn nun wieder los?
Vielleicht liegts ja daran das der Schnellstarter aktiv ist?
Also in AOO ihn deaktiviert, und das ganze noch mal von vorn, sprich "brennen". Aber nö! Dat wars auch nicht. Kommt die gleiche Fehlermeldung.


Ich kann dir jetzt nur noch folgendes empfehlen zu testen, vielleicht klappts ja dann bei dir auch.
Führe das Setup auf der Festplatte aus, und installiere auch auf der Festplatte in ein Verzeichnis, z.B. E:\Office_auf_CD, und nicht auf einen USB-Stick.

Wünsche dir viel Glück.



Gruß
balu

Re: AOO 3.4.1 portable auf CD?

von Stephan » Do, 07.03.2013 21:42

Nur zur besseren Übersicht hier noch mal meine vorgehensweise in Kurzform. Die Reihenfolge ist einzuhalten.
•Installation starten
• An gegebener Stelle abbrechen
• Setup mit /a durchführen
• Eventuell ein Verzeichnis angeben
• Nach dem Setup die bootstrap.ini ändern
• soffice.exe starten
• AOO beenden
• Das Verzeichnis mit AOO brennen
Habe ich getan, hilft bei mir nicht. Die FEhlermeldung ist jetzt:

Code: Alles auswählen

Die Anwendung kann nicht gestartet werden. Failed to updatefile://F:/program/fix/user/extensions/bundled/lastsynchronized
wobei /fix/user das Verzeichnis ist welches in bootstrap.ini eingetragen ist als:

UserInstallation=$ORIGIN/fix/user


Ich habe auch nochmals explizit überprüft das AOO 3.4.0 auf CD gebrannt mit dem gleichen Eintrag:

UserInstallation=$ORIGIN/fix/user

funktioniert, um jede Ungewissheit, diesbezüglich, auszuschließen.



Gruß
Stephan

Re: AOO 3.4.1 portable auf CD?

von Stephan » Do, 07.03.2013 19:06

Hallo @all,

danke soweit, ich muß das jetzt erstmal alles durchprobieren.

aber ich kenne Probleme, wenn die "Stellvertreter" Punkte hinter Origin fehlen. Also z.B. $ORIGIN/../AOO. Womöglich liegt es nur daran.
die zwei Punkte bedeuten ganz einfach einen WEchsel ins übergeordnete Verzeichnis bei relativer Pfadadressierung und sind nur nötig wenn tatsächlich ins überrgeordnete Verzeichnis' 'gesprungen 'werden soll.

siehe z.B.: http://de.wikipedia.org/wiki/Pfadname unter "Absolute und relative Pfadnamen"


Gruß
Stephan

Nach oben