Ziffernfolge umkehren

Antwort erstellen


Diese Frage dient dazu, das automatisierte Versenden von Formularen durch Spam-Bots zu verhindern.

BBCode ist eingeschaltet
[img] ist ausgeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind ausgeschaltet

Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: Ziffernfolge umkehren

Re: Ziffernfolge umkehren

von balu » So, 27.05.2018 20:32

Hallo Bommel,

ich bin wohl nicht echo (Holger), aber ich denke mir das er genau das gleiche Fragen würde.
Kannst du die Formeln so verändern, dass sie auch auf mehrere Zeilen und Spalten mit Werten angewendet werden können?
Spätestens jetzt MUSST Du dich mal dazu äußern welches Office mit welcher Versionsnummer Du hast.
Denn bei der Sache mit den Spalten hat ja Lupo1 schon gezeigt wie das gehen kann, vorausgesetzt Du hast LO.


Mir ist jedoch nicht klar wie man diese Passage genau verstehen soll.
mehrere Zeilen und Spalten
Soll nicht nur Beispielsweise nur aus A1 die Werte genommen werden, sondern aus A1 und B1 und A2 und B2? Und wenn dem doch so ist, um wieviele Zeilen und Spalten handelt es sich dabei genau?
Oder vertue ich mich, und Du meinst das ganz anders?



Gruß
balu

Re: Ziffernfolge umkehren

von Bommel » So, 27.05.2018 17:00

Hallo,

vielen Dank allen die mir geholfen haben. Alles konnte ich bisher noch nicht ausprobieren.

@ echo: Kannst du die Formeln so verändern, dass sie auch auf mehrere Zeilen und Spalten mit Werten angewendet werden können?

@ clag: Die UDF funktioniert einwandfrei.

Re: Ziffernfolge umkehren

von clag » Sa, 26.05.2018 21:33

Hallo Bommel,

hier noch eine Lösung mit einer UDF (User definierten Funktion)
Guckst du in der Beispieldatei
reverse_Zellinhalt.ods
(10.65 KiB) 103-mal heruntergeladen

viel Erfolg

etwas kürzer

von Lupo1 » Sa, 26.05.2018 17:53

Für bis zu 15stellige ganze Zahlen ohne Null am Ende und ohne VERBINDEN:

=SUMMENPRODUKT(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*10^(ZEILE(INDIREKT("1:"&LÄNGE(A1)))-1))

VERBINDEN ist jedoch der "Porsche", da auch Nichtziffern gedreht werden.

Re: Ziffernfolge umkehren

von mikeleb » Sa, 26.05.2018 17:32

Hallo,
ich hätte da auch noch eine Formel :shock: :

Code: Alles auswählen

=SUMMENPRODUKT(ABRUNDEN(REST(A1;10^ZEILE(INDIREKT("a1:a" & LÄNGE(A1))))/10^(ZEILE(INDIREKT("a1:a" & LÄNGE(A1)))-1));10^(LÄNGE(A1)-ZEILE(INDIREKT("a1:a" & LÄNGE(A1)))))
Die Formel setzt allerdings voraus, dass in A1 eine natürliche Zahl steht.

Re: Ziffernfolge umkehren

von Lupo1 » Sa, 26.05.2018 13:14

Ok, dann nehme ich diesen Hinweis auch an.

Vermutlich hätte ich die (nicht allzu wichtige) Frage einfach ans Ende des Vor-Beitrags packen sollen. Dann hätte es keinen gestört.

Re: Ziffernfolge umkehren

von balu » Sa, 26.05.2018 13:12

Mahlzeit Lupo1,

egal ob wir Freunde werden oder nicht, meine Frage und Hinweis waren berechtigt und einfach nur rein Sachlich. Denn es ist nämlich nicht Garantiert das ein Mod deine Frage sieht. Und für Probleme, oder ungereimtheiten mit dem Forum gibt es nun mal halt die von mir genannte Rubrik.



Gruß
balu

Re: Ziffernfolge umkehren

von Lupo1 » Sa, 26.05.2018 13:08

Auch solche Petitessen kennen wir drüben nicht. Auch zitieren wir weniger.

Re: Ziffernfolge umkehren

von nikki » Sa, 26.05.2018 13:02

Hallo Euer Hochwohlgeboren,
Lupo1 hat geschrieben:
Sa, 26.05.2018 12:52
Ach balu, wir beide werden bestimmt keine Freunde mehr.
es ist schwer vorstellbar, dass Du überhaupt Freunde hast.

Re: Ziffernfolge umkehren

von Lupo1 » Sa, 26.05.2018 12:52

Ach balu, wir beide werden bestimmt keine Freunde mehr.

So ein Verhalten gibt es in Excel-Foren nicht. Und passt auch nicht zu Deinem entspannten Faultier-Spruch in der Signatur.

Da Du mir neulich raten wolltest, wie ich zu antworten hätte: "Der Traffic stimmt tatsächlich so! Ansonsten haben wir auch die Rubrik daddeldu ..."

Re: Ziffernfolge umkehren

von balu » Sa, 26.05.2018 10:32

Moin Lupo1,
Stimmen die Zugriffe? Ist ja enorm!
Warum stellst Du diese Frage nicht dort wo sie hingehört, nämlich in der Forenrubrik "Site Feedback"?



Gruß
balu

Re: Ziffernfolge umkehren

von Deleted User 56227 » Sa, 26.05.2018 09:27

Hallo,

für OpenOffice gibt es das Addin PYOIN()
Textfunctions.zip
Textfunctions.zip in Textfunctions.oxt umbennen
(3.69 KiB) 88-mal heruntergeladen
Textfunctions.oxt mit OpenOffice öffnen und installieren.

Die Formel von Lupo1 als Matrixformel.

Code: Alles auswählen

=PYJOIN(TEIL(A1;LÄNGE(A1)+1-ZEILE(INDIREKT("1:"&LÄNGE(A1)));1);"")
Gruß HeritzP

Re: Ziffernfolge umkehren

von Lupo1 » Sa, 26.05.2018 09:21

Mal ne Frage an die Moderatoren:

Stimmen die Zugriffe? Ist ja enorm!

direkt ohne Hilfszellen

von Lupo1 » Fr, 25.05.2018 18:12

Ab LO 5.2
(OO, in welchem es die Funktion wohl noch nicht gibt, habe ich nicht, aber TE könnte ja auch LO haben, weil dieses Forum für beide da ist):

B1: {=VERBINDEN(;;TEIL(A1;LÄNGE(A1)+1-ZEILE(INDIREKT("1:"&LÄNGE(A1)));1))} mit Nr. 5
  • VERBINDEN in LO ist das
  • TEXTVERKETTEN aus Excel (365 oder -Online) und das
  • TEXTJOIN aus Docs/OnlyOffice,
so dass JEDER sie ausprobieren kann.

Die Formel entspricht in VBA StrReverse, einer eingebauten Funktion, so dass sich die Frage nach dem Zweck einer Stringumkehr eigentlich erübrigt: Man kann so mit den bestehenden Funktionen nämlich auch von hinten SUCHEN.

Anm: In Excel (und evtl. Docs) klappt es auch ohne Matrixformel: =TEXTVERKETTEN(;;INDEX(TEIL(A1;LÄNGE(A1)+1-ZEILE(INDIREKT("1:"&LÄNGE(A1)));1);))

(ohne Quelle, da Eigenbau)

Re: Ziffernfolge umkehren

von echo » Fr, 25.05.2018 17:53

Hallo
du könntest das mit Hilfsspalten lösen in der die Zeichenkette in seine Zeichen zerlegt und anschließend wieder zusammen gesetzt wird.
Siehe Anhang
Gruß Holger

PS Könntest du erklären wofür man so etwas braucht :shock:
EDIT erneut angehängt, war ein kleiner Fehler in der ersten Hilfsspalte, sorry
zeichen umkehren.ods
(10.91 KiB) 81-mal heruntergeladen

Nach oben