Die Suche ergab 829 Treffer

von mikeleb
Di, 10.12.2019 10:29
Forum: Calc
Thema: Gebt mir ein F ein U ein Ü das heißt FUÜ Feiertage Urlaub Überstunden abbau
Antworten: 3
Zugriffe: 414

Re: Gebt mir ein F ein U ein Ü das heißt FUÜ Feiertage Urlaub Überstunden abbau

Hallo, Ich habe eine Jahresübersicht erstellt in der ich in einer bestimmten Zeile folgende Abkürzung haben möchte: F = Feiertag U = Urlaub oder Ü = Überstunden abbauen. Welche Zeile? Was hast du vor? Eine logisch korrekte Anwort auf die nicht vorhandene Frage, wäre: Schreibe die Abkürzung in die be...
von mikeleb
So, 08.12.2019 15:30
Forum: Makros und allgemeine Programmierung
Thema: PDF-Export nur eines bestimmten Sheets
Antworten: 5
Zugriffe: 458

Re: PDF-Export nur eines bestimmten Sheets

Hallo, so eine richtig gute Dokumentation habe ich bisher nicht gefunden. Ein paar Infos gibt es hier: https://wiki.documentfoundation.org/Macros/Python_Guide/PDF_export_filter_data Per Makro aufzeichnen findet man folgendes: dim args1(2) as new com.sun.star.beans.PropertyValue args1(0).Name = "URL"...
von mikeleb
So, 08.12.2019 14:11
Forum: Makros und allgemeine Programmierung
Thema: PDF-Export nur eines bestimmten Sheets
Antworten: 5
Zugriffe: 458

Re: PDF-Export nur eines bestimmten Sheets

Hallo, dazu musst da die gewünschte Tabelle als weiteren "Auswahl"-Parameter dazugeben: sub alist_pdf() dim ls_datei as string ls_datei = "file:///C:/Prod/OO_Programmierung/alist.pdf" Dim pdfProperties(2) as new com.sun.star.beans.PropertyValue pdfProperties(0).Name = "FilterName" pdfProperties(0).V...
von mikeleb
So, 17.11.2019 16:04
Forum: Makros und allgemeine Programmierung
Thema: [gelöst]Unwissenheit bei Variablen Deklaration
Antworten: 6
Zugriffe: 2696

Re: [gelöst]Unwissenheit bei Variablen Deklaration

Hallo,

Code: Alles auswählen

Format(irgendeineZahl, "0.00")
wandelt die Zahl eben in eine Zeichenkette, was pcdirk91 eigentlich gerade vermeiden möchte.
von mikeleb
Di, 12.11.2019 17:52
Forum: Calc
Thema: Zahlenfolge
Antworten: 12
Zugriffe: 1709

Re: Zahlenfolge

Hallo,
ich bin mir nicht sicher, ob ich dich richtig verstanden habe.
Soll die Addition an jedem Tag neu beginnen?
von mikeleb
Mo, 11.11.2019 20:21
Forum: Makros und allgemeine Programmierung
Thema: Bezierkurve Farben ändern
Antworten: 2
Zugriffe: 927

Re: Bezierkurve Farben ändern

Hallo,
hast du den Schreibfehler schon entdeckt:

Code: Alles auswählen

oBzgl.LineColor=RGB(0,0,255)
besser:

Code: Alles auswählen

oBez1.LineColor=RGB(0,0,255)
von mikeleb
Do, 07.11.2019 08:47
Forum: Calc
Thema: [GELÖST] Summe, wenn entsprechende Wert in anderer Tabelle enthalten
Antworten: 8
Zugriffe: 1005

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Hallo,

Code: Alles auswählen

=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2.A1:A4;Tabelle1.A1:A8);Tabelle1.B1:B8)
von mikeleb
So, 03.11.2019 11:45
Forum: Calc
Thema: Zahlenfolge
Antworten: 12
Zugriffe: 1709

Re: Zahlenfolge

Hallo,
noch 'ne Formel

Code: Alles auswählen

=WENN(ODER(T1>=0;U1=4);1;U1*2)
von mikeleb
Sa, 02.11.2019 23:30
Forum: Calc
Thema: Zahlenfolge
Antworten: 12
Zugriffe: 1709

Re: Zahlenfolge

Hallo,
beginnend in U2, wenn die Werte ab T1 eingetragen sind:

Code: Alles auswählen

=WENN(T1<0;MIN(U1*2;4);1)
von mikeleb
Do, 31.10.2019 16:12
Forum: Makros und allgemeine Programmierung
Thema: Gruppierung ausblenden
Antworten: 8
Zugriffe: 1228

Re: Gruppierung ausblenden

Hallo, oSheet.getCellRangeByName("B1:K"&n;"R1:R"&n;"Y1:Y"&n;"AF:BO"&n).rangeAddress funktioniert nicht, da die Methode .getCellRangeByName() nur einen Zellbereich als Argument akzeptiert. Soweit ich es bisher untersucht habe, ist es per Makro nicht möglich herauszufinden, welche Spalten gruppiert si...
von mikeleb
Do, 31.10.2019 13:28
Forum: Calc
Thema: Abhängige Berechnungen werden seit LO 6.2.8 nicht mehr durchgeführt
Antworten: 8
Zugriffe: 1315

Re: Abhängige Berechnungen werden seit LO 6.2.8 nicht mehr durchgeführt

Hallo,
es wäre schon hilfreich zu wissen, welche Berechnungen konkret durchgeführt werden sollen, damit man das Problem nachstellen kann. Beispieldatei?
von mikeleb
Fr, 25.10.2019 18:16
Forum: Calc
Thema: diagonale Addition/Multiplikation
Antworten: 36
Zugriffe: 9664

Re: diagonale Addition/Multiplikation

Hallo,
für das Produkt:

Code: Alles auswählen

=PRODUKT(MMULT((L56:Q61)*EINHEITSMATRIX(ZEILEN(L56:Q61));ZEILE(L56:Q61)/ZEILE(L56:Q61)))
Ergänzung:
oder auch so

Code: Alles auswählen

=PRODUKT(WENN(ZEILE(L56:Q61)-ZEILE(L56)=SPALTE(L56:Q61)-SPALTE(L56);L56:Q61;1))
von mikeleb
Fr, 25.10.2019 18:07
Forum: Calc
Thema: diagonale Addition/Multiplikation
Antworten: 36
Zugriffe: 9664

Re: diagonale Addition/Multiplikation

Hallo,

Code: Alles auswählen

=SUMMENPRODUKT(L56:Q61;EINHEITSMATRIX(ZEILEN(L56:Q61)))
von mikeleb
Di, 22.10.2019 14:52
Forum: Makros und allgemeine Programmierung
Thema: [gelöst] Makro - Wenn in Zelle Zeit kleiner als dann Zeile löschen
Antworten: 6
Zugriffe: 1699

Re: Makro - Wenn in Zelle Zeit kleiner als dann Zeile löschen

Hallo,

Code: Alles auswählen

"0,002083"
ist ein String.
Den Wert vergleichst du mit

Code: Alles auswählen

0,002083