[GELÖST] Probleme mit bedingter Summe

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Dobias
Beiträge: 3
Registriert: Do, 13.03.2008 08:27

[GELÖST] Probleme mit bedingter Summe

Beitrag von Dobias » Do, 13.03.2008 08:42

Hallo,

ein Minimalbeispiel meines Problems lässt sich mit folgender Tabelle darstellen:

Code: Alles auswählen

        A        |        B        |        C
-----------------------------------------------
1  |  Werte      |      Grenze     |     Summen
2  |      4      |           1     |
3  |      2      |           2     |
4  |      7      |           3     |
5  |      5      |           4     |
6  |      8      |           5     |
7  |      9      |           6     |
In der Spalte Summen soll nun stehen, wieviele der Werte aus "Werte" (A2:A7) >= der jeweiligen Grenze (B2:B7) sind.
Das gewünschte Ergebnis wäre also:

Code: Alles auswählen

        A        |        B        |        C
-----------------------------------------------
1  |  Werte      |      Grenze     |     Summen      (Erklärung)
2  |      4      |           1     |          6      (4,2,7,5,8,9)
3  |      2      |           2     |          6      (4,2,7,5,8,9)
4  |      7      |           3     |          5      (4,7,5,8,9)
5  |      5      |           4     |          5      (4,7,5,8,9)
6  |      8      |           5     |          4      (7,5,8,9)
7  |      9      |           6     |          3      (7,8,9)
(Die Erklärung dahinter gehört nicht zur eigentlichen Tabelle, sondern die hab ich dazugeschrieben, falls meine Absicht ohne sie noch nicht eindeutig gewesen wäre.)

Ich bekomme die Formel dafür aber leider nicht hin. Hab mir schon einiges mit "Wenn", "Summewenn" und "Summenprodukt" versucht zu basteln, hat aber alles nicht funktioniert.

Es wäre nett, wenn ihr mir helfen könntet. :)

Vielen Dank
Dobias
Zuletzt geändert von Dobias am Do, 13.03.2008 09:02, insgesamt 2-mal geändert.

Eia
********
Beiträge: 2614
Registriert: Sa, 23.12.2006 07:40

Re: Probleme mit bedingter Summe - Wenn?Summewenn?Summenprodukt?

Beitrag von Eia » Do, 13.03.2008 08:58

Code: Alles auswählen

SUMMENPRODUKT($A$2:$A$7>=B2)
mfG

Dobias
Beiträge: 3
Registriert: Do, 13.03.2008 08:27

Re: Probleme mit bedingter Summe - Wenn?Summewenn?Summenprodukt?

Beitrag von Dobias » Do, 13.03.2008 09:02

Wow, vielen Dank für die sehr schnelle und (eben getestet) perfekt funktionierende Lösung. :)

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Probleme mit bedingter Summe - Wenn?Summewenn?Summenprodukt?

Beitrag von Karolus » Do, 13.03.2008 09:05

Hallo Dobias
Dobias hat geschrieben:
In der Spalte Summen soll nun stehen, wieviele der Werte aus "Werte" >= der jeweiligen Grenze sind.
Du willst doch zählen und nicht summieren....

Daher:(für C1)

Code: Alles auswählen

=ZÄHLENWENN(A$1:A$100;">="&B1)
es geht aber auch:

Code: Alles auswählen

=SUMMENPRODUKT(A$1:A$100>=B1)
(nach unten ausfüllen mit Doppelklick auf auf die rechte unter Ecke des Zellrahmens.)

Gruß Karo
AOO4, LO4.3, LO4.4 LinuxMint17.2

Dobias
Beiträge: 3
Registriert: Do, 13.03.2008 08:27

Re: [GELÖST] Probleme mit bedingter Summe

Beitrag von Dobias » Do, 13.03.2008 09:52

Cool, funktioniert ebenso. Thx. Wieder was gelernt. :)

Antworten