Calc: Sortierung nach Datum (Formatierungsproblem)

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

micha2
*
Beiträge: 11
Registriert: Sa, 23.05.2009 18:45

Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von micha2 » So, 05.09.2010 09:24

Hallo liebe Leute,

ich würde mich sehr freuen, wenn Ihr mir mit meinem Problem helfen könntet. Ich nutze OO 3.2.0 unter Ubuntu 10.04.
Basis ist eine *.cvs Datei mit einer Datumsspalte, die absteigend sortiert ist. Beispiel:

02.09
01.09
31.08
30.08
27.08
23.08
[...]

Ich benötige eine aufsteigende Sortierung, also das älteste Datum soll oben und das neuste unten stehen. Ich markiere die zu sortierenden Zeilen und wähle "Daten > sortieren", gebe die entsprechende Spalte an und "aufsteigend", Ergebnis:

01.09
02.09
03.09
06.08
09.08
13.08
16.08
23.08
27.08
30.08
31.08

Ich hätte erwartet, der 03.09 würde oben stehen und der 03.09 ganz unten. Formatiere ich die Spalte als Datum [TT.MM] erhalte ich das selbe Sortierungsergebnis wie oben. Auffallend ist, dass nach der Formatierung jeder Zellwert ein ' vorangestellt bekommt, unabhängig davon, welchen Datentyp ich angebe. Dies hat z.B. bei Berechnungen zur Folge, dass sie nicht funktionieren. Ich habe schon alles Mögliche versucht (Werte ausschneiden, Zellen formatieren, Werte wieder einfügen oder Werte in eine neue Calc-Datei einfügen oder zuerst Standardformatierung...) jedesmal erhalten die Zellwerte ein '
Calc.jpeg
Calc.jpeg (3.23 KiB) 4434 mal betrachtet
Ich vermute, die fehlerhafte Sortierung liegt an der Zellformatierung.

Vielen Dank für Hinweise!

Donco
****
Beiträge: 160
Registriert: Do, 26.08.2010 10:02

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von Donco » So, 05.09.2010 09:44

Hallo,

das Hochkomma vor der Zahl formatiert diese als Text. Daher wird nicht mehr nach der Wertgröße des Datums sondern nach den "Anfangsbuchstaben" - hier Ziffern sortiert. Und 03. ist kleiner als 30.

Gruß
Donco
Wissen gehört zu den wenigen Dingen, die wachsen, wenn sie geteilt werden. Danke allen Aktiven.

OO 3.2.1, Windows Vista 32bit
LibreOffice 3.6.4, Windows Vista 32bit
und
LO Version: 4.1.4.2, Win 8 64bit

micha2
*
Beiträge: 11
Registriert: Sa, 23.05.2009 18:45

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von micha2 » So, 05.09.2010 09:50

Hallo,

jetzt frag ich mich, was ich beim Formatieren falsch mache. Ich beschrieb ja oben schon, dass grundsätzlich nach dem Formatieren in einen anderen Zelltyp ein Hochkomma eingefügt wird.

micha2
*
Beiträge: 11
Registriert: Sa, 23.05.2009 18:45

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von micha2 » So, 05.09.2010 09:57

Auch wenn ich die Zellen in eine neue Calc-Datei einfüge, erhalten die Zellwerte das Hochkomma. Selbst wenn ich die betreffende Zeile vorher als Datum formatiert habe und nur Inhalte einfüge. Formatierung löschen hilft auch nicht, das Hochkomma bleibt stehen.

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von echo » So, 05.09.2010 10:09

Hallo

'01,09 > das ist ein Text der "zufällig" auch Zahlen einhält, entsprechend wird dieser sortiert
01.09.2010 > Das ist ein Datum das Calc versteht und auch richtig sortiert.

1. bei der Eingabe muss das Hochkomma weg, anders geht es nicht.
2. bei der Eingabe den Punkt zum trennen Tag.Monat.Jahr verwenden
3. Du kannst bei der Eingabe das aktuelle Jahr weg lassen wenn es mit dem heutigen Datum überein stimmt zB. 01.09 für 01.09.2010 dito für den Monat
4. Das Zellenformat bestimmt, wie das Datum angezeigt wird. Das Format kannst du sogar mit Text verknüpfen Beispiel >> "Am " TTTT" den " TT.MMM JJJJ <<

Wenn du das machst, wird das Datum von calc sofort bei der Eingabe als Datum erkannt und kann auch richtig, wie gewünscht sortiert werden.

Gruß Holger

EDIT
Ein Link dazu
Zuletzt geändert von echo am So, 05.09.2010 10:39, insgesamt 1-mal geändert.

micha2
*
Beiträge: 11
Registriert: Sa, 23.05.2009 18:45

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von micha2 » So, 05.09.2010 10:33

Hallo Holger, vielen Dank für Deine Antwort!
echo hat geschrieben:Hallo
'01,09 > das ist ein Text der "zufällig" auch Zahlen einhält, entsprechend wird dieser sortiert
01.09.2010 > Das ist ein Datum das Calc versteht und auch richtig sortiert.
In meiner Tabelle gibt es so einen Text nicht. Trenner ist immer ein Punkt, also 01.09 - und das Datumsformat TT.MM wird bei der Formatierung auch angeboten.
1. bei der Eingabe muss das Hochkomma weg, anders geht es nicht.
2. bei der Eingabe den Punkt zum trennen Tag.Monat.Jahr verwenden
3. Du kannst bei der Eingabe das aktuelle Jahr weg lassen wenn es mit dem heutigen Datum überein stimmt zB. 01.09 für 01.09.2010 dito für den Monat
4. Das Zellenformat bestimmt, wie das Datum angezeigt wird. Das Format kannst du sogar mit Text verknüpfen Beispiel >> "Am " TTTT" den " TT.MMM JJJJ <<
Zu
1. Versteht mich doch bitte: Das Hochkomma wird automatisch eingefügt, egal wie ich die Zellen formatiere
2. Es werden ausschließlich Punkte zum trennen verwendet
3. Ich gebe die Daten nicht ein. Das *.csv wird als Umsatzübersicht aus dem Webfrontend der Sparkasse generiert
4. Ich habe jeglichen auffindbaren Weg versucht, das Zellformat zu verändern: Es wird jedesmal ein Hochkomma eingefügt, unabhängig vom gewählten Format.

Nochmal: In der Quelldatei existieren die Hochkomma nicht! OO fügt sie jedesmal ein, wenn ich das Zellformat ändere um eine anständige Sortierung zu erreichen!

:(

micha2
*
Beiträge: 11
Registriert: Sa, 23.05.2009 18:45

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von micha2 » So, 05.09.2010 11:42

Formatiere ich Zellen explizit als Text, wird kein Hochkomma vor dem Wert eingefügt.
Entferne ich nur die Formate, wird auch wieder das Hochkomma eingefügt. Versuche ich, anschließend als Datum zu formatieren bleibt das Hochkomma stehen. Egal wie ich es drehe und wende, alles wird zu Text. Gibt es evtl. irgendwelche grundlegenden Einstellungen dazu? Ich habe zwar an der Standardkonfiguration nichts verändert, aber man kann ja nie wissen.

Eddy
********
Beiträge: 2496
Registriert: So, 02.10.2005 10:14

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von Eddy » So, 05.09.2010 12:01

Hallo micha2,

bitte stelle uns doch ein Beispiel zur Verfügung. Ausser den Datumszellen muss ja nichts enthalten sein. Dabei meine ich eine "Quelldatei", nach Deinen Aussagen eine CSV. Bitte probiere, ob damit das Problem auftritt.
Möglicherweise ist alles ein Importproblem.

Mit importierten Grüßen

Eddy

micha2
*
Beiträge: 11
Registriert: Sa, 23.05.2009 18:45

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von micha2 » So, 05.09.2010 12:30

Aha! Von dort stammt also die Text-Formatierung! Beim Textimport musst du für die Datumsspalte nicht Standard, sondern ein Datumsformat auswählen.
Jaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa! Das wars. :D Vielen Dank Rocko! :D
Ausschneiden und als unformatierter Text wieder einfügen. (Beim Ausschneiden wird auch die Formatierung "ausgeschnitten" und anschließend natürlich nicht wieder "mitgeliefert".).
Das habe ich die ganze Zeit versucht, bekomme es aber nicht hin, bzw. finde keine Option "als unformatierter Text wieder einfügen". Ich habe es über "Inhalte" einfügen versucht, aber so kann ich nur als Text einfügen (Formate habe ich deaktiviert). Wärst Du/Ihr evtl. so nett und würde(s)t mir das noch erklären? VIelen Dank!

freedom
********
Beiträge: 2145
Registriert: Do, 16.08.2007 15:12

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von freedom » So, 05.09.2010 12:59

Hallo Micha,

du kannst auch suchen und ersetzen

Strg+F
mehr Optionen - [x]regulärer Ausdruck
Suchen: ^.
Ersetzen: &

micha2
*
Beiträge: 11
Registriert: Sa, 23.05.2009 18:45

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von micha2 » So, 05.09.2010 13:32

Hallo und vielen Dank noch einmal für Eure Mühe!

Solange ich nicht schon beim Import die Spalten als Datum deklariere, funktioniert leider keiner der Hinweise (Details unten).
Da ich jetzt weiß, dass ich schon beim Import auf das Format der Zellen achten muss, ist mir bestens geholfen - nochmals vielen Dank!
Evtl. liegen ja meine Schwierigkeiten im Quelldokument "begraben". Ist schon erstaunlich, dass ich die Zellen im Nachhinein nicht umformatieren kann.
Rocko hat geschrieben:Über Inhalte einfügen funktioniert das auch, wenn du Formate deaktiviert hast. Der Begriff unformatierter Text ist etwas irreführend. Damit ist nicht "Text" alternativ zu "Zahlenwert" gemeint, sondern ganz einfach Text = Zeichen.
Ich finde keine Option "Zeichen". Formate habe ich deaktiviert beim "Inhalte einfügen" und solange ich "Text" nicht aktiviere, wird garnichts eingefügt. Ergebnis wie gehabt mit Hochkomma.
In der Format-Symbolleiste findest du einen kleinen Pfeil rechts neben dem Symbol einfügen. Damit klappt ein Fensterchen auf, in dem du den Einfügemodus Unformatierter Text findest.
Einfügen klappt, kein Hochkomma vorhanden. Formatiere ich die Zellen anschließend als Datum, ist das Hochkomma wieder da.

freedom
********
Beiträge: 2145
Registriert: Do, 16.08.2007 15:12

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von freedom » So, 05.09.2010 13:43

Hallo Micha,
Formatiere ich die Zellen anschließend als Datum, ist das Hochkomma wieder da.
klappt es mit dieser Reihenfolge?
- ausschneden
- formatiere noch leeren Bereich als Datum
- einfügen als unformatierten Text

micha2
*
Beiträge: 11
Registriert: Sa, 23.05.2009 18:45

Re: Calc: Sortierung nach Datum (Formatierungsproblem)

Beitrag von micha2 » So, 05.09.2010 13:49

Hallo freedom,

es klappt "zum Teil". Ich bin so vorgegangen, wie Du beschrieben hast. Jeweils für die oberste Zelle klappt es nicht, für die restlichen schon. Habe es mit mehreren Bereichen probiert. Wie man auf dem Bild sieht, zeigt sich der 27.08 unbeeindruckt von der Formatierung:
calc_einfügen.jpeg
calc_einfügen.jpeg (12.23 KiB) 4369 mal betrachtet

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 15 Gäste