[gelöst] Mittelwert aus selber Länge bilden

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

KatharinaS
*
Beiträge: 12
Registriert: Fr, 07.04.2017 07:42

[gelöst] Mittelwert aus selber Länge bilden

Beitrag von KatharinaS » Fr, 07.04.2017 07:47

Hallo ihr Lieben,

ich habe eine Tabelle in der die Maße von Balken eingetragen sind und die Preise.
Nun würde ich gerne den Mittelwert der selben Längen, in einer neuen Tabelle, bilden.
Leider stoße ich da schon an meine Grenzen. Ich hab schon überlegt de SVERWEIS zu benutzen, aber keine Ahnung wie.
Ich hoffe, ihr könnt mir weiter helfen :)
Zuletzt geändert von KatharinaS am Di, 11.04.2017 08:25, insgesamt 1-mal geändert.

TrueColor
******
Beiträge: 542
Registriert: Do, 11.03.2010 11:23

Re: Mittelwert aus selber Länge bilden

Beitrag von TrueColor » Fr, 07.04.2017 08:20

Der Mittelwert ist die Summe der Werte geteilt durch die Anzahl der Werte. Also z.B.

Code: Alles auswählen

=SUMME(Tabelle1.A1:A10)/ANZAHL(Tabelle1.A1:A10)
Oder du nutzt die vorhandenen Werkzeuge

Code: Alles auswählen

=MITTELWERT(Tabelle1.A1:A10)
Immer wieder gerne der Hinweis: Die OO-Hilfe ist im Vergleich zu vielen anderen Programmen sehr gut, sollte man also nutzen, damit die armen OO-Leute die Hilfe nicht umsonst geschrieben haben ;-)

Edit: Typo
Zuletzt geändert von TrueColor am Fr, 07.04.2017 08:49, insgesamt 1-mal geändert.
System:
Arbeit: Windows 7 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3), LibreOffice 4.1.4.2
Home: Windows 10 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3)

KatharinaS
*
Beiträge: 12
Registriert: Fr, 07.04.2017 07:42

Re: Mittelwert aus selber Länge bilden

Beitrag von KatharinaS » Fr, 07.04.2017 08:23

Hallo TrueColor,
danke für die schnelle Antwort. Ich merke grad, dass ich mich nicht ganz klar ausgedrückt hab.
Die Längen sind unterschiedlich, ich habe 3m, 3,3m, 3,6m, 3,9m, usw. Den Mittelwert möchte ich dann für alle 3m langen Stämme haben und für alle 3,3m langen Stämme, usw. Also brauch ich ja noch eine Funktion, die mir erst die richtigen Längen ausliest und dann aus den dazugehörigen Preisen den Mittelwert bildet.
Die Foren hab ich schon nach einem ähnlichen Problem durchsucht und wurde nicht fündig.
Liebe Grüße,
Katharina

TrueColor
******
Beiträge: 542
Registriert: Do, 11.03.2010 11:23

Re: Mittelwert aus selber Länge bilden

Beitrag von TrueColor » Fr, 07.04.2017 08:48

Beispieldatei?

Aus dem Bauch heraus würde ich's mit SUMMENPRODUKT() probieren, siehe z.B. http://www.online-excel.de/excel/singsel.php?f=53

Code: Alles auswählen

=SUMMENPRODUKT((Tabelle1.A1:A10=3,6)*(Tabelle1.B1:B10))/SUMMENPRODUKT((Tabelle1.A1:A10=3,6)*1)
Längen in Spalte A, Preise in Spalte B
Das Summenprodukt im Zähler gibt die Summe der Preise aller 3,60 m langen Balken zurück, das im Nenner die Anzahl aller 3,60 m langen Balken. (Tabelle1.A1:A10=3,6) ist eine Wahrheitsprüfung. Die Multiplikation mit 1 dient dazu, den Boolschen Wert in eine Zahl zu wandeln.
System:
Arbeit: Windows 7 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3), LibreOffice 4.1.4.2
Home: Windows 10 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3)

KatharinaS
*
Beiträge: 12
Registriert: Fr, 07.04.2017 07:42

Re: Mittelwert aus selber Länge bilden

Beitrag von KatharinaS » Fr, 07.04.2017 09:01

O P S
Länge Breite Preis
5100 125,00 144,00
5400 125,00 114,00
5700 125,00 145,00
6000 125,00 104,00
3900 100,00 167,00
3900 100,00 145,00
3900 100,00 105,00
4200 100,00 115,00
4200 100,00 115,00
4200 100,00 185,00

Ich hab jetzt den Umweg gewählt, dass ich in der Tabelle Summewenn benutze.

=SUMMEWENN($Preis2016.O2:O2138;"=3000";$Preis2016.S2:S2138)

Dann brauch ich noch eine Funktion die zählen kann, wie viele es gibt. (=Zählenwenn müsste klappen denk ich).
Ist dann etwas umständlicher, aber bringt mich hoffentlich zum Ziel. Wenn dir eine einfachere Lösung dazu einfällt, ich bin offen für Neues :D

Liebe Grüße

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Mittelwert aus selber Länge bilden

Beitrag von Karolus » Fr, 07.04.2017 09:20

Hallo

Für so was gibts die Pivottabelle

http://de.openoffice.org/doc/oooauthors ... npilot.pdf
http://www.ooowiki.de/DatentabellenAusw ... belle.html

Ein kurzes Beispiel:
Mittelwerte_pivot.ods
(11.81 KiB) 52-mal heruntergeladen
AOO4, LO4.3, LO4.4 LinuxMint17.2

KatharinaS
*
Beiträge: 12
Registriert: Fr, 07.04.2017 07:42

Re: Mittelwert aus selber Länge bilden

Beitrag von KatharinaS » Fr, 07.04.2017 09:32

Karolus hat geschrieben:
Fr, 07.04.2017 09:20
Hallo

Für so was gibts die Pivottabelle

http://de.openoffice.org/doc/oooauthors ... npilot.pdf
http://www.ooowiki.de/DatentabellenAusw ... belle.html

Ein kurzes Beispiel:Mittelwerte_pivot.ods
An diese Pivottabellen hab ich mich bisher nicht ran getraut :oops: Aber wenn ich damit schneller und vor allem einfacher ans Ziel komme, dann werde ich das doch mal versuchen :)
Vielen lieben Dank für die Hilfe am frühen Morgen

TrueColor
******
Beiträge: 542
Registriert: Do, 11.03.2010 11:23

Re: Mittelwert aus selber Länge bilden

Beitrag von TrueColor » Fr, 07.04.2017 09:33

Ich hab jetzt den Umweg gewählt, dass ich in der Tabelle Summewenn benutze.

=SUMMEWENN($Preis2016.O2:O2138;"=3000";$Preis2016.S2:S2138)

Dann brauch ich noch eine Funktion die zählen kann, wie viele es gibt. (=Zählenwenn müsste klappen denk ich).
Ja, das fkt. auch, da du nur auf 1 Kriterium prüfst.
System:
Arbeit: Windows 7 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3), LibreOffice 4.1.4.2
Home: Windows 10 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3)

Benutzeravatar
balu
********
Beiträge: 3543
Registriert: Fr, 24.08.2007 00:28
Wohnort: Warstein

Re: Mittelwert aus selber Länge bilden

Beitrag von balu » Fr, 07.04.2017 10:17

Moin Katharina,

und wie wärs ganz einfach mit dieser Formel?

Code: Alles auswählen

=SUMMENPRODUKT($Preis2016.O2:O2138=3900;$Preis2016.S2:S2138)/SUMMENPRODUKT($Preis2016.O2:O2138=3900)
Das ist übrigens die korrekte Schreibweise in OpenOffice.



Gruß
balu
Sei öfter mal ein Faultier, sag öfter mal "Ach was!" Dann kriegst du keinen Herzinfarkt, und hast ne menge Spass.

wehr rächtschraipfähler findet khan si behalden :D

KatharinaS
*
Beiträge: 12
Registriert: Fr, 07.04.2017 07:42

Re: Mittelwert aus selber Länge bilden

Beitrag von KatharinaS » Fr, 07.04.2017 10:48

Karolus hat geschrieben:
Fr, 07.04.2017 09:20
Hallo

Für so was gibts die Pivottabelle
Oh man :D Hab es tatsächlich mit einer Pivittabelle hinbekommen. Das ist ja gar nicht so kompliziert und geht ruck zuck. Vielen Dank nochmal für den Tipp :D
balu hat geschrieben:
Fr, 07.04.2017 10:17
Moin Katharina,

und wie wärs ganz einfach mit dieser Formel?

Code: Alles auswählen

=SUMMENPRODUKT($Preis2016.O2:O2138=3900;$Preis2016.S2:S2138)/SUMMENPRODUKT($Preis2016.O2:O2138=3900)
Das ist übrigens die korrekte Schreibweise in OpenOffice.



Gruß
balu
Moin Balu,

summiert es mir dann wirklich nur die Preise der einen Länge nur weil am Schluss ein =(gewünschte Länge) steht? Das wäre ja verrückt :D
Ich hab's noch nicht ausprobiert, aber ich werde das gleich mal machen. Das kommt mir irgendwie zu einfach vor ;)
Und warum teilst du zwei Summenprodukte durcheinander? Einmal sollte es doch die Anzahl sein, oder versteh ich da was falsch?

Benutzeravatar
balu
********
Beiträge: 3543
Registriert: Fr, 24.08.2007 00:28
Wohnort: Warstein

Re: Mittelwert aus selber Länge bilden

Beitrag von balu » Fr, 07.04.2017 11:18

SUMMENPRODUKT alleine

Code: Alles auswählen

=SUMMENPRODUKT($Preis2016.O2:O2138=3900)
hat mit ZÄHLENWENN eins gemeinsam, es wird gezählt wie oft eine Übereinstimmung existiert. Und in diesem Falle sind das 3 Übereinstimmungen.


Code: Alles auswählen

=SUMMENPRODUKT($Preis2016.O2:O2138=3900;$Preis2016.S2:S2138)
Nun wird in der Spalte S (S2:S2138) jeder Betrag addiert der in der gleichen Zeile mit dem Suchkriterium in der Spalte O (O2:O2138) übereinstimmt. Das macht in diesem Falle gleich 417.

Code: Alles auswählen

=SUMMENPRODUKT($Preis2016.O2:O2138=3900;$Preis2016.S2:S2138)/SUMMENPRODUKT($Preis2016.O2:O2138=3900)
Jetzt wird das Ergebnis durch die 3 Übereinstimmungen geteilt, und das ergibt 139. Das wars.


Der Datenpilot ist wohl auch nicht schlecht, oder verkehrt. Aber er hat den Nachteil, das er jedesmal neu angestoßen werden muss, wenn sich etwas ändert. Eine Formel reagiert sofort, sie muss nicht extra neu angestoßen werden. Es bleibt dir aber ganz alleine überlassen für was Du dich schlußendlich entscheidest. ;-)



Gruß
balu
Sei öfter mal ein Faultier, sag öfter mal "Ach was!" Dann kriegst du keinen Herzinfarkt, und hast ne menge Spass.

wehr rächtschraipfähler findet khan si behalden :D

KatharinaS
*
Beiträge: 12
Registriert: Fr, 07.04.2017 07:42

Re: Mittelwert aus selber Länge bilden

Beitrag von KatharinaS » Fr, 07.04.2017 14:14

balu hat geschrieben:
Fr, 07.04.2017 11:18
SUMMENPRODUKT alleine

Code: Alles auswählen

=SUMMENPRODUKT($Preis2016.O2:O2138=3900)
hat mit ZÄHLENWENN eins gemeinsam, es wird gezählt wie oft eine Übereinstimmung existiert. Und in diesem Falle sind das 3 Übereinstimmungen.


Code: Alles auswählen

=SUMMENPRODUKT($Preis2016.O2:O2138=3900;$Preis2016.S2:S2138)
Nun wird in der Spalte S (S2:S2138) jeder Betrag addiert der in der gleichen Zeile mit dem Suchkriterium in der Spalte O (O2:O2138) übereinstimmt. Das macht in diesem Falle gleich 417.

Code: Alles auswählen

=SUMMENPRODUKT($Preis2016.O2:O2138=3900;$Preis2016.S2:S2138)/SUMMENPRODUKT($Preis2016.O2:O2138=3900)
Jetzt wird das Ergebnis durch die 3 Übereinstimmungen geteilt, und das ergibt 139. Das wars.


Der Datenpilot ist wohl auch nicht schlecht, oder verkehrt. Aber er hat den Nachteil, das er jedesmal neu angestoßen werden muss, wenn sich etwas ändert. Eine Formel reagiert sofort, sie muss nicht extra neu angestoßen werden. Es bleibt dir aber ganz alleine überlassen für was Du dich schlußendlich entscheidest. ;-)



Gruß
balu
Vielen Dank, habe auch das ausprobiert :D So viel Neues heute. Und auch das funktioniert einwandfrei. Heute bin ich mal richtig begeistert von Calc, so viele Möglichkeiten...

TrueColor
******
Beiträge: 542
Registriert: Do, 11.03.2010 11:23

Re: Mittelwert aus selber Länge bilden

Beitrag von TrueColor » Mo, 10.04.2017 08:58

KatharinaS hat geschrieben:
Fr, 07.04.2017 10:48
summiert es mir dann wirklich nur die Preise der einen Länge nur weil am Schluss ein =(gewünschte Länge) steht? Das wäre ja verrückt :D
Ich hab's noch nicht ausprobiert, aber ich werde das gleich mal machen. Das kommt mir irgendwie zu einfach vor ;)
noch was zum Nachlesen (steht in de normalen F1-Hilfe nicht drin) dazu:

aus https://wiki.openoffice.org/wiki/Docume ... T_function
[...]
SUMPRODUCT(A1:A6="red"; B1:B6="big"; C1:C6)

returns the sum of cells in C1:C6 whose corresponding entries in the A column are red and in the B column are big. This is not portable to Excel, as Excel ignores logical values.

SUMPRODUCT((A1:A6="red") * (B1:B6="big") * C1:C6)

a version of SUMPRODUCT(A1:A6="red"; B1:B6="big"; C1:C6) which is portable to Excel, as the logical values are converted to numbers during the multiplication.
[...]
und https://wiki.openoffice.org/wiki/Docume ... SUMPRODUCT
System:
Arbeit: Windows 7 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3), LibreOffice 4.1.4.2
Home: Windows 10 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3)

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 12 Gäste