Spalten zählen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Atta

Spalten zählen

Beitrag von Atta » Mo, 01.05.2017 13:07

Hallo Forum,

bin seit einiger Zeit auf der Suche, nach einer Möglichkeit Spalten zu zählen in dem ein bestimmtes Wort 2/3 vorkommt.
Hab überlegt Zählenwenn zu nutzen, jedoch bekomme ich es nicht hin.

Beispiel:

Peter Altmeier Spät Spät Spät
Martin Schulz Spät Spät Spät
Gunther Gabriel Spät Spät

Hier gäbe es 2 Spalten mit 3x Spät und eine Spalt mit 2xSpät.
Gibt es eine Möglichkeit das über ein größeren Raum(1Jahr,jeden Tag) zu zählen ?

Benutzeravatar
komma4
********
Beiträge: 5330
Registriert: Mi, 03.05.2006 23:29
Wohnort: Chon Buri Thailand Asia
Kontaktdaten:

Re: Spalten zählen

Beitrag von komma4 » Mo, 01.05.2017 15:20

Mmh,

Du meist sicherlich: 2 Zeilen, die 3 Spalten mit "spät" haben..., oder?

In einer "Hilfsspalte" nehme die Formel

Code: Alles auswählen

=ZÄHLENWENN(A2:A366;"=spät")
Zählt im Bereich A2 bis A366 das Vorkommen der Zeichenkette spät.

Dann ziehst Du die Formel über alle Zeilen runter, die Du zählen möchtest.
War's das?
Cheers
Winfried
aktuell: LO 5.3.5.2 30m0(Build:2) SUSE rpm, unter Linux openSuSE Leap 42.3 x86_64/KDE5
DateTime2 Einfügen von Datum/Zeit/Zeitstempel (als OOo Extension)

Atta
Beiträge: 8
Registriert: Mo, 01.05.2017 15:39

Re: Spalten zählen

Beitrag von Atta » Mo, 01.05.2017 15:51

Oh da hab ich mich ein wenig falsch ausgedrückt.
Also ich will alle Spalten zählen in dem das Wort "Spät" 3x vorkommt.
Die anderen Spalten, in denn "Spät" 2x vorkommt möchte ich seperat zählen.
Im Beispiel (hab mal eine Datei angehängt) wären es 4 Spalten.
Aber immer wenn ich Zählenwenn einsetze zählt er alle "Spät" also 12x
Dateianhänge
Unbenannt 1.ods
(11.87 KiB) 54-mal heruntergeladen

Benutzeravatar
miesepeter
*******
Beiträge: 1606
Registriert: Sa, 10.05.2008 15:05
Wohnort: Bayern

Re: Spalten zählen

Beitrag von miesepeter » Mo, 01.05.2017 17:29

Atta hat geschrieben:
Mo, 01.05.2017 15:51
Aber immer wenn ich Zählenwenn einsetze zählt er alle "Spät" also 12x
Hallo,
du solltest so vorgehen wie komma4 vorschlug, also in einer Hilfszeile am Anfang oder Ende einer Spalte die Zählung ansetzen. Du erhältst dann zunächst Zahlen, mit denen du später weiterarbeiten kannst. Beispiel:

Code: Alles auswählen

=ZÄHLENWENN(C1:C9;"Spät")
Das könntest du zunächst in deiner Beispieldatei in C10 eintragen, entsprechend mit Bezug auf D1:D9 in Zelle D10 usw.
In einem weiteren Schritt kannst du abfragen, wie oft z.B. die Zahlen 3 oder 2... vorkommen. Auch wieder mit =ZÄHLENWENN().
Ciao

Atta
Beiträge: 8
Registriert: Mo, 01.05.2017 15:39

Re: Spalten zählen

Beitrag von Atta » Mo, 01.05.2017 18:09

Dann hab ich komma falschverstanden. Der verschobene "Sonntag" spielt mir übel mit.
Die Lösung kam mir auch schon in denn Sinn, hab aber gedacht es geht auch anderst(kompakter).

Aufjedenfall danke ich euch zweien für eure freundliche und schnelle Hilfe.
Ein schönen restlichen "Arbeitstag" wünsche ich euch

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 13 Gäste