Sverweis

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Huschpuscheldi
Beiträge: 6
Registriert: Fr, 14.03.2014 20:02

Sverweis

Beitrag von Huschpuscheldi » Fr, 14.07.2017 18:31

Hallo!
In den Spalten A, B und C werden jeden Mo, Di und Fr Werte eingetragen, die in eine andere Tabelle (E, F und G) übernommen werden sollen, aber dort sind auch der Mi und Do enthalten.
Wenn ich jetzt in Spalte C einen zusätzlichen Wert eintrage, z.B. am 12.05.2017, dann soll dieser Wert auch rechts in Spalte G neben der Zelle des 12.05.2017 erscheinen. Also müssen die Zellen G9 und G10 leer bleiben und in G11 muss der Wert aus C7 erscheinen.

Mit einem Sverweis bekomme ich das zwar grundsätzlich hin, aber wenn ich den Sverweis in G2 eintrage und die Formel dann einach herunterziehe erscheinen auch Werte in den Zellen vom Mi und Do.
Kann mir eine helfen? Danke!
Dateianhänge
Sverweis.JPG
Sverweis.JPG (50.48 KiB) 935 mal betrachtet

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Sverweis

Beitrag von echo » Fr, 14.07.2017 19:08

Hallo
du hasst als Suchkriterium B2 statt F2 eingetragen.
Weiter hat SVerweis() ein zusätzliches 4. Argument dies sollte FALSCH oder 0 haben.

Ich denke das sollte angepasst werden.
Gruß Holger

Benutzeravatar
lorbass
********
Beiträge: 4014
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: Sverweis

Beitrag von lorbass » Fr, 14.07.2017 19:11

Das Suchkriterium in SVERWEIS muss natürlich F2 sein, nicht B2:

Code: Alles auswählen

=SVERWEIS(F2;$B$2:$C$10;2;0)
Dann noch die Fehlermeldungen für Daten ausblenden, die in der linken Tabelle nicht auftreten:

Code: Alles auswählen

=WENNFEHLER(SVERWEIS(F2;$B$2:$C$10;2;0);"")
Gruß
lorbass

Huschpuscheldi
Beiträge: 6
Registriert: Fr, 14.03.2014 20:02

Re: Sverweis

Beitrag von Huschpuscheldi » Fr, 14.07.2017 22:07

Danke euch beiden.
Das es F2 sein muss haben ich eben selbst rausgefunden, konnte hier aber nichts posten, weil ich nicht auf die Seite kam... War das Forum eben down?

So wie es aussieht kennt Openoffice die Wennfehler Funktion nicht. Habe ein bisjen gegoogelt, anscheinend kann Wennfehler mit

=WENN(ISTNV(SVERWEIS(F2;$B$2:$C$10;2;0));"";SVERWEIS(F2;$B$2:$C$10;2;0)) ersetzt werden. So klappt es jedenfalls.
Danke!
Dateianhänge
Sverweis3.JPG
Sverweis3.JPG (63.4 KiB) 896 mal betrachtet

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 15 Gäste