WENN mit UND() und ODER()

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

mafug
*
Beiträge: 10
Registriert: Mi, 19.01.2011 17:45

WENN mit UND() und ODER()

Beitrag von mafug » Mo, 31.07.2017 13:35

Hallo,

ich möchte als "Ergebnis" einen Wert aus einer von 4 Zellen, wenn zwei Bedingungen aus jeweils vier Vergleichen zutreffen.
Ich hoffe, es ist verständlich
Das ist meine bisherige Formel, die leider kein Ergebnis ergibt, sondern FALSCH.

=WENN(UND(ODER($C2=$H2;$C3=$H2;$C4=$H2;$C5=$H2);(ODER($A2=$M1;$A3=$M1;$A4=$M1;$A5=$M1));(WENN($A2=M$1;$I2;WENN($A3=M$1;$I3;WENN($A4=M$1;$I4;WENN($A5=M$1;$I5;0)))));0))

Die beiden Vergleiche scheinen zu stimmen, denn als Teilergebnis sind sie jeweils WAHR. Auch im Weiteren (bezug zur entspr. Zelle in Spalte "I" zeigt das Teilergebnis den richtigen Wert an.

Wo ist der Fehler?

Danke schon mal
mafug

Gast

Re: WENN mit UND() und ODER()

Beitrag von Gast » Mo, 31.07.2017 13:51

Servus,

was für Bedingungen sollten das sein?.
Es gibt einige WENN(), UND(), ODER() abfragen, aber was soll geschehen.


Gast

mafug
*
Beiträge: 10
Registriert: Mi, 19.01.2011 17:45

Re: WENN mit UND() und ODER()

Beitrag von mafug » Mo, 31.07.2017 14:48

Hallo,

in Zelle M2 soll der Wert aus der entspr. Zelle I2 - I5 stehen, der sich ergibt, wenn eine Zelle aus C2-C5 identisch ist mit einer Zelle aus dem Bereich H2-H5 UND eine Zelle aus dem Bereich A2-A5 identisch ist mit M1.

Gruß mafug

mafug
*
Beiträge: 10
Registriert: Mi, 19.01.2011 17:45

Re: WENN mit UND() und ODER()

Beitrag von mafug » Mo, 31.07.2017 15:02

Hallo,

sorry, da war ein kleiner Fehler, RICHTIG ist:
in Zelle M2 soll der Wert aus der entspr. Zelle I2 - I5 stehen, der sich ergibt, wenn eine Zelle aus C2-C5 identisch ist mit H2 UND eine Zelle aus dem Bereich A2-A5 identisch ist mit M1.

mafug

Mondblatt24
****
Beiträge: 121
Registriert: So, 14.05.2017 16:11

Re: WENN mit UND() und ODER()

Beitrag von Mondblatt24 » Mo, 31.07.2017 15:40

Hallo,
die Zelle als Standard formatieren (Strg+Umschalt+6)

Gruß Peter
Zuletzt geändert von Mondblatt24 am Mo, 31.07.2017 16:15, insgesamt 2-mal geändert.
LO 5.3.6; LO 5.4.2; LO 5.4.2 Portable; AOO Portable 4.1.4

Gast

Re: WENN mit UND() und ODER()

Beitrag von Gast » Mo, 31.07.2017 15:45

Servus,


es waren alle WENN() Funktionen in der UND() Funktion.

Code: Alles auswählen

=WENN(UND(ODER($C2=$H2;$C3=$H2;$C4=$H2;$C5=$H2);ODER($A2=$M1;$A3=$M1;$A4=$M1;$A5=$M1)) ;WENN($A2=M$1;$I2;WENN($A3=M$1;$I3;WENN($A4=M$1;$I4;WENN($A5=M$1;$I5;0))));0)
Gast

mafug
*
Beiträge: 10
Registriert: Mi, 19.01.2011 17:45

Re: WENN mit UND() und ODER()

Beitrag von mafug » Mo, 31.07.2017 16:23

Hallo und Servus,

vielen Dank.
Wenn ich das richtig sehe, war es nur eine " ( " die fehlte.
Kleine Ursache- große Auswirkung

mafug

Gast

Re: WENN mit UND() und ODER()

Beitrag von Gast » Mo, 31.07.2017 16:36

Servus,

es waren 3 zuviel.


Gast

Mondblatt24
****
Beiträge: 121
Registriert: So, 14.05.2017 16:11

Re: WENN mit UND() und ODER()

Beitrag von Mondblatt24 » Mo, 31.07.2017 18:32

Hallo,
verkürzte Fassung

Code: Alles auswählen

=WENN(UND(ZÄHLENWENN($C$2:$C$5;$H$2);ZÄHLENWENN($A$2:$A$5;$M$1));SVERWEIS($M$1;$A$2:$I$5;9;0);0)
MfG Peter
LO 5.3.6; LO 5.4.2; LO 5.4.2 Portable; AOO Portable 4.1.4

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 9 Gäste