Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

smayer
Beiträge: 8
Registriert: Mi, 02.08.2017 22:04

Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von smayer » Mi, 02.08.2017 22:21

Hallo ich möchte den Wert einer Zelle aus einer Spalte einer Tabelle mit den werten einer anderen (Referenz) Tabelle vergleichen und bei Übereinstimmung ausgeben .

Beispiel:

Tabelle 1

Spalte A Spalte B

2 "wen die zahl 2 in Tabelle B gefunden wurde dann hier ausgeben"
4
6
8
10
12
14
17

Tabelle 2

Spalte A Spalte B Spalte C
1 2 3
4 5 6
7 8 9
10 11 12

hab null Ahnung von Calc vielleicht kann jemand helfen

danke

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von echo » Mi, 02.08.2017 22:32

Hallo
Versuchs mal mit einer Beispieldatei als Anhang
oder mit der Formel =wenn(zählenwenn()<>0;"Gefunden";"Nicht gefunden")
Formel auf deine Tabelle erweitern / anpassen, das kann ich ohne input nicht

Gruß Holger

smayer
Beiträge: 8
Registriert: Mi, 02.08.2017 22:04

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von smayer » Mi, 02.08.2017 22:36

ok mach ich gleich

smayer
Beiträge: 8
Registriert: Mi, 02.08.2017 22:04

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von smayer » Mi, 02.08.2017 22:43

tabelle 2.ods
(10.53 KiB) 27-mal heruntergeladen
tabelle 1.ods
(10.53 KiB) 25-mal heruntergeladen
danke

smayer
Beiträge: 8
Registriert: Mi, 02.08.2017 22:04

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von smayer » Mi, 02.08.2017 22:45

die Funktion ist: =VERGLEICH(A:A;Tabelle2.A1:C20;0)
klappt aber nicht so Richtig

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von echo » Mi, 02.08.2017 22:48

Zelle B1
=WENN(ZÄHLENWENN(Tabelle2.$A$1:$C$20;A1);"gefunden";"nicht gefunden")
und runter kopieren
Gibt immer "gefunden" zurück weil alle Zahlen in dem Suchbereich vorhanden sind.

Gruß Holger

smayer
Beiträge: 8
Registriert: Mi, 02.08.2017 22:04

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von smayer » Mi, 02.08.2017 22:58

danke
ist es möglich anstelle von wahr und falsch den wahren wert als zahl auszugeben

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von echo » Mi, 02.08.2017 23:03

ersetze "gefunden" durch A1;
ersetze "nicht gefunden" durch irgendwas zB. ""

Nachtrag:
Wenn es sich ausschließlich um Zahlen handelt, geht es etwas kürzer:
=(ZÄHLENWENN(Tabelle2.$A$1:$C$20;A1)<>0)*A1

Das Ergebnis ist Null oder A1

smayer
Beiträge: 8
Registriert: Mi, 02.08.2017 22:04

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von smayer » Mi, 02.08.2017 23:35

hab gesucht und nicht gefunden wo ich das ändern kann
ersetze "gefunden" durch A1;
ersetze "nicht gefunden" durch irgendwas zB. ""

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von echo » Mi, 02.08.2017 23:49

=WENN(ZÄHLENWENN(Tabelle2.$A$1:$C$20;A1);"gefunden";"nicht gefunden")
Du solltest schon ein wenig die Augen auf machen...
Angepasst
=WENN(ZÄHLENWENN(Tabelle2.$A$1:$C$20;A1);A1;"")

smayer
Beiträge: 8
Registriert: Mi, 02.08.2017 22:04

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von smayer » Do, 03.08.2017 00:02

ja funktioniert fast, ich hoffe ich nerf nicht zu sehr, , anstelle des falsch ist jetzt eine lehre zelle, das ist super.
wäre gut wen an stelle des Wortes wahr die übereinstimmende zahl stehen würde

danke

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von echo » Do, 03.08.2017 00:42

tut mir leid, ich weiß nicht von was du schreibst, da wird kein FALSCH ausgegeben.
Dateianhänge
tabelle 1.ods
(10.43 KiB) 28-mal heruntergeladen

smayer
Beiträge: 8
Registriert: Mi, 02.08.2017 22:04

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von smayer » Do, 03.08.2017 01:08

hab jetzt deine tabelle verwendet und es funktioniert
vielen dank für die mühe.
wie kann man sich hier im forum revanchieren

Benutzeravatar
lorbass
********
Beiträge: 4015
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: Wert einer Spalte Tabelle mit werten einer anderen Tabelle vergleichen

Beitrag von lorbass » Do, 03.08.2017 19:02

smayer hat geschrieben:
Do, 03.08.2017 01:08
wie kann man sich hier im forum revanchieren
Ganz einfach: Indem du eine Frage eines anderen Benutzers, die du sicher(!) beantworten kannst, beantwortest und die Lösung ggf. beschreibst.

Gruß
lorbass

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 12 Gäste