Zellschutz funktioniert nicht richtig

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Miriskre
Beiträge: 7
Registriert: So, 02.12.2007 17:21

Zellschutz funktioniert nicht richtig

Beitrag von Miriskre » Fr, 22.09.2017 12:05

Ich habe eine Vorlage mit 2 Tabellen gebastelt.

In Tabelle 1 kann man in 5 Felder Werte eingeben, in Tabelle 2 werden diese ausgewertet, berechnet, usw.

Ich habe in Tabelle 1 den Zellschutz aktiviert, so dass man nur die 5 benötigten Felder anklicken und ausfüllen kann. Das funktioniert. Alles, was nicht ausgefüllt werden soll, kann man gar nicht erst anklicken, um Verwirrungen zu vermeiden.

Leider funktioniert es nur so lange, bis ich die Datei gespeichert und neu geladen habe. Danach kann man in die gesperrten Zellen zwar weiterhin nichts reinschreiben, aber jetzt, nach dem Laden, kann man die für das Anklicken gesperrten Zellen wieder anklicken.

Mache ich etwas falsch oder ist das ein Bug?

Version: Apache OpenOffice 4.1.3
AOO413m1(Build:9783) - Rev. 1761381
2016-09-29 02:39:19

Windows 10

Mondblatt24
****
Beiträge: 127
Registriert: So, 14.05.2017 16:11

Re: Zellschutz funktioniert nicht richtig

Beitrag von Mondblatt24 » Fr, 22.09.2017 13:40

Hallo,
das Anklicken soll ja nicht verhindert werden,
sondern das Überschreiben oder das Löschen der Daten in der gesperrten Zelle.
Also alles in Ordnung.


MfG Peter
LO 5.3.7; LO 5.4.3; LO 5.4.3 Portable; AOO Portable 4.1.4

Mondblatt24
****
Beiträge: 127
Registriert: So, 14.05.2017 16:11

Re: Zellschutz funktioniert nicht richtig

Beitrag von Mondblatt24 » Fr, 22.09.2017 13:56

Hallo,
da bin ich wieder. Ein kleiner Nachtrag.
Unter den Optionen gibt es noch ein paar Wahlmöglichkeiten.

Gruß Peter
Dateianhänge
Bild.PNG
Bild.PNG (10.49 KiB) 820 mal betrachtet
LO 5.3.7; LO 5.4.3; LO 5.4.3 Portable; AOO Portable 4.1.4

Miriskre
Beiträge: 7
Registriert: So, 02.12.2007 17:21

Re: Zellschutz funktioniert nicht richtig

Beitrag von Miriskre » Sa, 23.09.2017 05:47

Genau mit diesen Wahlmöglichkeiten konnte ich ja verhindern, dass nicht benötigte Zellen angeklickt werden können.

Funktioniert ja auch.

Leider nur so lange, bis ich die Datei geschlossen und wieder neu geöffnet habe.

Danach sind sie weiterhin gegen Überschreiben gesperrt, aber nicht gegen Anklicken.

Wird wohl ein Bug sein?

Oder gibt es dafür eine logische Erklärung?

Stephan
********
Beiträge: 10168
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Zellschutz funktioniert nicht richtig

Beitrag von Stephan » Sa, 23.09.2017 06:05

Wird wohl ein Bug sein?
Die Funktion funktioniert bei mir.
Oder gibt es dafür eine logische Erklärung?
z.B. wäre es ein Grund das Du in einem ungeeigneten Format speicherst, im Konkreten funktionieren beispielsweise ods und xls aber z.B. sxc nicht.

Gruß
Stephan

HeritzP
*****
Beiträge: 235
Registriert: So, 22.12.2013 11:23

Re: Zellschutz funktioniert nicht richtig

Beitrag von HeritzP » Sa, 23.09.2017 08:35

Hallo,

diesen Effekt habe Ich auch unter Linux, mit der Version 4.1.2.
Wenn die Datei mit *.ods gespeichert wird, ist dieser Schutz aufgehoben.

Gruß HeritzP

Stephan
********
Beiträge: 10168
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Zellschutz funktioniert nicht richtig

Beitrag von Stephan » Sa, 23.09.2017 10:29

diesen Effekt habe Ich auch unter Linux, mit der Version 4.1.2.
und ich habe ihn unter Windows.

Ich verstehe nur die Relevanz nicht, denn hier im Thread ging es um AOO 4.1.3, und darauf bezog sich deshalb meine erste Antwort, für die ich weitere Programmversionen nicht berücksichtigt hatte.


Gruß
Stephan

Stephan
********
Beiträge: 10168
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Zellschutz funktioniert nicht richtig

Beitrag von Stephan » Sa, 23.09.2017 10:37

Korrektur

Ich muss mich korrigieren:

bei 4.1.3 funktioniert es nur mit Speicherformat xls das die Nichtauswählbarkeit beim erneuten Öffnen erhalten bleibt.


Gruß
Stephan

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 15 Gäste