Häufigkeit vorkommender Werte zählen aber jeden Wert nur einmal auflisten

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Bommel
*
Beiträge: 18
Registriert: Di, 01.12.2009 18:12

Häufigkeit vorkommender Werte zählen aber jeden Wert nur einmal auflisten

Beitrag von Bommel » So, 09.09.2018 15:42

Hallo,

in einer Tabelle sollen in Spalte A Werte stehen, in Spalte B jeder vorkommende Wert einmal angezeigt werden und daneben in Spalte C die Häufigkeit jedes Wertes angezeigt werden. Hier habe ich etwas Ähnliches für Excel gefunden: https://www.mrexcel.com/forum/excel-que ... ost3307823
Weiß jemand, wie ich die Formel - in Zelle D2 in dem verlinkten Beitrag - für Calc anpassen muss?

Beispiel:

Code: Alles auswählen

Spalte A	Spalte B	Spalte C
 Wert		 Wert	       Häufigkeit
  AA		  MM		   3
  OO		  OO		   2
  MM		  AA		   2
  OO		  UU		   1
  UU
  MM
  AA
  MM
Vielen Dank!

Helmut_S
***
Beiträge: 56
Registriert: So, 29.10.2017 11:29

Re: Häufigkeit vorkommender Werte zählen aber jeden Wert nur einmal auflisten

Beitrag von Helmut_S » So, 09.09.2018 16:51

Hallo Bommel, am einfachsten machst du das so:
Spaltenkopf A markieren (das markiert die gesamte Spalte A) alternativ den Bereich in Spalte markieren, der Daten enthält.
Menue Daten >Weitere Filter >Standardfilter. Diesen stellst du so ein wie auf dem Screenshot.
Klick auf ok filtert Duplikate und kopiert Ergebnis nach Spalte B
In C2 gibst du ein =ZÄHLENWENN(A:A;B2) Diese Formel kannst du am unteren rechten Eck der Zelle C2 nach unten ziehen so weit deine Daten reichen.
P.S. den Standardfilter erreichst du auch über die Schaltfläche Autofilter der Standard-Menueleiste.
Calc_Standardfilter.png
Calc_Standardfilter.png (30.69 KiB) 1203 mal betrachtet
Gruß, Helmut
Dateianhänge
Zählenwenn.ods
(8.85 KiB) 50-mal heruntergeladen
openSUSE Leap 15.0 / Win 10-64
LO 6.1.3, AOO 4.1.5

heike b.

Re: Häufigkeit vorkommender Werte zählen aber jeden Wert nur einmal auflisten

Beitrag von heike b. » Di, 13.11.2018 19:21

hallo..., sowas in der art suche ich gerade..., funktioniert das auch, wenn die zellen text (z.b. vorgegebene antworten auf eine frage) enthält, oder artikelnummern als kombination aus zahlen und buchstaben?

mikeleb
******
Beiträge: 742
Registriert: Fr, 09.12.2011 16:50

Re: Häufigkeit vorkommender Werte zählen aber jeden Wert nur einmal auflisten

Beitrag von mikeleb » Di, 13.11.2018 19:52

Hallo,
probiere es aus.
Noch einfacher und komfortabler funktioniert es per Pivottabelle.
Gruß,
mikeleb

heike b.

Re: Häufigkeit vorkommender Werte zählen aber jeden Wert nur einmal auflisten

Beitrag von heike b. » Di, 13.11.2018 21:16

aaaaaah... da war doch noch was - danke, manchmal sieht man den wald vor lauter bäumen nicht ;) - ist allerdings schon über 10 jahre her, dass ich das zuletzt gebraucht hab, da kann man das schon mal aus den augen verlieren. na, nun bin ich da bals wieder fit

Antworten