[Gelöst] Verschachtelte WENN-Formel inklusive ISTLEER

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Pat01
Beiträge: 2
Registriert: Fr, 02.11.2018 23:55

[Gelöst] Verschachtelte WENN-Formel inklusive ISTLEER

Beitrag von Pat01 » Fr, 02.11.2018 23:58

Hallo zusammen,

nach an mehreren Tagen des Suchens und Suchens und Knobelns und Probierens hoffe ich nun,
hier die Lösung zu finden. Ich hoffe, gut schildern zu können, was erreicht werden soll.

In einer Tabelle muß ich in zwei Zellen Wahrheitsprüfungen auf Befüllung durchführen.
Solange beide Zellen (F31, G31) leer sind, sollten beide Ergebnisfelder (L31, M31) eine
"0" zeigen (oder alternativ leer bleiben).

Wird nun (lediglich) eine der Beiden (F31, G31) mit einem Wert befüllt, so soll entweder
in (L31) oder in (M31) ein Hinweis auf die noch fehlende zweite Eingabe erscheinen (z. B. "WERT??").

Werden dagegen in beide Zellen (F31) und (G31) Werte eingetragen, so soll die erste Berechnung
im ersten Ergebnisfeld (L31) ausgeführt werden und eine Weitere im zweiten Ergebnisfeld (M31).


Was ich bis jetzt habe:

Die reine Prüfung auf Befüllung funktioniert. Ich hatte auch die ISTLEER-Variante probiert,
und auch dies ging. Hier habe ich erstmal zum Test eine "2" als "Sonst" gesetzt.

Code: Alles auswählen

=WENN(UND(F31="";G31="");0;2)
Auch die Zeitberechnung habe ich hinbekommen, und sie funktioniert alleine für sich. Hierbei wird
zusätzlich geprüft, ob der Wert in (G31) auf den nächsten Tag fällt und entsprechend berechnet.

Code: Alles auswählen

=WENN(G31>F31;G31-F31;G31+1-F31)*24
In Ergebnisfeld-2 (M31) erfolgt eine weitere Berechnung/Ausgabe mit dieser Formel, die ebenfalls
alleine für sich funktioniert:

Code: Alles auswählen

=SUMME(L31)*2+K31+I31

1. Problem:
Die beiden ersten Formeln zu verschmelzen; ich erhalte bei allen Versuchen nur Error-Meldungen.


2. Problem:
Der jeweilige Hinweis auf den noch fehlenden Wert. Als Kompromißlösung sah ich an, diese Prüfung
nicht zusätzlich noch mit in (L31) zu stecken, sondern in (M31) zu integrieren, was jedoch leider so
NICHT funktioniert:

Code: Alles auswählen

=WENN(UND(F31>0;G31>0);SUMME(L31)*2+K31+I31);WENN(UND(F31>0;G31<0);"WERT??";WENN(und/F31<0;G31>0);"WERT??";"")))

Jetzt sehe ich wohl vor lauter Bäumen keinen Wald mehr.

Kann mir hier jemand helfen? Vielen Dank schon mal fürs Lesen bis hierher.

Gruß,
Pat
Zuletzt geändert von Pat01 am So, 04.11.2018 19:13, insgesamt 1-mal geändert.

Mondblatt24
*****
Beiträge: 258
Registriert: So, 14.05.2017 16:11

Re: Verschachtelte WENN-Formel inklusive ISTLEER

Beitrag von Mondblatt24 » Sa, 03.11.2018 07:16

Hallo,
Crossposting!

Peter
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Pat01
Beiträge: 2
Registriert: Fr, 02.11.2018 23:55

Re: Verschachtelte WENN-Formel inklusive ISTLEER

Beitrag von Pat01 » So, 04.11.2018 19:13

:pray: :pray:

Stephan
********
Beiträge: 10639
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: [Gelöst] Verschachtelte WENN-Formel inklusive ISTLEER

Beitrag von Stephan » Mo, 05.11.2018 08:02

1. Problem:
Die beiden ersten Formeln zu verschmelzen; ich erhalte bei allen Versuchen nur Error-Meldungen.
Wenn die zweite Formel den Sonst-Wert darstellt (das tut sie meiner Annahme nach), dann sollte die Zusammenfassung so lauten:

=WENN(UND(F31="";G31="");0;WENN(G31>F31;G31-F31;G31+1-F31)*24)


Gruß
Stephan

Gast

Re: [Gelöst] Verschachtelte WENN-Formel inklusive ISTLEER

Beitrag von Gast » Mo, 05.11.2018 12:24

Hallo Stephan,

danke Dir. Ja, ich meinte zwar, das so auch zuvor probiert zu haben, doch vielleicht fehlte mir
auch die Klammer am Ende (...oder sonst irgendetwas). Hab wohl auch irgendwann die Formel
vor Zeichen nicht mehr gesehen.

Anyway, auch der Rest ist gelöst dank netter Hilfe im - ich nenne es mal "Schwesterforum".

So die Lösungen auch hier jemandem dienlich sein könnten, hier der Link zu diesem Thread.

Grüße,
Pat

Antworten