verschachtelte WENN Abfrage

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Shabone

verschachtelte WENN Abfrage

Beitrag von Shabone » Mo, 20.05.2019 11:15

Hallo Zusammen,
ich steh auf dem Schlauch.
In A1 steht die E-Mail-Adresse und ich versuche mit der Formel
=WENN(SUCHEN(".de";A2);"de";WENN(SUCHEN(".at";A2);"at";WENN(SUCHEN(".ch";A2);"ch";"X")))
den Länder-Isocode in eine neue Spalte zu bekommen.
Leider klappt das nur mit den .de Adressen sonst kommt immer #WERT!
Achso und wenn weder .de, .at oder .ch ist soll es X werden.
Vielen Dank schonmal für Eure Hilfe

Andreas

Mondblatt24
*****
Beiträge: 425
Registriert: So, 14.05.2017 16:11

Re: verschachtelte WENN Abfrage

Beitrag von Mondblatt24 » Mo, 20.05.2019 11:29

Hallo Andreas,
damit sollte es funktionieren.

Code: Alles auswählen

=WENN(ISTZAHL(SUCHEN(".de";A2));"de";WENN(ISTZAHL(SUCHEN(".at";A2));"at";WENN(ISTZAHL(SUCHEN(".ch";A2));"ch";"X")))
Gruß Peter
Win.10 (x64)__ LO 6.2.5 (x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden. Anleitung

Shabone

Re: verschachtelte WENN Abfrage

Beitrag von Shabone » Mo, 20.05.2019 11:33

und hier die Lösung:
=WENN(ISTFEHLER(SUCHEN(".de";A1));WENN(ISTFEHLER(SUCHEN(".at";A1));WENN(ISTFEHLER(SUCHEN(".ch";A1));"X";"ch");"at");"de")

Shabone

Re: verschachtelte WENN Abfrage

Beitrag von Shabone » Mo, 20.05.2019 11:35

Mondblatt24 hat geschrieben:
Mo, 20.05.2019 11:29
Hallo Andreas,
damit sollte es funktionieren.

Code: Alles auswählen

=WENN(ISTZAHL(SUCHEN(".de";A2));"de";WENN(ISTZAHL(SUCHEN(".at";A2));"at";WENN(ISTZAHL(SUCHEN(".ch";A2));"ch";"X")))
Gruß Peter
Hallo Peter,
ja vielen Dank funktioniert auch super.
Viele Wege führen nach Rom.

Andreas

Antworten