ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Benutzeravatar
hxCtYCQgSI70IdDPpFWP
**
Beiträge: 30
Registriert: Mo, 22.08.2016 16:58

ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Beitrag von hxCtYCQgSI70IdDPpFWP » Sa, 15.06.2019 10:17

Ich verwende in OpenOffice Calc die Funktion

Code: Alles auswählen

ZÄHLENWENN
. Dabei habe ich
eine Spalte A, in der Betreffzeilen stehen, eine weitere B, in der die
Funktion steht und eine weitere J, in der nach A gesucht wird.

Die Funktion sieht also in Zelle B2 so aus: =ZÄHLENWENN($J$2:$J$863;A2)
und in Zelle B3 so aus: =ZÄHLENWENN($J$2:$J$863;A3) usw.

Das funktioniert auch gut. Manchmal gibt es einen Rechtschreibfehler in
der Spalte J, doch wenn ich die richtige Version der Zelle von Spalte A
in die Zelle in Spalte J kopiere, sie also tatsächlich jetzt gleich sein
sollten, steht bei der Zelle in Spalte B immer noch 0 statt 1.
Zuletzt geändert von hxCtYCQgSI70IdDPpFWP am Sa, 15.06.2019 13:21, insgesamt 1-mal geändert.

Gast

Re: [OpenOffice Calc] ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Beitrag von Gast » Sa, 15.06.2019 10:24

Servus,

die Texte werden nicht gleich sein.
Es gibt die Funktion identisch() zum Vergleichen.

Gast

Benutzeravatar
hxCtYCQgSI70IdDPpFWP
**
Beiträge: 30
Registriert: Mo, 22.08.2016 16:58

Re: [OpenOffice Calc] ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Beitrag von hxCtYCQgSI70IdDPpFWP » Sa, 15.06.2019 10:31

Hallo.

Wenn ich die Zelle in Spalte A markiere, Strg-C drücke, dann die Zelle in Spalte J markiere und Strg-V drücke, sollten sie gleich sein, oder nicht?

=IDENTISCH(A2;J114) ergibt wahr. Trotzdem steht bei B 0.

Gast

Re: [OpenOffice Calc] ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Beitrag von Gast » Sa, 15.06.2019 10:35

Servus,

dann müsste auch die Funktion richtig zählen.
Eine Beispieldatei zum Nachsehen bitte.

Gast

Benutzeravatar
hxCtYCQgSI70IdDPpFWP
**
Beiträge: 30
Registriert: Mo, 22.08.2016 16:58

Re: [OpenOffice Calc] ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Beitrag von hxCtYCQgSI70IdDPpFWP » Sa, 15.06.2019 10:53

Test.ods
(10.51 KiB) 26-mal heruntergeladen

Gast

Re: [OpenOffice Calc] ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Beitrag von Gast » Sa, 15.06.2019 11:03

Servus,

unter Extras, Einstellungen, OpenOffice Calc, Berechnungen, reguläre Ausdrücke zulassen deaktivieren.

Gast

Benutzeravatar
hxCtYCQgSI70IdDPpFWP
**
Beiträge: 30
Registriert: Mo, 22.08.2016 16:58

Re: [OpenOffice Calc] ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Beitrag von hxCtYCQgSI70IdDPpFWP » Sa, 15.06.2019 11:04

Wenn ich dich nicht hätte...

Gast

Re: [OpenOffice Calc] ZÄHLENWENN gibt 0 aus, auch wenn ein Eintrag gleich ist

Beitrag von Gast » Sa, 15.06.2019 11:05

Servus,

alternativ kann auch Summenprodukt verwendet werden.

Code: Alles auswählen

=SUMMENPRODUKT($J$2:$J$863=A2)
Gast

Antworten