Writer: Neu aus Explorer=keine Sprache

spezielle Probleme mit AOO/LO unter Windows

Moderator: Moderatoren

mamo
****
Beiträge: 116
Registriert: Do, 25.10.2012 14:20

Writer: Neu aus Explorer=keine Sprache

Beitrag von mamo » Fr, 11.10.2013 10:25

Hallo OO-Freunde,

wenn ich aus dem Windowsexplorer heraus eine Neue OO-Datei anlege, diese dann öffne ist merkwürdigerweise keine Sprache hinterlegt, die Rechtschreibprüfung ist damit deaktiviert. Wenn eine neue Datei aus OO erzeugt wird, wird natürlich auf die Standardvorlage zurückgegriffen. Auf was greif denn das System zurück, wenn es nicht die Standardvorlage verwendet??

Danke für Euren Input!

OO341
Win 7


Moderation,4: verschoben in WINDOWS-Unterbereich, wo alle WINDOWS-betreffenden Fragen hin gehören; Betreff angepasst
Dateianhänge
Unbenannt.PNG
Unbenannt.PNG (13.29 KiB) 6865 mal betrachtet

Benutzeravatar
lorbass
********
Beiträge: 4023
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von lorbass » Fr, 11.10.2013 12:58

mamo hat geschrieben:Auf was greif denn das System zurück, wenn es nicht die Standardvorlage verwendet??
Wähle im Writer den Menüpunkt Datei → Eigenschaften… und lies die verwendete Vorlage auf im Dialog Eigenschaften auf dem Registerblatt Allgemein ganz unten ab.

Gruß
lorbass

mamo
****
Beiträge: 116
Registriert: Do, 25.10.2012 14:20

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von mamo » Fr, 11.10.2013 13:53

lorbass hat geschrieben:
mamo hat geschrieben:Auf was greif denn das System zurück, wenn es nicht die Standardvorlage verwendet??
Wähle im Writer den Menüpunkt Datei → Eigenschaften… und lies die verwendete Vorlage auf im Dialog Eigenschaften auf dem Registerblatt Allgemein ganz unten ab.

Gruß
lorbass

Leider ist dort gar nichts hinerlegt! :?
Dateianhänge
Vorlage.png
Vorlage.png (35.29 KiB) 6842 mal betrachtet

Benutzeravatar
lorbass
********
Beiträge: 4023
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von lorbass » Fr, 11.10.2013 14:11

mamo hat geschrieben:Leider ist dort gar nichts hinerlegt!
Was dann ja alles erklärt.

Ordne dem Dokument eine Dokumentvorlage zu. Installiere dazu die Extension Template Changer.

Gruß
lorbass

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von pmoegenb » Fr, 11.10.2013 17:05

Mindestens LibreOffice benutzt für neue Dokumente aus dem Windows-Explorer über das Kontextmenü Option Neu im Verzeichnis \Program Files (x86)\LibreOffice 4\share\template\shellnew die Datei soffice.odt als Dokumentvorlage.

Ich meine Stephan hätte einmal Ähnliches für OOo/AOO beschrieben. Man könnte zumindest in der Registry unter dem Schlüssel
  • HKEY_CLASSES_ROOT\.odt\opendocument.WriterDocument.1\ShellNew
nachschauen.

Die Zuweisung einer Standardvorlage innerhalb des Office-Programmes bewirkt bei einem neuen Dokument über den Windows-Explorer nichts.
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

mamo
****
Beiträge: 116
Registriert: Do, 25.10.2012 14:20

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von mamo » Mo, 14.10.2013 07:50

Ok. das werde ich beides mal probieren. THX!

mamo
****
Beiträge: 116
Registriert: Do, 25.10.2012 14:20

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von mamo » Di, 15.10.2013 07:53

mamo hat geschrieben:Ok. das werde ich beides mal probieren. THX!

...so, probiert.

Ergebnis: Wenn ich die Standard Vorlage ändere, dann wird diese auch aus dem Explorer heraus verwendet. Ist keine Standardvorlage gesetzt bzw. wurde diese auf den Ursprung zurückgesetzt, greift irgend eine andere Einstellung.

Danke Euch für Eure Hilfen. Wenn noch jemand eine andere Lösung anzubieten hat - immer her damit! ;)

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von pmoegenb » Di, 15.10.2013 10:34

Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

mamo_gast

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von mamo_gast » Di, 15.10.2013 13:22


Dieser Link war Gold wert!

Aber, wenn man eine eigene Vorlage als Standard gesetzt hat liegt diese ebenfalls unter:

C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Templates (... soffice.odt)

Wenn man jetzt die Vorlage auf Standard zurück setzten wöllte, muss man ebenso im o.g. Ordner die Vorlage entfernen, ansonsten greift der Explorer auf diese zurück!

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von pmoegenb » Di, 15.10.2013 14:29

mamo_gast hat geschrieben: Aber, wenn man eine eigene Vorlage als Standard gesetzt hat liegt diese ebenfalls unter:
C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Templates (... soffice.odt)
Wenn man jetzt die Vorlage auf Standard zurück setzten wöllte, muss man ebenso im o.g. Ordner die Vorlage entfernen, ansonsten greift der Explorer auf diese zurück!
Das wäre mir neu.

Dokumentvorlagen, auch Eigene, ob als Standardvorlage gesetzt oder nicht, befinden sich in den Verzeichnissen die unter Extras/Einstellungen.../OpenOffice/Pfade definiert sind und haben die Dateiendung .ott. Möglicher Weise hast manuell etwas reinkopiert.
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

mamo
****
Beiträge: 116
Registriert: Do, 25.10.2012 14:20

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von mamo » Mi, 16.10.2013 09:11

pmoegenb hat geschrieben:
mamo_gast hat geschrieben: Aber, wenn man eine eigene Vorlage als Standard gesetzt hat liegt diese ebenfalls unter:
C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Templates (... soffice.odt)
Wenn man jetzt die Vorlage auf Standard zurück setzten wöllte, muss man ebenso im o.g. Ordner die Vorlage entfernen, ansonsten greift der Explorer auf diese zurück!
Das wäre mir neu.

Dokumentvorlagen, auch Eigene, ob als Standardvorlage gesetzt oder nicht, befinden sich in den Verzeichnissen die unter Extras/Einstellungen.../OpenOffice/Pfade definiert sind und haben die Dateiendung .ott. Möglicher Weise hast manuell etwas reinkopiert.

....nee. Probiere es mal aus.

KLar sie weden im Localen OO-Profil hinterlegt, aber ebenso unter C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Templates (... soffice.odt) - zuminsdestens bei unsere Umgebung. Ob das nun generell so ist müsste man vlt. mal nachforschen.

EInen Dank an alle, die sich bis hierher schon mit diesem Thread beschäftigt haben! THX!

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von pmoegenb » Mi, 16.10.2013 09:21

mamo hat geschrieben:....nee. Probiere es mal aus.
KLar sie weden im Localen OO-Profil hinterlegt, aber ebenso unter C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Templates (... soffice.odt) - zuminsdestens bei unsere Umgebung. Ob das nun generell so ist müsste man vlt. mal nachforschen.
Da kann ich probieren so oft ich will, dann tritt das nicht ein was Du vorgibst.
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

tetmor

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von tetmor » Di, 25.04.2017 10:59

Ich möchte meine Erfahrung und eine Lösung mit demselben oder zumindest ähnlichem Problem schildern.

Problem: Open Office greift nicht mehr auf Wörterbücher und Thesaurus zu. Die automatische Korrekturprüfung unterkringelt alles rot.
Der Zugriff auf die Wörterbücher geht nach einem schweren Systemabsturz von OO und anschließenden Wiederherstellung verloren.

Das Problem kenne ich seit Jahren.

Lösung: Open Office vollständig neu installieren.
Ich gehe davon aus, dass du OO als Admin installiert hast und allen Benutzern die Mitbenutzung erlaubst. Im Zuge der Neuinstallation sind folgende Schritte durchzuführen:
1) den Pfad, indem OO installiert ist, löschen oder ungültig machen. Bei mir lautet er: C:\Programme(x86)\OpenOffice 4. Ich mache ihn ungültig, indem ich ihn umbenenne in C:\Programme(x86)\OpenOffice 4(alt).
2) Die von OO verwendeten Pfade löschen oder ungültig machen. Wo die sich genau befinden, erfährst du, wenn du in OO wählst: EXTRAS – EINSTELLUNGEN... - OPONOFFICE – PFADE. Bei mir steht da z. B. C:\User\“Benutzername“\AppData\Roaming\OpenOffice\4\user\...
Dieser Pfad führt zu 6 Dateien. Ich mache ihn ungültig, indem ich ihn ändere in C:\User\“Benutzername“\AppData\Roaming\OpenOffice(alt)\4\user\...
Den Pfad C:\User\“Benutzername“\AppData\Local\Temp lasse ich unverändert
3) Punkt 2) wiederhole ich für alle Benutzer, die auf dem PC mit OO arbeiten dürfen.
4) Ich führe eine Neuinstallation von OO auf der Admin-Ebene durch.
Ergebnis: Open Office funktioniert wieder tadellos.
Ich habe das auf meinem Windows 10 Rechner gestern so durchgeführt. Vorher habe ich mit OO 4.1.2 gearbeitet und bei der Gelegenheit das Upgrade auf auf OO 4.1.3 durchgeführt. Es geht vermutlich noch einfacher, habe ich aber noch nicht ferifiziert.

tetmor

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von tetmor » Di, 25.04.2017 11:24

sind ein paar Fehler drin, tut mir leid. Sachlich aber okay.

Thomas Mc Kie
******
Beiträge: 880
Registriert: Mo, 12.04.2010 00:37

Re: Writer: Neu aus Explorer=keine Sprache

Beitrag von Thomas Mc Kie » Di, 25.04.2017 13:24

tetmor hat geschrieben:
Di, 25.04.2017 11:24
sind ein paar Fehler drin, tut mir leid. Sachlich aber okay.
Und ein grundsätzlicher, den dir sicher die Mods erklären oder du ihn durch lesen der in jedem Unterforum oben verlinkten "Allgemeine Hinweise zur Forumsbenutzung" auch selber finden kannst.
Grüße
Thomas

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste