Links in PDF-Export nicht anklickbar

Das Textverarbeitungsprogramm

Moderator: Moderatoren

Bieger
Beiträge: 6
Registriert: Fr, 29.01.2010 23:00
Wohnort: Pauschalhausen

Links in PDF-Export nicht anklickbar

Beitrag von Bieger » Fr, 29.01.2010 23:09

Zu diesem Thema habe ich schon eifrig gegoogelt, aber nichts gefunden, deswegen gehe ich davon aus, daß ich entweder etwas falsch verstanden habe, oder etwas falsch mache.

Ich habe Hyperlinks in einem Dokument (mit http-Zielen), im Writer kann ich die auch mit Ctrl-Klick benutzen. Aber wenn ich ein PDF daraus erstelle (über "Exportieren als PDF") und im Adobe Reader anzeigen lasse, dann sind die Links zwar irgendwie drin, denn wenn man mit der Maus drüberfährt geht so ein gelber Kasten auf, mit einer Leerzeile und in der nächsten Zeile dem Link. Aber anklicken geht nicht, da passiert einfach nichts. Öffne ich dagegen das odt mit TextMaker und exportiere es dort als PDF, dann sind die Links im PDF einwandfrei anklickbar.

Das Problem habe ich nicht erst seit der aktuellen Writer-Version, sondern schon immer. Ich bin ehrlich gesagt völlig ratlos, weil andere das Problem offensichtlich nicht haben, sonst hätte ich dazu im Web etwas gefunden.

Also, bitte helft mir auf die Sprünge, wie man ordentliche Links im PDF hinbekommt :-)

hylli
*******
Beiträge: 1632
Registriert: Mi, 22.02.2006 19:37

Re: Links in PDF-Export nicht anklickbar

Beitrag von hylli » Sa, 30.01.2010 09:40

Mach doch mal ein Beispieldokument in ODT und exportiere es nach PDF. Stelle beide Dateien mal hier zur Verfügung.

Hylli
Ein Dankeschön für eine Lösung tut nicht weh!
Wer eine Lösung selbst findet, sollte die für die Nachwelt auch posten!

Geschäftlich: LibreOffice 5.1.x ("Still") unter Windows 7 32/64bit
Privat: LibreOffice 5.x unter Linux Mint 18.x Cinnamon 64bit u. Arch Anywhere "Mate"

Bieger
Beiträge: 6
Registriert: Fr, 29.01.2010 23:00
Wohnort: Pauschalhausen

Re: Links in PDF-Export nicht anklickbar

Beitrag von Bieger » Sa, 30.01.2010 15:42

Gerne. Ich habe das Beispieldokument als odt, als exportiertes pdf beigelegt und noch einen Screenshot vom Adobe Reader, wie er den Link darstellt. Anklickbar ist er, wie gesagt, im Adobe Reader nicht.
Dateianhänge
linktest.zip
ZIP-Datei mit den drei Dateien
(102.5 KiB) 53-mal heruntergeladen

limux
**
Beiträge: 48
Registriert: Fr, 08.01.2010 18:53

Re: Links in PDF-Export nicht anklickbar

Beitrag von limux » Sa, 30.01.2010 16:50

Hi,

so wie es aussieht hast Du beim exportieren die "PDF/A-Option" aktiviert. Falls dies zutrifft, ändere dies mal und versuch es nochmal. Sollte dann klappen, bei mir ist es jedenfalls so.

Gruß limux

Bieger
Beiträge: 6
Registriert: Fr, 29.01.2010 23:00
Wohnort: Pauschalhausen

Re: Links in PDF-Export nicht anklickbar

Beitrag von Bieger » Sa, 30.01.2010 18:08

limux hat geschrieben:so wie es aussieht hast Du beim exportieren die "PDF/A-Option" aktiviert. Falls dies zutrifft, ändere dies mal und versuch es nochmal. Sollte dann klappen, bei mir ist es jedenfalls so.
Gute Güte, du hast recht! Auf diesen Zusammenhang wäre ich nie gekommen.

Problem ist, daß ich auf PDF/A mehr oder weniger angewiesen bin, weil die verwendeten Fonts eingebettet sein sollen - eben zwecks Langzeitarchivierbarkeit. Ist dieses Verhalten des Adobe Reader bei PDF/A normal oder ist das ein Bug seitens OpenOffice Writer?

Danke und Gruß,
Bieger

limux
**
Beiträge: 48
Registriert: Fr, 08.01.2010 18:53

Re: Links in PDF-Export nicht anklickbar

Beitrag von limux » Sa, 30.01.2010 19:38

Hallo,

ich denke schon, dass dies in Ordnung ist, siehe auch ->Hier. Eigentlich klar, denn das verlinkte Ziel kann ja jederzeit gelöscht werden .

Gruß limux

Bieger
Beiträge: 6
Registriert: Fr, 29.01.2010 23:00
Wohnort: Pauschalhausen

Re: Links in PDF-Export nicht anklickbar

Beitrag von Bieger » Sa, 30.01.2010 19:58

limux hat geschrieben:ich denke schon, dass dies in Ordnung ist, siehe auch ->Hier.
Wobei die Antwort in dem verlinkten Beitrag eine typische "Null-Antwort" ist, weil sie die Frage nicht beantwortet ;-)
Eigentlich klar, denn das verlinkte Ziel kann ja jederzeit gelöscht werden .
Schon richtig, aber wäre der Link anklickbar, würde er wenigstens solange funktionieren, wie das Ziel existiert. So, wie der Adobe Reader den Link behandelt, ist der Link von Anfang an unbrauchbar. :lol:

Aber jetzt da ich weiß, daß es an PDF/A hängt, habe ich auch etwas herausgefunden:

1. Es ist wohl die Schuld des Adobe Readers, denn ich habe testweise mal die gleiche Datei mit dem Foxit Reader geöffnet, der behandelt den Link so wie man es erwartet. Das steht ja auch in dem von dir verlinkten Posting.

2. Hyperlinks sind auch in PDF/A erlaubt, siehe hier http://www.pdfa.org/doku.php?id=artikel ... cal-side_3.
As a rule, URL links and other links are permitted - they must be ‘somehow’ displayed by a PDF/A viewer, but they must not necessarily be executed. As far as the standard is concerned, it does not matter whether or not a link references a valid target.
Für mich ist damit die Frage beantwortet: Es ist eine Entscheidung von Adobe, Links in PDF/A-Dokumenten zu deaktivieren.

Danke!

Mikoo

Re: Links in PDF-Export nicht anklickbar

Beitrag von Mikoo » Mo, 01.02.2010 11:13

Bieger hat geschrieben:Es ist wohl die Schuld des Adobe Readers
Hi, kann ich nicht bestätigen.

Leider bist Du bei Deinen Angaben ebenso unkonkret, wie viele andere, die Fehler entdecken: Es fehlen Angaben zu den verwendeten Programmversionen.

Um die Sache mal etwas zu konkretisieren: Ich habe mit OOo 2.4, 3.1 und der aktuellen Entwicklerversion getestet. Die PDF-A Dateien werden überall mit funktionierenden Links erstellt. Die Links sind im AcrobatReader (Vers. 8) problemlos anklickbar und verbinden zur gewünschten Seite (in meinem Fall http://www.openoffice.org ;-)

Daher gehe ich mal davon aus, das es in keinem Fall ein OOo-Problem ist, aber auch kein pauschales Acrobat-Reader Problem sein kann.

Warum wird immer so schnell verallgemeinert? Mikoo

Bieger
Beiträge: 6
Registriert: Fr, 29.01.2010 23:00
Wohnort: Pauschalhausen

Re: Links in PDF-Export nicht anklickbar

Beitrag von Bieger » Mo, 01.02.2010 20:55

Mikoo hat geschrieben:Warum wird immer so schnell verallgemeinert?
Wieso verallgemeinert? Weil ich keine extra Angabe über die Version machte, ging ich davon aus, daß jedem klar wäre, daß es die aktuelle ist. Also 9.3.0. Ich habe keine 8er zur Verfügung, aber mit Foxit Reader probiert. Und da es mit dem ging und mit Adobe Reader 9 nicht, war meine Schlußfolgerung, daß es wohl am Adobe Reader liegen müsse. Ich hätte natürlich auch den Mond oder den Schnee auf dem Dach in Verdacht haben können, aber da Dokument A mit Anwendung B nicht geht und mit Anwendung C schon, wollte ich lieber unbotmäßig verallgemeinern und Anwendung B die Schuld geben. Vielleicht baut auch Anwendung O in Dokument A eine Weiche ein, damit A mit C geht, aber nicht mit B. Oder B mag O nicht und tut deswegen so als wäre A kaputt, nur weiß C nichts davon. Mir ist das zu theoretisch, deswegen halte ich mich an das was ich sehe und ich sehe, daß A mit C geht, mit B nicht, also hat B auf der Reise nach Jerusalem verloren.

limux
**
Beiträge: 48
Registriert: Fr, 08.01.2010 18:53

Re: Links in PDF-Export nicht anklickbar

Beitrag von limux » Mo, 01.02.2010 21:26

Hallo Bieger,

ist dir eigentlich schon aufgefallen, dass du jeden von der Seite anmachst, der versucht, etwas klarzustellen oder einfach nur behilflich zu sein? Dank Mikoo ist nun bekannt, dass es eben KEIN generelles Acrobat Problem ist, sondern bisher nur die Veersion 9.3.0 getestet ist.

Bieger
Beiträge: 6
Registriert: Fr, 29.01.2010 23:00
Wohnort: Pauschalhausen

Re: Links in PDF-Export nicht anklickbar

Beitrag von Bieger » Mo, 01.02.2010 22:14

limux hat geschrieben:Hallo Bieger,

ist dir eigentlich schon aufgefallen, dass du jeden von der Seite anmachst, der versucht, etwas klarzustellen oder einfach nur behilflich zu sein?
Jeden? Das ist eine Verallgemeinerung. Ich habe mich nur gegen jemanden zur Wehr gesetzt, der sich aufplustert, weil ich "Adobe Reader" anstatt "Adobe Reader 9.3.0" schrieb.
Dank Mikoo ist nun bekannt, dass es eben KEIN generelles Acrobat Problem ist, sondern bisher nur die Veersion 9.3.0 getestet ist.
Oh mein Gott, es ist Mikoo! Mikoo, wir haben Mikoo hier! Er hat Acrobat gerettet! Moment, vielleicht ist dir schon aufgefallen, daß der Acrobat Reader seit Jahren schon Adobe Reader heißt. Nein? Komisch.

Wenn du die von dir verlinkte Antwort komplett gelesen hättest, wäre dir schon früher aufgefallen, daß es kein Problem des PDFs ist, sondern des Readers. Nichts anderes hatte ich nochmals wiederholt. Oh Mist, stimmt nicht, es war ja Mikoo, der den Reader gerettet hat.

Benutzeravatar
Kruemel112
*****
Beiträge: 428
Registriert: Mi, 07.11.2007 13:02

Re: Links in PDF-Export nicht anklickbar

Beitrag von Kruemel112 » Di, 02.02.2010 14:46

Moin
das ist eine Frage der Einstellung beim Adobe Reader 9.3.0 (Lite), in den Voreinstellungen unter Dokument - ganz unten

(ein Grund mehr das Ding nicht mehr zu benutzen)

MfG
Meine Beiträge sind grundsätzlich von persönlichen Gefühlen, Meinungen oder Vorurteilen bestimmt!

hylli
*******
Beiträge: 1632
Registriert: Mi, 22.02.2006 19:37

Re: Links in PDF-Export nicht anklickbar

Beitrag von hylli » Di, 02.02.2010 15:23

Das war der entscheidende Tipp. Gilt auch für die "Vollversion" des Adobe Readers.

Hylli
Ein Dankeschön für eine Lösung tut nicht weh!
Wer eine Lösung selbst findet, sollte die für die Nachwelt auch posten!

Geschäftlich: LibreOffice 5.1.x ("Still") unter Windows 7 32/64bit
Privat: LibreOffice 5.x unter Linux Mint 18.x Cinnamon 64bit u. Arch Anywhere "Mate"

Mikoo

Re: Links in PDF-Export nicht anklickbar

Beitrag von Mikoo » Mi, 03.02.2010 14:18

Bieger hat geschrieben:Weil ich keine extra Angabe über die Version machte, ging ich davon aus, daß jedem klar wäre, daß es die aktuelle ist.
Du erwartest ernsthaft, das jeder im Ooo-Forum darüber informiert ist, was derzeit die aktuelle Version des Adobe Readers ist und daraus automatisch ersichtlich ist, das Du die auch benutzt? Selbst wenn, vielleicht ist das in drei Wochen auch noch so aber wie ist das in einem Jahr? Wohl eher nicht.

Ziemlich sicher ist dagegen, daß dieser Thread auch später noch von anderen Hilfesuchenden gefunden wird und die richten sich dann nach der pauschalen Aussage, die ein Nutzer namens Bieger glasklar analysiert hat: Der Adobe Reader kann das nicht – Punkt.

Tatsächlich ist es aber eine Einstellungssache und betrifft anscheinend nur eine bestimmte Versionsnummer. Wobei noch unbeantwortet ist, ob diese Funktion schon in den Voreinstellungen deaktiviert ist, oder weil jemand das nachträglich geändert hat.

Bieger hat geschrieben:Also, bitte helft mir auf die Sprünge, wie man ordentliche Links im PDF hinbekommt
Genau das wurde hier gemacht. Freiwillige Helfer haben sich netterweise um eine Lösung für DEIN Problem bemüht. Nachdem sich herausgestellt hatte, das Du mit OOo eine spezielle Form des PDF erstellst, OOo das korrekt exportiert, es kein allgemeines Problem des Adobe Readers ist und bekannt war, welche Version Du benutzt, konnte Krümel sogar einen genauen Hinweis geben, wo Du die entsprechende Einstellung findest.

Manchmal reicht es jedoch nicht, nur beim Programm die Einstellung zu ändern.

Gutes Gelingen, Mikoo

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 10 Gäste