SUMMEWENN() durchführen und vor dem Summieren noch Sinus() durchführen)

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

ramäro
Beiträge: 2
Registriert: Di, 07.11.2017 22:39

SUMMEWENN() durchführen und vor dem Summieren noch Sinus() durchführen)

Beitrag von ramäro » Di, 07.11.2017 23:07

Ich habe ein kleines Problem, bei welchem ich selber nicht weiter komme.

In einer Zeile (z.B. B2:Y2) sind Zahlen zwischen 0 und 360. Leider sind auch Messfehler enthalten, welche durch -999 oder -9999 gekennzeichnet sind.

Von den Zahlen in der Zeile B2:Y2 (z.B. 360; 90; 35; -9999; 200; ...) möchte ich jeweils den Sinuswert mit SIN(RAD()) nehmen und anschließend alle so entstandenen Werte summieren.

z.B. Sin(360) + Sin(90) + Sin(35) + Sin(200) = mein gesuchter Wert

Mein Problem ist, das ich nicht möchte, dass die -9999 oder -999 berücksichtigt wird.

Mit =SUMMEWENN(B2;Y2">-1") habe ich es hinbekommen, dass die Summe aus allen Zahlen ohne der -9999 gebildet wird. Allerding soll bei mir, nachdem die Fehlerwerte aussortiert wurden, vor dem Summieren noch der Sinus der einzelnen Werte berechnet werden.

Ich würde mich sehr freuen, wenn jemand eine Idee hat, wie ich dieses Problem lösen kann.
Vielen Dank im Vorraus :)

mikeleb
******
Beiträge: 683
Registriert: Fr, 09.12.2011 16:50

Re: SUMMEWENN() durchführen und vor dem Summieren noch Sinus() durchführen)

Beitrag von mikeleb » Mi, 08.11.2017 12:39

Hallo,

Code: Alles auswählen

=SUMMENPRODUKT(B2:Y2>=0;SIN(RAD(B2:Y2)))
Gruß,
mikeleb

Helmut_S
**
Beiträge: 38
Registriert: So, 29.10.2017 11:29

Re: SUMMEWENN() durchführen und vor dem Summieren noch Sinus() durchführen)

Beitrag von Helmut_S » Mi, 08.11.2017 18:18

Hallo, wollte nur bestätigen, dass die von mikeleb vorgeschlagene Formel das "Problem" perfekt löst. Unter Libreoffice heißt die Funktion RAD() (wie sie unter openoffice-Calc genannt wird) allerdings Bogenmass()
Gruß Helmut
openSUSE Leap 15.0 / Linux Mint 18.3 / Win 10-64
LO 6.04.2

Mondblatt24
*****
Beiträge: 220
Registriert: So, 14.05.2017 16:11

Re: SUMMEWENN() durchführen und vor dem Summieren noch Sinus() durchführen)

Beitrag von Mondblatt24 » Mi, 08.11.2017 19:15

Hallo,
Unter Libreoffice heißt die Funktion RAD() (wie sie unter openoffice-Calc genannt wird) allerdings Bogenmass()
oder GRAD() Falsch!!!!!

Gruß Peter
Zuletzt geändert von Mondblatt24 am Do, 09.11.2017 08:37, insgesamt 2-mal geändert.
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Helmut_S
**
Beiträge: 38
Registriert: So, 29.10.2017 11:29

Re: SUMMEWENN() durchführen und vor dem Summieren noch Sinus() durchführen)

Beitrag von Helmut_S » Do, 09.11.2017 08:21

@Mondblatt24, bist du sicher, dass du da nicht etwas verwechselst?
bogenmass.ods
(10.14 KiB) 24-mal heruntergeladen
Gruß Helmut
openSUSE Leap 15.0 / Linux Mint 18.3 / Win 10-64
LO 6.04.2

Mondblatt24
*****
Beiträge: 220
Registriert: So, 14.05.2017 16:11

Re: SUMMEWENN() durchführen und vor dem Summieren noch Sinus() durchführen)

Beitrag von Mondblatt24 » Do, 09.11.2017 08:40

Hallo Helmut,
ja hast recht.

Gruß Peter
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

ramäro
Beiträge: 2
Registriert: Di, 07.11.2017 22:39

Re: SUMMEWENN() durchführen und vor dem Summieren noch Sinus() durchführen)

Beitrag von ramäro » Do, 09.11.2017 18:27

Vielen Dank für die Hilfe. Mit der obigen Formel funktioniert es super!

Antworten