Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

kernm23
***
Beiträge: 94
Registriert: Mi, 16.07.2014 15:54

Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von kernm23 »

ich suche eine Formel die mir die Spalte B im Tabellenblatt 1 ausfüllt mit einem Text aus Tabellenblatt 2, wenn der Eintrag in Spalte A der beiden Tabellen identisch ist. Sollte keine Übereinstimmung vorliegen, soll das Feld in der Spalte B leer bleiben.

Hat jemand einen Tipp?

vgl. das vereinfachte Beispiel im Anhang
Dateianhänge
Formel_fuer_SpalteB_Tab1.ods
(8.19 KiB) 75-mal heruntergeladen

Mondblatt24
******
Beiträge: 567
Registriert: So, 14.05.2017 16:11

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von Mondblatt24 »

Hallo,
da nicht zu erkennen ist ob Du mit AOO oder Libre Office arbeitest, hier zwei Versionen der Formel.
Formel_fuer_SpalteB_Tab1.ods
(12.08 KiB) 78-mal heruntergeladen
und noch eine Formel:

Code: Alles auswählen

=Wennfehler(SVERWEIS(A2;Tabelle2.$A$2:$B$11;2;0);"")
BG Peter
Win.10 (x64) ▪ LO 6.3.6 (x64) ▪ AOO Portable 4.1.6
An den Fragesteller: Wurde die Frage zutreffend beantwortet den Betreff der Eingangsfrage mit [GELÖST] ergänzen. Beschreibung

paljass als Gast

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von paljass als Gast »

...oder - auch für AOO und LO

Code: Alles auswählen

=WENN(ZÄHLENWENN($Tabelle2.$A$2:$A$20;A2);SVERWEIS(A2;$Tabelle2.$A$2:$B$20;2;0);"")
Gruß
paljass

kernm23
***
Beiträge: 94
Registriert: Mi, 16.07.2014 15:54

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von kernm23 »

Ich arbeite mit OpenOffice. Müssen die beiden Tabellen sortiert sein? Wenn ja, beide nach FeldA?

kernm23
***
Beiträge: 94
Registriert: Mi, 16.07.2014 15:54

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von kernm23 »

Verwende AOO 4.1.5.

bisher hat´s mit oben genannten Formeln bei meiner Echt-Tabelle noch nicht geklappt.

kernm23
***
Beiträge: 94
Registriert: Mi, 16.07.2014 15:54

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von kernm23 »

hiermit hat´s jetzt geklappt: =WENN(ZÄHLENWENN($Tabelle2.$A$2:$A$20;A2);SVERWEIS(A2;$Tabelle2.$A$2:$B$20;2;0);"")

wofür steht die 2 und die 0 am Ende im SVERWEIS-Befehl?

datensätze habe ich vorher nicht sortiert. scheint keine Rolle zu spielen, oder?

paljass
******
Beiträge: 735
Registriert: Do, 25.10.2012 07:25

Re: Feld in Tab1 mit Text befüllen aus Tab2 wenn identischer Text in Spalte davor

Beitrag von paljass »

Hi,
wofür steht die 2 und die 0 am Ende im SVERWEIS-Befehl?
datensätze habe ich vorher nicht sortiert. scheint keine Rolle zu spielen, oder?
OO 4.1.5 wird mit Hilfe-Datei ausgeliefert. Hast du da mal reingeguckt?

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

Antworten