#NV

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

davidbk
Beiträge: 1
Registriert: Fr, 06.03.2020 08:40

#NV

Beitrag von davidbk » Fr, 06.03.2020 09:05

Hallo,
ich habe eine Tabelle für die Urlaubsplanung.
In der Spalte B steht das Datum (B13 = 01.01.2020 bis B378 = 31.12.2020)
Unter dem Kalender befindet sich eine Liste [ C387 bis D402 ] mit errechneten Feiertagen.
Die Feiertage werden dann automatisch im Kalender in der Spalte A eingetragen und farblich markiert. Soweit so gut... aber an den Tagen wo kein Feiertag ist wird immer #NV angezeigt. Ich habe schon einiges ausprobiert, aber ohne Erfolg.
Vielleicht kann mir ja jemand helfen.

=WENN(ISTNV(SVERWEIS(B13;$C$387:$D$402;2;0));SVERWEIS(B13;$C$387:$D$402;2;0);SVERWEIS(B13;$C$387:$D$402;2;0))

Gruß David
Dateianhänge
Urlaubskalender.ods
(24.63 KiB) 42-mal heruntergeladen

Stephan
********
Beiträge: 11474
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: #NV

Beitrag von Stephan » Fr, 06.03.2020 09:28

Du brauchst doch nur hinzuschauen was Du geschrieben hast:

=WENN(ISTNV(SVERWEIS(B13;$C$387:$D$402;2;0));SVERWEIS(B13;$C$387:$D$402;2;0);SVERWEIS(B13;$C$387:$D$402;2;0))

der rote, blaue und grüne Ausdruck sind identisch, mithin steht dort:

Wenn eine Formel den Fehler "#NV" erzeugt, benutze trotzdem diese Formel, ansonsten benutze ebenfalls diese Formel.

und was dasrehen sollte ist aber:

Wenn eine Formel den Fehler "#NV" erzeugt, zeige nichts an, ansonsten benutze diese Formel.

nun richtig hinschreiben:

=WENN(ISTNV(SVERWEIS(B13;$C$387:$D$402;2;0));"";SVERWEIS(B13;$C$387:$D$402;2;0))


Gruß
Stephan

Mondblatt24
******
Beiträge: 547
Registriert: So, 14.05.2017 16:11

Re: #NV

Beitrag von Mondblatt24 » Fr, 06.03.2020 09:43

Hallo,
eine andere Variante für Zelle A13 ist:

Code: Alles auswählen

=WENN(ZÄHLENWENN($C$387:$C$401;B13);SVERWEIS(B13;$C$387:$D$401;2;0);"")
Gruß Peter


PS: Die Monsterformel für Ostersonntag (Zelle C390) kannst Du in OpenOffice getrost vergessen, denn hier gibt es die Funktion OSTERSONNTAG().
Win.10 (x64) ▪ LO 6.2.8 (x64) ▪ AOO Portable 4.1.6
Fragen, die zur Zufriedenheit beantwortet wurden, bitte im Betreff des Eröffnungsposts mit dem Zusatz [GELÖST] erweitern. Beschreibung

Antworten