Nullen vor Zahlen löschen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

MarioTripodi
Beiträge: 2
Registriert: Fr, 26.06.2020 18:29

Nullen vor Zahlen löschen

Beitrag von MarioTripodi »

Hallo Leute,

ich brauche ein bisschen Hilfe, Ich habe mehrere Zellen wo Zeichen drinne sind wie zum Beispiel:

EUR07, FRA11, ITA10 Jetzt möchte ich gerne die Nullen vor den Zahlen löschen und nur die. Das suchen klappt ja schon mal.

.0[:digit:]+ hier mit findet das Programm die richtigen Zellen aber wie lösche ich jetzt die 0 Weg ohne das der Rest auch verschwindet?

Danke für die Hilfe.

Gast

Re: Nullen vor Zahlen löschen

Beitrag von Gast »

Servus,

reguläre Ausdrücke in den Optionen freischalten.

Code: Alles auswählen

=WENN(TEIL(A1;SUCHEN("\d";A1;1);1)="0";WECHSELN(A1;0;"";1);A1)

Gast

Hiker
*****
Beiträge: 268
Registriert: Mo, 08.09.2014 21:34
Wohnort: Berlin

Re: Nullen vor Zahlen löschen

Beitrag von Hiker »

MarioTripodi hat geschrieben:
Fr, 26.06.2020 18:38
.0[:digit:]+ hier mit findet das Programm die richtigen Zellen aber wie lösche ich jetzt die 0 Weg ohne das der Rest auch verschwindet?
Hallo,
man kann Klammern verwenden um zu speichern, was gefunden wurde und auf diese bei Ersetzen zurückgreifen, allerdings sollte das Muster dann mit .* anfangen.

Probier mal folgendes
Suchen:
(.*)0([:digit:]+)
Ersetzen:
$1$2

Mfg, Jörn
Libre Office 6.3.1 (Win 10 Pro) / Libre Office 6.0.7 (Win8.1 Pro, Win 7 Pro) / AOO (Win 7)

MarioTripodi
Beiträge: 2
Registriert: Fr, 26.06.2020 18:29

Re: Nullen vor Zahlen löschen

Beitrag von MarioTripodi »

Hallo Jörn,

perfekt funktioniert danke dir. Da muss ich noch einiges Basteln bis ich da den Durchblick habe :-)

Gruß Mario

Antworten