"Bedingtes" Zählen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

juhge
*
Beiträge: 11
Registriert: Mo, 09.05.2011 13:41

"Bedingtes" Zählen

Beitrag von juhge » So, 08.10.2017 14:08

Hallo,
ich verzweifle gerade an einer wahrscheinlich recht einfachen Aufgabe.

Ich möchte aus einem Dienstplan mit Tag-/ Spät-/ Nachtdiensten für jeden Mitarbeiter einzeln die Dienste zählen. Für die Spätdienste kein Problem =ZÄHLENWENN(C4:C33;"Mitarbeiter1").. Ich möchte jedoch die Nachtdienste aufteilen in Dienste von Mo bis Do und Fr bis So.

Meine bisherigen Versuche mit Vorlagen aus dem Forum sind bisher immer gescheitert, daher benötige ich Hilfe.
Mein letzter Versuch war: =ZÄHLENWENN(UND(D4:D33;"Mitarbeiter1";B4:B33;WENN(WOCHENTAG(B4;2)>5)) für das bekomme ich aber Fehler 520

Der Aufbau ist folgendermaßen:
| A | B | C | D | E
|Datum|Wochentag|Spätdienst|Nachtdienst|Wochenenddienst Tag|
|1.11. | Mi | |Mitarbeiter1| Mitarbeiter2 |
usw...

Vielen Dank für eure Hilfe..

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: "Bedingtes" Zählen

Beitrag von echo » So, 08.10.2017 17:29

Mein letzter Versuch war: =ZÄHLENWENN(UND(D4:D33;"Mitarbeiter1";B4:B33;WENN(WOCHENTAG(B4;2)>5)) für das bekomme ich aber Fehler 520
Hallo, versuche es mal so:
=SUMMENPRODUKT((D4:D33="Mitarbeiter1")*(WOCHENTAG(B4:B33;2)<5))
für Mo-Do
=SUMMENPRODUKT((D4:D33="Mitarbeiter1")*(WOCHENTAG(B4:B33;2)>=5))
für Fr.-So

Beachte das Wochentag() ein Datum auswertet.
in Spalte B darf daher nicht "Mi" als Text stehen, sondern es bedarf dort eins gültigen Datums. (Zellformat TTT)
Alternativ Spalte A verwenden.

Gruß Holger
Zuletzt geändert von echo am So, 08.10.2017 17:46, insgesamt 1-mal geändert.

Mondblatt24
****
Beiträge: 119
Registriert: So, 14.05.2017 16:11

Re: "Bedingtes" Zählen

Beitrag von Mondblatt24 » So, 08.10.2017 17:36

Hallo,
Summenprodukt() hilft Dir weiter.

Gruß Peter
Dateianhänge
Nachtschicht.ods
(13.64 KiB) 16-mal heruntergeladen
LO 5.3.6; LO 5.4.1; LO 5.4.2 Portable; AOO Portable 4.1.4

juhge
*
Beiträge: 11
Registriert: Mo, 09.05.2011 13:41

Re: "Bedingtes" Zählen

Beitrag von juhge » So, 08.10.2017 22:54

Super vielen Dank. Es lag damit nur am WOCHENTAG, bei dem ich eben von den Namen ausging und nicht vom Datum...

Wochenende gerettet...

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 15 Gäste