2 Formeln zu einer verbinden

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Forscher
*
Beiträge: 14
Registriert: So, 14.05.2017 11:28

2 Formeln zu einer verbinden

Beitrag von Forscher » So, 08.10.2017 18:21

Hallo
Bekommt man es hin, diese beiden Formeln so zusammenzufügen das zuerst Nr2 und wenn nichts zutrifft dann Nr1 sonst nichts in der zelle steht?
Einzeln funktionieren die Formeln wunderbar und wenn beides zutrifft das wäre die hohe Kunst es anzuzeigen Natürlich mit Farbe

Bitte kein Makro ,möchte es nachvollziehen können ,

Nr1 =WENN(ISTFEHLER(SVERWEIS(A4;$Feiertage1.$A$3:$B$22;2;FALSCH()));"";SVERWEIS(A4;$Feiertage1.$A$3:$B$22;2;FALSCH()))



Nr2 =WENN($Januar.G7="";"";"44")

Danke

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: 2 Formeln zu einer verbinden

Beitrag von echo » So, 08.10.2017 18:43

Hallo
wenn ich das richtig verstanden habe und die einzeln Formeln funktionieren, so kannst du doch in der 2.Formel das "" (NICHTS) durch die erste Formel ersetzen:

=WENN($Januar.G7="";"";"44")

=WENN($Januar.G7="";WENN(ISTFEHLER(SVERWEIS(A4;$Feiertage1.$A$3:$B$22;2;FALSCH()));"";SVERWEIS(A4;$Feiertage1.$A$3:$B$22;2;FALSCH()));"44")

PS
Soll umgekehrt zuerst der SVerweis() versucht werden ersetzt du dort "" durch die zweite Formel
=WENN(ISTFEHLER(SVERWEIS(A4;$Feiertage1.$A$3:$B$22;2;FALSCH()));WENN($Januar.G7="";"";"44");SVERWEIS(A4;$Feiertage1.$A$3:$B$22;2;FALSCH()))



Gruß Holger

Gast

Re: 2 Formeln zu einer verbinden

Beitrag von Gast » So, 08.10.2017 20:04

Hallo nochmal
Also grundsätzlich funktionieren die Varianten mit dem Ergebnis- "44"
aber am 1.1.2017 müsste Neujahr stehen

und genau das hab ich nicht hinbekommen ,
und kann ich über die bedingte Formati. in der Ergebnis Variante "Neujahr" Farbe ins Ergebnis bringen

Hab bis jetzt
Formel ist =>SUMMENPRODUKT(ZÄHLENWENN(INDIREKT("'"&{"Vorgabe. B18:B37"}&"'!E4");""))

Mondblatt24
****
Beiträge: 119
Registriert: So, 14.05.2017 16:11

Re: 2 Formeln zu einer verbinden

Beitrag von Mondblatt24 » Mo, 09.10.2017 10:52

Hallo,
kannst Du eine Beispieldatei zur Verfügung stellen?
Alles andere ist nur Spekulation,

Gruß Peter

PS.:
=>SUMMENPRODUKT(ZÄHLENWENN(INDIREKT("'"&{"Vorgabe. B18:B37"}&"'!E4");""))
Diese Formel kannst Du in EXCEL benutzen, aber nicht in OpenOfficeCalc oder LibreOfficeCalc.
LO 5.3.6; LO 5.4.2; LO 5.4.2 Portable; AOO Portable 4.1.4

Forscher
*
Beiträge: 14
Registriert: So, 14.05.2017 11:28

Re: 2 Formeln zu einer verbinden

Beitrag von Forscher » Di, 10.10.2017 16:46

Hallo Peter
z.B.
A B C
Tag Datum Kilometer
So 01.01.17 44 <== hier müßte Neujahr erscheinen ,aber es erscheint 44,
Mo 02.01.17 44
Di 03.01.17 44
Mi 04.01.17 44
Do 05.01.17 44
Fr 06.01.17 44
Sa 07.01.17
So 08.01.17
wie gesagt einzeln funktionieren die Formeln ,möchte vermeiden noch eine zusätzliche Spalte zuhaben
Spalte A und B Tag Datum , Spalte C ist das Problem

Gruß und Danke

Benutzeravatar
lorbass
********
Beiträge: 4013
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: 2 Formeln zu einer verbinden

Beitrag von lorbass » Di, 10.10.2017 18:42

Mondblatt24 hat geschrieben:
Mo, 09.10.2017 10:52
kannst Du eine Beispieldatei zur Verfügung stellen?
@Forscher, warum folgst du Mondblatt24's Bitte nicht? Nur anhand einer von DIR erstellten Beispieldatei können wir erkennen, was bei dir falsch läuft!

Gruß
lorbass

Forscher
*
Beiträge: 14
Registriert: So, 14.05.2017 11:28

Re: 2 Formeln zu einer verbinden

Beitrag von Forscher » Do, 12.10.2017 11:39

Hallo Nochmal
Hab mein Problem Gelöst ,Hatte nicht richtig die Formel Angepasst

Danke Euch

Mondblatt24
****
Beiträge: 119
Registriert: So, 14.05.2017 16:11

Re: 2 Formeln zu einer verbinden

Beitrag von Mondblatt24 » Do, 12.10.2017 12:58

Hallo Forscher,
wäre schön zu erfahren wie deine Lösung aussieht.

Gruß Peter
LO 5.3.6; LO 5.4.2; LO 5.4.2 Portable; AOO Portable 4.1.4

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste