Mittelwertermittlung mit Bedingungen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

jacopo2017

Mittelwertermittlung mit Bedingungen

Beitrag von jacopo2017 » Di, 19.12.2017 21:36

Ich habe aktuell das Problem, dass ich aus einer Spalte mit Beispielsweise 12 Zeilen zwei Mittelwerte errechnen möchte.
Mittelwert 1 soll bestehen aus den Zellen 5-10
Mittelwert 2 soll bestehen aus den Zellen 1-4, sowie 11-12.
Jeder der beiden Mittelwerte soll aus allen Zellen gebildet werden, deren Inhalt <>0 ist.

Eigentlich nicht schwierig, dachte ich, ein vernünftiges Ergebnis bekomme ich jedoch nicht, sondern einen Error. Ich habe Summenfunktionen in Verbindung mit Zählenwenn versucht, stehe da aber jedes Mal vor dem Problem, dass ich bei der Formel für Mittelwert 2 die Zellen 5-10 nicht aus der Berechnung ausgeklammert bekomme.

Helmut_S
**
Beiträge: 38
Registriert: So, 29.10.2017 11:29

Re: Mittelwertermittlung mit Bedingungen

Beitrag von Helmut_S » Mi, 20.12.2017 08:55

Hallo Jacopo, schau dir die angehängte Tabelle an, wenn ich dich nicht falsch verstanden habe, müsste das mit den Funktionen Mittelwert() und Mittelwertwenn() zu lösen sein.
Mittelwertwenn.ods
(8.81 KiB) 47-mal heruntergeladen
Gruß, Helmut
openSUSE Leap 15.0 / Linux Mint 18.3 / Win 10-64
LO 6.04.2

Benutzeravatar
jacopo
Beiträge: 3
Registriert: Di, 19.12.2017 21:26

Re: Mittelwertermittlung mit Bedingungen

Beitrag von jacopo » Mi, 20.12.2017 20:20

Hallo Helmut,

vielen Dank für deine Hilfe. Ich antworte jetzt mal mit richtigem Log-In und so, gestern lief irgendwas schief. Ich habe das Gefühl, ich schau jetzt öfter rein, also...

Was du vorbereitet hast, geht in die richtige Richtung. Die Funktion für MW 5-10 funktioniert. Die andere noch nicht ganz, ich sehe den Fehler allerdings nicht. Wenn man mit den Zahlen spielt und nachrechnet, kommt man zu anderen Ergebnissen. Darüber hinaus gibt es einen #DIV/0, wenn die letzten beiden Zellen 0 sind.
Nur um auszuschließen, dass ich mich missverständlich ausgedrückt habe, beschreibe ich nochmal das verbliebene Problem:
Aus den Zellen 1-4, sowie 11-12 soll ein gemeinsamer Mittelwert gebildet werden. Da diese Zellen sich erst nach und nach füllen (die Zellen stellen Monate dar), soll der Mittelwert nur aus Zellen gebildet werden, die bereits gefüllt sind (<>0). Ist der Wert von 1-4 jeweils 2 und 11 & 12 sind leer, sollte der Mittelwert also 2 sein.

Gruß,
jacopo
#StrgKaltEntf

Helmut_S
**
Beiträge: 38
Registriert: So, 29.10.2017 11:29

Re: Mittelwertermittlung mit Bedingungen

Beitrag von Helmut_S » Mi, 20.12.2017 22:06

Hallo Jacopo, dann versuche es mal mit dieser überarbeiteten Tabelle.
Hier muss nur mehr mind. 1 Wert vorhanden sein damit es nicht Div/0- Fehler gibt.
Mittelwert02.ods
(9.06 KiB) 50-mal heruntergeladen
Gruß Helmut
openSUSE Leap 15.0 / Linux Mint 18.3 / Win 10-64
LO 6.04.2

Benutzeravatar
jacopo
Beiträge: 3
Registriert: Di, 19.12.2017 21:26

Re: Mittelwertermittlung mit Bedingungen

Beitrag von jacopo » Fr, 22.12.2017 21:07

Das scheint zu funktionieren!
Bisher bekomme ich die Ergebnisse, die ich haben wollte. Ich habe das jetzt noch so umgebaut, dass bei fehlenden Werten 0 statt eines Fehlers gezeigt wird und bin aktuell sehr zufrieden.

Code: Alles auswählen

=WENN(A1>0;(SUMME(A1:A4;A11:A12))/(SUMME(ZÄHLENWENN(A1:A4;"<>0");ZÄHLENWENN(A11:A12;"<>0")));0)
Danke!
#StrgKaltEntf

Mondblatt24
*****
Beiträge: 216
Registriert: So, 14.05.2017 16:11

Re: Mittelwertermittlung mit Bedingungen

Beitrag von Mondblatt24 » Sa, 23.12.2017 09:56

Hallo,
Ich habe das jetzt noch so umgebaut, dass bei fehlenden Werten 0 statt eines Fehlers gezeigt wird und bin aktuell sehr zufrieden.

Code: Alles auswählen

CODE: ALLES AUSWÄHLEN
=WENN(A1>0;(SUMME(A1:A4;A11:A12))/(SUMME(ZÄHLENWENN(A1:A4;"<>0");ZÄHLENWENN(A11:A12;"<>0")));0)
Schön und Gut. Aber was machst Du, wenn A1 keine Werte enthält die anderen Zellen aber schon?

Besser wäre z.B.:

Code: Alles auswählen

WENN(ISTFEHLER(SUMME(A1:A4;A11:A12)/(SUMME(ZÄHLENWENN(A1:A4;"<>0");ZÄHLENWENN(A11:A12;"<>0"))));0;SUMME(A1:A4;A11:A12)/(SUMME(ZÄHLENWENN(A1:A4;"<>0");ZÄHLENWENN(A11:A12;"<>0"))))
Frohes Fest
Peter.
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Benutzeravatar
jacopo
Beiträge: 3
Registriert: Di, 19.12.2017 21:26

Re: Mittelwertermittlung mit Bedingungen

Beitrag von jacopo » Sa, 23.12.2017 10:20

Hm, ich verstehe, was du meinst. Da hast du recht.
Ich habe das ausprobiert, es ergibt aber in der Form auch keinen Sinn für mich, da die Werte von oben beginnend aufeinander aufbauen. Der erste wird mithilfe eines Wertes aus einem anderen Blatt ermittelt, wenn er also fehlt, dann wird das Ergebnis in jedem Fall unplausibel. Falls es dazu käme, müsste ich - so wie ich das sehe - die Formel, der dann die Aufgabe zufiele, "alles in Gang zu setzen" von Hand anpassen.
#StrgKaltEntf

Antworten