Formatierung in Tabelle - bleibt nicht!

Das Textverarbeitungsprogramm

Moderator: Moderatoren

Cheryll
***
Beiträge: 51
Registriert: Fr, 09.08.2019 11:52

Formatierung in Tabelle - bleibt nicht!

Beitrag von Cheryll » Mo, 12.08.2019 17:29

Ich habe eine Tabelle, die ich formatiert habe mit der Tabellen-Vorlage Academic.
So weit, so fein.

Jetzt ist es so, dass die Tabelle über fast 50 Seiten geht und ich darin "nichts finde".
Also habe ich eine Formatvorlage aus Überschrift 2 und Überschrift 3 abgeleitet.
Diese dienen mir jetzt als Blickfang für einzelne Markierungen in der Tabelle und lassen sich auch prima aus dem Navigator heraus anspringen.
So weit, so fein.

Mein Problem:
Diese beiden Überschriften sind fett, was mich freut.
Jedoch sobald ich "nicht hinsehe", wird diese Fett-Formatierung meiner Überschriften innerhalb der Tabelle wieder aufr Standard-Normalschrift angepasst, also nicht fett.

Was kann ich tun, damit die Sonderformatierungen innerhalb meiner Tabelle erhalten bleiben?
Danke für Tipps.

Cheryll

Stephan
********
Beiträge: 11170
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Stephan » Mo, 12.08.2019 18:35

Ich weiß nicht was da schiefläuft. So wie Du Dein Vorgehen beschreibst ist das richtig und es sollte wie gewünscht funktionieren.

Kannst Du eine Beispieldatei zur Verfügung stellen?



Gruß
Stephan

Cheryll
***
Beiträge: 51
Registriert: Fr, 09.08.2019 11:52

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Cheryll » Mo, 12.08.2019 19:00

jetzt wird es spooky!
Was diesmal "futsch" ist, ist nicht die Formatierung, sondern der Inhalt.

Ich tat dies:
- ich kopierte den obersten Teil meiner Tabelle aus dem sehr umfangreichen Dokument in ein neues Dokument
- ich formatierte willkürlich jene Zelle, in der Du den Cursor stehen siehst mit "Überschrift 2 ohne Nummer"
- ich nahm einen Screenshot davon
- ich speicherte die Datei ab
- ich öffnete sie wieder
=> diesmal fehlte nicht die fett-Formatierung von Überschrift-2-ohne-Nummer, sondern die Inhalt der Zellen.
Diese Inhalte haben keinerlei Besonderheiten. Sind eine reine Text-Eingabe, also keine Links oder Querverweise oder so.

Was Du sehen wirst, wissen die binären Götter.
Daher lade ich einen Screenshot der verschwundenen-Zellen-Ansicht ebenfalls hoch.

quotsi
*****
Beiträge: 347
Registriert: Do, 14.11.2013 10:04

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von quotsi » Mo, 12.08.2019 19:17

Also, wie sehen gar nichts.
Zuerst Angaben: welches BS, welcche Office, welche Version.
Dann ein Beispieldokument, dass diesen Fehler aufweist.
(Erst dann die Schilderungen, die wir bekommen haben...)

Wieso formatierst du eigentliche innerhalb der Zelle mit Überschriftxxx ? Warum gibst du deinen veränderten Formatierungen keinen eigenen Namen wie z.B. Kopfzeile fett, Tabelleninhalt, usw.?
win7prof - Avira - LO 6.2.7.1 (x64) - AOO 4.1.5
Problem gelöst? Dann bitte im Betreff der ersten Nachricht [gelöst] voranstellen.

Cheryll
***
Beiträge: 51
Registriert: Fr, 09.08.2019 11:52

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Cheryll » Mi, 14.08.2019 10:57

ich versuche seit 3 Tagen, die Dateien hochzulagen, doch lese stets "Server antwortet nicht, Timeout"
Die Dateien sind nur einige KB groß. Ich probiere es weiter.

Cheryll
***
Beiträge: 51
Registriert: Fr, 09.08.2019 11:52

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Cheryll » Mi, 14.08.2019 10:59

das ist die Beispieldate.
Diesmal werden gleich die Inhalte abgeschossen nach dem Speichern. Wegen der Upload Probleme lade ich die Screenshots nach.

Cheryll
***
Beiträge: 51
Registriert: Fr, 09.08.2019 11:52

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Cheryll » Mi, 14.08.2019 11:00

Screenshots vor dem Speichern und nach dem neu-Öffnen.
Diesmal ist nicht die Formatierung anders, sondern der Inhalt (ich kopierte den oberen Teil meiner Problemtabelle in eine neue Datei).
Dateianhänge
Tabellenformatierung_2.PNG
Tabellenformatierung_2.PNG (79.15 KiB) 1107 mal betrachtet
Tabellenformatierung.PNG
Tabellenformatierung.PNG (64.63 KiB) 1107 mal betrachtet

Benutzeravatar
miesepeter
*******
Beiträge: 1705
Registriert: Sa, 10.05.2008 15:05
Wohnort: Bayern

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von miesepeter » Mi, 14.08.2019 13:09

@Cheryll:
Man bat dich doch mehrmals um Uploads. Wenn's hier im Forum nicht geht, so gibt's doch etliche Uploader, die kostenlos sind; oder du hast einen E-Mail-Provider, bei dem du Dateien/Ordner für bestimmte Zeit freigeben kannst. Ist das so schwierig?
Dass deine Datei Probleme hat, ist schon klar, aber ohne Beispieldatei kann man vermutlich nicht mehr schreiben, als in den vorigen Beiträgen schon aufgeführt wurde...
Ciao

Cheryll
***
Beiträge: 51
Registriert: Fr, 09.08.2019 11:52

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Cheryll » Mi, 14.08.2019 16:10

die Datei sehe ich nicht hier, ich probiere noch einmal ein Upload.

So, jetzt ist sie hier.
Also die Beispieldatei ist ein Auszug aus der Problemdatei und sie hat das Problem in anderer Form auch.
Die Screenshots zeigen sie vor dem Speichern und nach dem Wieder-Öffnen, wo Zellinhalte verändert wurden. Keine Formatierung diesmals, sondern gleich die Info gelöscht :shock:
Dateianhänge
Beispieldatei.odt
(14.7 KiB) 31-mal heruntergeladen

Benutzeravatar
miesepeter
*******
Beiträge: 1705
Registriert: Sa, 10.05.2008 15:05
Wohnort: Bayern

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von miesepeter » Do, 15.08.2019 07:35

Also ich kann erst einmal keine Probleme in deiner Datei erkennen. Wenn ich die Inhalte ändere, speichere, schließe und wieder öffne sind die geänderten Inhalte nicht zurückgesetzt.

Gast Peter

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Gast Peter » Do, 15.08.2019 10:15

Guten Morgen Cheryll.
Bei mir sieht die Datei aus, wie in deinem Sreenshot "Tabellenformatierung_2.PNG".
Der Text in den rechten Spalten fehlt, es stehen Nullen an der Stelle.

Eine Erklärung dafür habe ich nicht gefunden, vermute aber, dass die Datei oder Teile daraus aus MS-Office importiert wurden (?).
Vor allem Konvertierungen aus dem MS docx bzw. allgemein aus MS .---x Formaten bereiten noch viele Probleme.
Womöglich hat LO beim Speichern etwas verhauen.

Jedenfalls klappte Öffnen der Datei in einem "Microsoft-Office-docx Versteher Programm" und anschließendes Speichern als odt.
Hier findest Du die korrigierte Datei http://www.imagenetz.de/f075a98ad/Tabel ... e.odt.html
Probier mal, ob die jetzt bei dir richtig angezeigt wird.

Eddy
********
Beiträge: 2615
Registriert: So, 02.10.2005 10:14

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Eddy » Do, 15.08.2019 10:22

Hallo Cheryll,

in Deiner Datei ist ein Fehler. Bei mir hat sie 158 Wörter und 835 Zeichen. Das stimmt offensichtlich nicht. Wenn ich die Tabelle in ein neues Dokument kopiere hat das 32 Wörter und 119 Zeichen. Unter Datei > Eigenschaften zeigen sich weitere Unterschiede. Das ist zumindest für mich seltsam.

In Deiner Beispieldatei sind (rechts) Nullen - statt des Textes. Warum der vermutlich vorhandene Text nicht angezeigt wird, kann ich, zumindest auf die Schnelle, nicht sagen.

Eddy

Gast

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Gast » Do, 15.08.2019 12:22

Guten Tag Eddy.
Eddy hat geschrieben:
Do, 15.08.2019 10:22
Bei mir hat sie 158 Wörter und 835 Zeichen. Das stimmt offensichtlich nicht. Wenn ich die Tabelle in ein neues Dokument kopiere hat das 32 Wörter und 119 Zeichen.
Doch, das passt schon.
Der Text ist grundsätzlich noch vorhanden, wird nur nicht angezeigt. Wenn du in die "content.xml" Datei im odt Archiv schaust, ist der Text noch drin. Und das sind 158 Wörter.

Der angezeigte Text mit den Nullen entspricht jedoch nur 32 Wörtern (eine Null zählt jeweils als Wort).

Wenn Du das jetzt markierst und in eine neue Datei kopierst, wird nur das, was Du auch siehst übernommen - also quasi kopiert wie gesehen. Der "versteckte" Text aus der Originaldatei ist folglich nach dem Speichern der neuen Datei nicht in deren "content.xml" vorhanden.

quotsi
*****
Beiträge: 347
Registriert: Do, 14.11.2013 10:04

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von quotsi » Do, 15.08.2019 12:26

Eddy hat geschrieben:
Do, 15.08.2019 10:22
in Deiner Datei ist ein Fehler. Bei mir hat sie 158 Wörter und 835 Zeichen. Das stimmt offensichtlich nicht. Wenn ich die Tabelle in ein neues Dokument kopiere hat das 32 Wörter und 119 Zeichen. Unter Datei > Eigenschaften zeigen sich weitere Unterschiede. Das ist zumindest für mich seltsam.
Ich habe das Beispiel ebenfalls mit LO geladen und es sieht so aus, wie Eddy es beschrieb: 158 W / 835 Z und Nullen rechts.
Zu diesem Zeitpunkt ist das Dokument im temporären Speicher. Also sichern unter ... , um überhaupt was damit anfangen zu können und schon tritt das von Eddy beschriebene Phänomen auf. Man braucht also nix kopieren, sondern nur Sichern unter ...
win7prof - Avira - LO 6.2.7.1 (x64) - AOO 4.1.5
Problem gelöst? Dann bitte im Betreff der ersten Nachricht [gelöst] voranstellen.

Cheryll
***
Beiträge: 51
Registriert: Fr, 09.08.2019 11:52

Re: Formatierung in Tabelle - bleibt nicht!

Beitrag von Cheryll » Do, 15.08.2019 12:34

Ganz lieben Dank an Peter und auch an Eddy und Gast!
Mir fällt einmal ein Stein vom Herzen, dass der Text nicht verloren geht. Euch mag er völlig unverständlich sein, doch hinter den Kürzeln steht richtig viel Arbeit! :idea:

Die gute Nachricht ist: Ja, die von Peter (danke!) hochgeladene Datei enthält wieder meinen Text.

Offen bleibt: Wie und warum wurde er verborgen?
Ich glaube nicht, dass ich das Dokument einmal aus Word übernommen habe. Die konkrete Tabelle auf gar keinen Fall. Möglicherweise habe ich eine Formatierung aus einer ehemaligen Word-Tabelle importiert. Diese Dateien sind sehr alt und haben eine lange Bearbeitungsgeschichte. Bin schon vor Jahren auf odt umgestiegen und versuchte, alle Word-Elemente zu löschen.

Die Kernfrage bleibt:
Warum wird meine Formatierung oder auch die Anzeige "zurückgesetzt"?
Gibt es einen Weg, für eine Tabelle zu sagen "alle direkten Formatierungen löschen?
Ob das damit zu tun hat, weiß ich nicht: Die Funktion "Tabelle in Text umwandeln" tut bei mir einfach nichts, so lange mehr als eine Zelle da ist.

Ich bräuchte eine Art "reset" für diese Tabellenformatierung und danach wieder die Sache mit den Formatierungen, die ich extratourlich brauche (das ist eben die Gliederungsebene für die Navigator-Anzeige in der Mammut-Tabelle und den Fettdruck fürs optische Zurechtfinden).

Antworten