[gelöst] laufender Durchschnitt pro Zeile von unten nach oben

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Calcomania
Beiträge: 5
Registriert: Di, 04.04.2023 23:28

[gelöst] laufender Durchschnitt pro Zeile von unten nach oben

Beitrag von Calcomania »

Hallo Leute,

Gegeben:

Die Spalte A sind gegebene Werte.

A___B

5
7
3
2
6
1
3





Gesucht:

In Spalte B soll der "Laufende Durchschnitt" gemäß dem folgenden Beispiel unter Gesucht.
D.h in Spalte B sind die Durchschnittswerte aus Spalte A, aber in folgender Weise:
wie an der Rechnung unter Bemerkung zu erkennen ist, ergibt sich der Durchschnittswert in der untersten Zeile aus dem Wert in A geteilt durch 1.
In der zweiten Zeile von unten ergibt sich der Durchschnitt aus dem aktuellen Wert aus A, also "1" plus dem darunterliegenden Wert "3", zusammen 4 geteilt durch 2, Ergebnis 2.
In der dritten Zeile von unter ergibt sich der laufende Durchschnittswert in Spalte B aus der Summe des aktuellen Wertes aus Spalte A plus den darunterliegenden Werten, also 3+1+6, geteilt durch 3, weil es 3 Summanden sind.
usw:)
Ziel ist es letzten Endes nicht jeden Wert in Spalte B manuell über Mittelwert berechnen lassen zu müssen.


A___B____________'Bemerkung

5____3,85_________'...
7____3,66_________'...
3____3____________'weil (3+1+6+2+3) / 5 = 3
2____3____________' weil (3+1+6+2) /4 = 3
6____3,33_________' weil (3+1+6) / 3 = 3,33
1____2____________' weil (3+1) /2 = 2
3____3____________' weil (3) /1 = 3



hat dafür jmd eine Lösung?

Gruß Calco
Zuletzt geändert von Calcomania am Mo, 12.02.2024 10:36, insgesamt 1-mal geändert.
Karolus
********
Beiträge: 7426
Registriert: Mo, 02.01.2006 19:48

Re: laufender Durchschnitt pro Zeile von unten nach oben

Beitrag von Karolus »

Hallo
starte ganz unten (z.B. in B100) mit:

Code: Alles auswählen

=MITTELWERT(A$100:A100)
und zieh die Formel nach oben.
LO7.4.7.2 debian 12(bookworm) auf Raspberry4b 8GB (64bit)
LO7.6.2.1 flatpak debian 12(bookworm) auf Raspberry4b 8GB (64bit)
Calcomania
Beiträge: 5
Registriert: Di, 04.04.2023 23:28

Re: laufender Durchschnitt pro Zeile von unten nach oben

Beitrag von Calcomania »

ich denke mit dem was du im kopf hast kannst du reich werden, danke!
Karolus
********
Beiträge: 7426
Registriert: Mo, 02.01.2006 19:48

Re: laufender Durchschnitt pro Zeile von unten nach oben

Beitrag von Karolus »

Calcomania hat geschrieben: Mo, 12.02.2024 10:35 ich denke mit dem was du im kopf hast kannst du reich werden, danke!
möchtest du etwa meine Konntonummer :lol:
LO7.4.7.2 debian 12(bookworm) auf Raspberry4b 8GB (64bit)
LO7.6.2.1 flatpak debian 12(bookworm) auf Raspberry4b 8GB (64bit)
Antworten